aboutsummaryrefslogtreecommitdiff
path: root/audio/gmpc-discogs/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-09-25 18:02:55 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-09-25 18:02:55 +0000
commited932ea7171569e84e611e73590d60c53389eb89 (patch)
tree453b068c9819019ed2ba4bf488933baeee914102 /audio/gmpc-discogs/Makefile
parentb744bb55d8650c8d3f2507f74e384cb205f00941 (diff)
downloadports-ed932ea7171569e84e611e73590d60c53389eb89.tar.gz
ports-ed932ea7171569e84e611e73590d60c53389eb89.zip
Notes
Diffstat (limited to 'audio/gmpc-discogs/Makefile')
-rw-r--r--audio/gmpc-discogs/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/audio/gmpc-discogs/Makefile b/audio/gmpc-discogs/Makefile
new file mode 100644
index 000000000000..1225f151b9df
--- /dev/null
+++ b/audio/gmpc-discogs/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gmpc-discogs
+# Date created: September 14 2007
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmpc-discogs
+PORTVERSION= 0.19.0
+CATEGORIES= audio
+MASTER_SITES= http://download.sarine.nl/Programs/gmpc/${PORTVERSION}/ \
+ http://freebsd.unixfreunde.de/sources/
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Album Image fetcher for gmpc
+
+LIB_DEPENDS= mpd:${PORTSDIR}/audio/libmpd \
+ curl.5:${PORTSDIR}/ftp/curl
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gmpc.pc:${PORTSDIR}/audio/gmpc
+RUN_DEPENDS= gmpc:${PORTSDIR}/audio/gmpc
+
+GNU_CONFIGURE= yes
+USE_XORG= x11
+USE_GMAKE= yes
+USE_GNOME= gnomehack intltool
+USE_LDCONFIG= yes
+USE_GETTEXT= yes
+
+.include <bsd.port.mk>