aboutsummaryrefslogtreecommitdiff
path: root/audio/gmpc-lyrics/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-09-16 09:17:50 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-09-16 09:17:50 +0000
commit47feb5cddf0572f25743fa3a409ad6e81736b782 (patch)
treea404f90c4e520841cb5ce39799b0b99bd2bcee6d /audio/gmpc-lyrics/Makefile
parent63f7723ef47308ff53c59716cb4d029b8eb0177b (diff)
downloadports-47feb5cddf0572f25743fa3a409ad6e81736b782.tar.gz
ports-47feb5cddf0572f25743fa3a409ad6e81736b782.zip
Notes
Diffstat (limited to 'audio/gmpc-lyrics/Makefile')
-rw-r--r--audio/gmpc-lyrics/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/audio/gmpc-lyrics/Makefile b/audio/gmpc-lyrics/Makefile
new file mode 100644
index 000000000000..2bb28666f1de
--- /dev/null
+++ b/audio/gmpc-lyrics/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: gmpc-lyrics
+# Date created: September 14 2007
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmpc-lyrics
+PORTVERSION= 0.15.0
+CATEGORIES= audio
+MASTER_SITES= http://download.sarine.nl/gmpc-${PORTVERSION}/plugins/
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= A Lyrics Provider plugin for gmpc
+
+LIB_DEPENDS= mpd:${PORTSDIR}/audio/libmpd \
+ curl.4:${PORTSDIR}/ftp/curl
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gmpc.pc:${PORTSDIR}/audio/gmpc
+RUN_DEPEND= gmpc:${PORTSDIR}/audio/gmpc
+
+GNU_CONFIGURE= yes
+USE_XLIB= yes
+USE_GNOME= gnomehack
+
+.include <bsd.port.mk>