aboutsummaryrefslogtreecommitdiff
path: root/audio/gmpc-magnatune/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-09-16 09:14:37 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-09-16 09:14:37 +0000
commit554e98c31452a944dfe667cbec43904227903e87 (patch)
tree605cb8d706501b1fdaac833a3032c97f15e9c476 /audio/gmpc-magnatune/Makefile
parent083b8cee6b0524cf20913ac1bf7406fdbd5fde4b (diff)
downloadports-554e98c31452a944dfe667cbec43904227903e87.tar.gz
ports-554e98c31452a944dfe667cbec43904227903e87.zip
Notes
Diffstat (limited to 'audio/gmpc-magnatune/Makefile')
-rw-r--r--audio/gmpc-magnatune/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/audio/gmpc-magnatune/Makefile b/audio/gmpc-magnatune/Makefile
new file mode 100644
index 000000000000..3b3bf3bd8e4c
--- /dev/null
+++ b/audio/gmpc-magnatune/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: gmpc-magnatune
+# Date created: September 14 2007
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmpc-magnatune
+PORTVERSION= 0.15.0
+CATEGORIES= audio
+MASTER_SITES= http://download.sarine.nl/gmpc-${PORTVERSION}/plugins/
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= A Autoplaylist plugin for gmpc
+
+LIB_DEPENDS= mpd:${PORTSDIR}/audio/libmpd \
+ curl.4:${PORTSDIR}/ftp/curl
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gmpc.pc:${PORTSDIR}/audio/gmpc
+RUN_DEPEND= gmpc:${PORTSDIR}/audio/gmpc
+
+GNU_CONFIGURE= yes
+USE_XLIB= yes
+USE_GNOME= gnomehack
+
+.include <bsd.port.mk>