aboutsummaryrefslogtreecommitdiff
path: root/audio/gmpc-magnatune
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-09-16 09:14:37 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-09-16 09:14:37 +0000
commit554e98c31452a944dfe667cbec43904227903e87 (patch)
tree605cb8d706501b1fdaac833a3032c97f15e9c476 /audio/gmpc-magnatune
parent083b8cee6b0524cf20913ac1bf7406fdbd5fde4b (diff)
downloadports-554e98c31452a944dfe667cbec43904227903e87.tar.gz
ports-554e98c31452a944dfe667cbec43904227903e87.zip
Notes
Diffstat (limited to 'audio/gmpc-magnatune')
-rw-r--r--audio/gmpc-magnatune/Makefile25
-rw-r--r--audio/gmpc-magnatune/distinfo3
-rw-r--r--audio/gmpc-magnatune/pkg-descr6
-rw-r--r--audio/gmpc-magnatune/pkg-plist6
4 files changed, 40 insertions, 0 deletions
diff --git a/audio/gmpc-magnatune/Makefile b/audio/gmpc-magnatune/Makefile
new file mode 100644
index 000000000000..3b3bf3bd8e4c
--- /dev/null
+++ b/audio/gmpc-magnatune/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: gmpc-magnatune
+# Date created: September 14 2007
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmpc-magnatune
+PORTVERSION= 0.15.0
+CATEGORIES= audio
+MASTER_SITES= http://download.sarine.nl/gmpc-${PORTVERSION}/plugins/
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= A Autoplaylist plugin for gmpc
+
+LIB_DEPENDS= mpd:${PORTSDIR}/audio/libmpd \
+ curl.4:${PORTSDIR}/ftp/curl
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gmpc.pc:${PORTSDIR}/audio/gmpc
+RUN_DEPEND= gmpc:${PORTSDIR}/audio/gmpc
+
+GNU_CONFIGURE= yes
+USE_XLIB= yes
+USE_GNOME= gnomehack
+
+.include <bsd.port.mk>
diff --git a/audio/gmpc-magnatune/distinfo b/audio/gmpc-magnatune/distinfo
new file mode 100644
index 000000000000..569cdeda809b
--- /dev/null
+++ b/audio/gmpc-magnatune/distinfo
@@ -0,0 +1,3 @@
+MD5 (gmpc-magnatune-0.15.0.tar.gz) = 2a310e9fe95e83a66027954bc2cf94ff
+SHA256 (gmpc-magnatune-0.15.0.tar.gz) = 6c6f449a6b3dde6fea25e233d99f2f5d86ec1f9db7496ad62fc677aae906edb5
+SIZE (gmpc-magnatune-0.15.0.tar.gz) = 317018
diff --git a/audio/gmpc-magnatune/pkg-descr b/audio/gmpc-magnatune/pkg-descr
new file mode 100644
index 000000000000..9cdcc8c90181
--- /dev/null
+++ b/audio/gmpc-magnatune/pkg-descr
@@ -0,0 +1,6 @@
+The magnatune plugin provides an interface to the www.magnatune.com website.
+The plugin allows you to browse, and preview available albums.
+(It uses the 128kbit mp3 version). The magnatune plugin provides a double
+function, it also uses the data from the magnatune website to fetch cover art.
+
+WWW: http://sarine.nl/gmpc-plugins
diff --git a/audio/gmpc-magnatune/pkg-plist b/audio/gmpc-magnatune/pkg-plist
new file mode 100644
index 000000000000..fb4e8945468a
--- /dev/null
+++ b/audio/gmpc-magnatune/pkg-plist
@@ -0,0 +1,6 @@
+share/gmpc/plugins/magnatune/magnatune.png
+share/gmpc/plugins/magnatune/xdg-open
+share/gmpc/plugins/magnatuneplugin.so
+@dirrmtry share/gmpc/plugins/magnatune
+@dirrmtry share/gmpc/plugins
+@dirrmtry share/gmpc