aboutsummaryrefslogtreecommitdiff
path: root/audio/gmpc-mserver/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-03-30 00:03:28 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-03-30 00:03:28 +0000
commitd143f7a84cd656bd9133596431b88b35a96210c7 (patch)
tree59b978ee35eaeafe9916455c727b38476c362051 /audio/gmpc-mserver/Makefile
parentaf81745393e7fc1dd26f3d7bdd54a779b63cf1e4 (diff)
downloadports-d143f7a84cd656bd9133596431b88b35a96210c7.tar.gz
ports-d143f7a84cd656bd9133596431b88b35a96210c7.zip
Notes
Diffstat (limited to 'audio/gmpc-mserver/Makefile')
-rw-r--r--audio/gmpc-mserver/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/audio/gmpc-mserver/Makefile b/audio/gmpc-mserver/Makefile
new file mode 100644
index 000000000000..6dd34f895f9a
--- /dev/null
+++ b/audio/gmpc-mserver/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: gmpc-mserver
+# Date created: March 27 2008
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmpc-mserver
+PORTVERSION= 0.15.5.0
+CATEGORIES= audio
+MASTER_SITES= http://download.sarine.nl/gmpc-${PORTVERSION:C/\.0$//}/
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= A plugin for gmpc that serves music.
+
+LIB_DEPENDS= mpd:${PORTSDIR}/audio/libmpd \
+ curl.4:${PORTSDIR}/ftp/curl
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gmpc.pc:${PORTSDIR}/audio/gmpc
+RUN_DEPEND= gmpc:${PORTSDIR}/audio/gmpc
+
+GNU_CONFIGURE= yes
+USE_XORG= x11
+USE_GNOME= gnomehack
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>