aboutsummaryrefslogtreecommitdiff
path: root/audio/gmpc-random-playlist
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-03-30 00:02:51 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-03-30 00:02:51 +0000
commitaf81745393e7fc1dd26f3d7bdd54a779b63cf1e4 (patch)
treed38e39a8a377ef364686d92d36cc2358e6b4c259 /audio/gmpc-random-playlist
parent0cb1715028a24d04afa752d04078f6ac26d03c9e (diff)
downloadports-af81745393e7fc1dd26f3d7bdd54a779b63cf1e4.tar.gz
ports-af81745393e7fc1dd26f3d7bdd54a779b63cf1e4.zip
Notes
Diffstat (limited to 'audio/gmpc-random-playlist')
-rw-r--r--audio/gmpc-random-playlist/Makefile26
-rw-r--r--audio/gmpc-random-playlist/distinfo3
-rw-r--r--audio/gmpc-random-playlist/pkg-descr3
-rw-r--r--audio/gmpc-random-playlist/pkg-plist4
4 files changed, 36 insertions, 0 deletions
diff --git a/audio/gmpc-random-playlist/Makefile b/audio/gmpc-random-playlist/Makefile
new file mode 100644
index 000000000000..2340f00a0916
--- /dev/null
+++ b/audio/gmpc-random-playlist/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: gmpc-random-playlist
+# Date created: March 27 2008
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmpc-random-playlist
+PORTVERSION= 0.15.5.0
+CATEGORIES= audio
+MASTER_SITES= http://download.sarine.nl/gmpc-${PORTVERSION:C/\.0$//}/
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= A random playlist plugin for gmpc
+
+LIB_DEPENDS= mpd:${PORTSDIR}/audio/libmpd \
+ curl.4:${PORTSDIR}/ftp/curl
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gmpc.pc:${PORTSDIR}/audio/gmpc
+RUN_DEPEND= gmpc:${PORTSDIR}/audio/gmpc
+
+GNU_CONFIGURE= yes
+USE_XORG= x11
+USE_GNOME= gnomehack
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/audio/gmpc-random-playlist/distinfo b/audio/gmpc-random-playlist/distinfo
new file mode 100644
index 000000000000..dcb0c74a4899
--- /dev/null
+++ b/audio/gmpc-random-playlist/distinfo
@@ -0,0 +1,3 @@
+MD5 (gmpc-random-playlist-0.15.5.0.tar.gz) = a12bbb5f27637e0d30f8f8db4e2c9c0f
+SHA256 (gmpc-random-playlist-0.15.5.0.tar.gz) = f24f41589cf54d3fb9dd45d0ac5a120e433d43af96efb57a8e623433fa62dbc8
+SIZE (gmpc-random-playlist-0.15.5.0.tar.gz) = 304090
diff --git a/audio/gmpc-random-playlist/pkg-descr b/audio/gmpc-random-playlist/pkg-descr
new file mode 100644
index 000000000000..797c194e45ad
--- /dev/null
+++ b/audio/gmpc-random-playlist/pkg-descr
@@ -0,0 +1,3 @@
+The plugin allows you to generate random playlist.
+
+WWW: http://sarine.nl/gmpc-plugins
diff --git a/audio/gmpc-random-playlist/pkg-plist b/audio/gmpc-random-playlist/pkg-plist
new file mode 100644
index 000000000000..6d115e9cab15
--- /dev/null
+++ b/audio/gmpc-random-playlist/pkg-plist
@@ -0,0 +1,4 @@
+share/gmpc/plugins/librandomplaylist.la
+share/gmpc/plugins/librandomplaylist.so
+@dirrmtry share/gmpc/plugins
+@dirrmtry share/gmpc