aboutsummaryrefslogtreecommitdiff
path: root/audio/gmusicbrowser/Makefile
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2015-03-22 14:26:40 +0000
committerThomas Zander <riggs@FreeBSD.org>2015-03-22 14:26:40 +0000
commitdd4a4cd3db19923a0a5b64e3680a62fbf249f769 (patch)
treebc6c1ebaba843f796046b64aef467671f3df3ec2 /audio/gmusicbrowser/Makefile
parent4a9ac5f799d3b66966ecc439c76da537a46fbd0a (diff)
downloadports-dd4a4cd3db19923a0a5b64e3680a62fbf249f769.tar.gz
ports-dd4a4cd3db19923a0a5b64e3680a62fbf249f769.zip
Notes
Diffstat (limited to 'audio/gmusicbrowser/Makefile')
-rw-r--r--audio/gmusicbrowser/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/audio/gmusicbrowser/Makefile b/audio/gmusicbrowser/Makefile
index 1c05bad98a03..6e605ca71579 100644
--- a/audio/gmusicbrowser/Makefile
+++ b/audio/gmusicbrowser/Makefile
@@ -2,14 +2,15 @@
# $FreeBSD$
PORTNAME= gmusicbrowser
-PORTVERSION= 1.1.10
-PORTREVISION= 1
+PORTVERSION= 1.1.13
CATEGORIES= audio
MASTER_SITES= http://gmusicbrowser.org/download/
MAINTAINER= lichray@gmail.com
COMMENT= Jukebox for large collections of mp3/ogg/flac/mpc files
+LICENSE= GPLv3
+
RUN_DEPENDS= p5-Gtk2>=1.0:${PORTSDIR}/x11-toolkits/p5-Gtk2
NO_BUILD= yes
@@ -20,19 +21,21 @@ PORTDATA= *
USES= shebangfix
SHEBANG_FILES= *.pl
-OPTIONS_DEFINE= GSTREAMER MPLAYER DBUS WEBKIT NLS LIBNOTIFY DOCS
-OPTIONS_DEFAULT=MPLAYER
+OPTIONS_DEFINE= GSTREAMER DBUS WEBKIT NLS LIBNOTIFY DOCS
+OPTIONS_DEFAULT=LIBNOTIFY
LIBNOTIFY_DESC= Desktop notification
WEBKIT_DESC= Enable embedded web browser
GSTREAMER_RUN_DEPENDS= p5-GStreamer>=0:${PORTSDIR}/multimedia/p5-GStreamer
-MPLAYER_RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
DBUS_RUN_DEPENDS= p5-Net-DBus>=1.0:${PORTSDIR}/devel/p5-Net-DBus
WEBKIT_RUN_DEPENDS= p5-Gtk2-WebKit>=0:${PORTSDIR}/www/p5-Gtk2-WebKit
-LIBNOTIFY_RUN_DEPENDS= pt-Gtk2-Notify>=0.05:${PORTSDIR}/devel/p5-Gtk2-Notify
+LIBNOTIFY_RUN_DEPENDS= p5-Gtk2-Notify>=0.05:${PORTSDIR}/devel/p5-Gtk2-Notify
+NLS_RUN_DEPENDS= p5-Locale-gettext>=1.0:${PORTSDIR}/devel/p5-Locale-gettext
OPTIONS_SUB= yes
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.man ${STAGEDIR}${MANPREFIX}/man/man1/${MAN1}
@@ -44,7 +47,9 @@ do-install:
${INSTALL_SCRIPT} iceserver.pl ${STAGEDIR}${DATADIR})
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
+.if ${PORT_OPTIONS:MNLS}
(cd ${WRKSRC}/locale && \
${COPYTREE_SHARE} \* ${STAGEDIR}${PREFIX}/share/locale)
+.endif
.include <bsd.port.mk>