aboutsummaryrefslogtreecommitdiff
path: root/audio/gnapster/Makefile
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>2000-11-24 00:01:43 +0000
committerChris Piazza <cpiazza@FreeBSD.org>2000-11-24 00:01:43 +0000
commitf53141c229669ea7c943e0683a923be4d99161d3 (patch)
tree04953c1a1b40ad05a304b6d2f3ba472f9aff7927 /audio/gnapster/Makefile
parent2bd923921b0f3c22d4eba95640d30a1be58cba09 (diff)
downloadports-f53141c229669ea7c943e0683a923be4d99161d3.tar.gz
ports-f53141c229669ea7c943e0683a923be4d99161d3.zip
Notes
Diffstat (limited to 'audio/gnapster/Makefile')
-rw-r--r--audio/gnapster/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/audio/gnapster/Makefile b/audio/gnapster/Makefile
index 9cc47ac474b4..7ad3adb4360d 100644
--- a/audio/gnapster/Makefile
+++ b/audio/gnapster/Makefile
@@ -12,15 +12,21 @@ MASTER_SITES= http://www.faradic.net/~jasta/files/
MAINTAINER= cpiazza@FreeBSD.org
-LIB_DEPENDS= ungif.5:${PORTSDIR}/graphics/libungif
+.if defined(HAVE_GNOME)
+LIB_DEPENDS= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk_pixbuf
+.endif
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOME= yes
-USE_XPM= yes
+USE_IMLIB= yes
+WANT_GNOME= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+.if !defined(HAVE_GNOME)
+CONFIGURE_ARGS+=--disable-gnome --disable-gdk-pixbuf
+.endif
pre-patch:
@${PERL} -pi -e 's|-lpthread|-pthread|g ; \