aboutsummaryrefslogtreecommitdiff
path: root/audio/gnump3d
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-29 19:08:03 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-29 19:08:03 +0000
commitb9d4acf7d85c816922031baf028f82157cdcfdc8 (patch)
treea6b972bbaeb1360eb5820455d7fcd8e0941bc7b4 /audio/gnump3d
parent493374f8c3de67454fbd5a7d49bb57850cdb4350 (diff)
downloadports-b9d4acf7d85c816922031baf028f82157cdcfdc8.tar.gz
ports-b9d4acf7d85c816922031baf028f82157cdcfdc8.zip
Notes
Diffstat (limited to 'audio/gnump3d')
-rw-r--r--audio/gnump3d/Makefile37
-rw-r--r--audio/gnump3d/distinfo2
-rw-r--r--audio/gnump3d/files/patch-freebsd83
-rw-r--r--audio/gnump3d/pkg-plist62
4 files changed, 63 insertions, 121 deletions
diff --git a/audio/gnump3d/Makefile b/audio/gnump3d/Makefile
index 4849a0281869..48128bea63dc 100644
--- a/audio/gnump3d/Makefile
+++ b/audio/gnump3d/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= gnump3d
-PORTVERSION= 0.9.9.9
+PORTVERSION= 0.9.9.9.1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,11 +15,36 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
USE_BZIP2= yes
-MAKE_ENV= CC="${CXX}" CFLAGS="${CXXFLAGS}" \
- PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- PTHREAD_LIBS="${PTHREAD_LIBS}"
-ALL_TARGET= freebsd
+USE_PERL5= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-MAN1= mp3d.1 mp3d.conf.1 mp3d-config.1 mp3d-top.1
+MAN1= gnump3d.1 gnump3d.conf.1 gnump3d-config.1 gnump3d-top.1
+
+.if !defined(WITHOUT_VORBIS)
+CONFIGURE_ARGS+= --with-vorbis
+.endif
+
+pre-everything::
+.if !defined(WITHOUT_VORBIS)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "If you want to compile without Ogg/Vorbis support,"
+ @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITHOUT_VORBIS=yes\""
+ @${ECHO_MSG}
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|=aclocal|=${TRUE}|g ; \
+ s|=autoconf|=${TRUE}|g ; \
+ s|=automake|=${TRUE}|g ; \
+ s|=autoheader|=${TRUE}|g ; \
+ s|-pthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|#undef socklen_t||g' ${WRKSRC}/src/config.h.in
.include <bsd.port.mk>
diff --git a/audio/gnump3d/distinfo b/audio/gnump3d/distinfo
index c3577d853532..844cbba22a21 100644
--- a/audio/gnump3d/distinfo
+++ b/audio/gnump3d/distinfo
@@ -1 +1 @@
-MD5 (gnump3d-0.9.9.9.tar.bz2) = d3631ef85abadea0019c04c31b203def
+MD5 (gnump3d-0.9.9.9.1.tar.bz2) = 10048c53ec1a1382fe8092dd181dbe00
diff --git a/audio/gnump3d/files/patch-freebsd b/audio/gnump3d/files/patch-freebsd
deleted file mode 100644
index b74539b9320d..000000000000
--- a/audio/gnump3d/files/patch-freebsd
+++ /dev/null
@@ -1,83 +0,0 @@
---- mkfiles/freebsd.orig Fri Jun 7 06:31:56 2002
-+++ mkfiles/freebsd Sat Jun 8 09:27:02 2002
-@@ -6,8 +6,8 @@
- # if you wish you may change PREFIX to be /usr/local,
- # for example
- #
--PREFIX =
--#PREFIX = /usr/local
-+#PREFIX =
-+PREFIX ?= /usr/local
-
- #
- # Binary installation directory.
-@@ -24,7 +24,7 @@
- #
- # Where we install the manpages.
- #
--MANDIR = /usr/local/man/man1
-+MANDIR = $(PREFIX)/man/man1
-
-
-
-@@ -32,12 +32,12 @@
- O = o
- RM = rm -f
- RMDIR = rm -rf
--CC = g++
--LIBS = -pthread
-+CC ?= g++
-+LIBS = ${PTHREAD_LIBS}
-
-
--DEFAULT_CFLAGS = -I. -D_THREAD_SAFE -D_REENTRANT -DBINARY_DIR="\"$(BINARYDIR)\"" -DSYSCONFDIR="\"$(CONFIGDIR)\"" -DVERSION="\"0.9.9.9\""
--CFLAGS = $(DEFAULT_CFLAGS) -Wall -DOS_TYPE="\"FreeBSD\""
-+DEFAULT_CFLAGS = -I. ${PTHREAD_CFLAGS} -D_REENTRANT -DBINARY_DIR="\"$(BINARYDIR)\"" -DSYSCONFDIR="\"$(CONFIGDIR)\"" -DVERSION="\"0.9.9.9\""
-+CFLAGS += $(DEFAULT_CFLAGS) -Wall -DOS_TYPE="\"FreeBSD\""
-
-
- #
-@@ -116,25 +116,26 @@
- # Install the software.
- #
- install: $(PROG)
-- install -d $(BINARYDIR) -d $(CONFIGDIR) -d $(TEMPLATEDIR)
-- install ../mp3d $(BINARYDIR)
-- install ../contrib/stats/mp3d-top $(BINARYDIR)
-- install ../mp3d.conf $(CONFIGDIR)
-+ -mkdir -p $(BINARYDIR) $(CONFIGDIR) $(TEMPLATEDIR)
-+ ${BSD_INSTALL_PROGRAM} ../mp3d $(BINARYDIR)
-+ ${BSD_INSTALL_SCRIPT} ../contrib/stats/mp3d-top $(BINARYDIR)
-+ ${BSD_INSTALL_DATA} ../mp3d.conf $(CONFIGDIR)
- # Install all the theme directories.
-- for i in ../templates/*/; do cp -R ../templates/$$i $(TEMPLATEDIR); done
-- install ../templates/README $(TEMPLATEDIR)
--
-- # Fix up permissions correctly.
-- find $(TEMPLATEDIR) -name "CVS" -print | xargs rm -rf
-- chmod -R a+rx $(TEMPLATEDIR)
-- find $(TEMPLATEDIR) -name "*.*" -print | xargs chmod -x
--
-+ -mkdir -p $(TEMPLATEDIR)/default
-+ ${BSD_INSTALL_DATA} ../templates/default/* $(TEMPLATEDIR)/default
-+ -mkdir -p $(TEMPLATEDIR)/nausicaa
-+ ${BSD_INSTALL_DATA} ../templates/nausicaa/* $(TEMPLATEDIR)/nausicaa
-+ -mkdir -p $(TEMPLATEDIR)/simple
-+ ${BSD_INSTALL_DATA} ../templates/simple/* $(TEMPLATEDIR)/simple
-+ -mkdir -p $(TEMPLATEDIR)/split
-+ ${BSD_INSTALL_DATA} ../templates/split/* $(TEMPLATEDIR)/split
-+ ${BSD_INSTALL_DATA} ../templates/README $(TEMPLATEDIR)
- # Man pages.
-- install -d $(MANDIR)
-- install ../doc/mp3d.1 $(MANDIR)
-- install ../doc/mp3d.conf.1 $(MANDIR)
-- install ../doc/mp3d-top.1 $(MANDIR)
-- install ../doc/mp3d-config.1 $(MANDIR)
-+ -mkdir -p $(MANDIR)
-+ ${BSD_INSTALL_MAN} ../doc/mp3d.1 $(MANDIR)
-+ ${BSD_INSTALL_MAN} ../doc/mp3d.conf.1 $(MANDIR)
-+ ${BSD_INSTALL_MAN} ../doc/mp3d-top.1 $(MANDIR)
-+ ${BSD_INSTALL_MAN} ../doc/mp3d-config.1 $(MANDIR)
-
-
- #
diff --git a/audio/gnump3d/pkg-plist b/audio/gnump3d/pkg-plist
index 2bfab7543e52..5883503b8fee 100644
--- a/audio/gnump3d/pkg-plist
+++ b/audio/gnump3d/pkg-plist
@@ -1,31 +1,31 @@
-bin/mp3d
-bin/mp3d-top
-etc/mp3d.conf
-etc/mp3d/README
-etc/mp3d/default/error.html
-etc/mp3d/default/index.html
-etc/mp3d/default/results.html
-etc/mp3d/default/search.html
-etc/mp3d/default/stats.html
-etc/mp3d/nausicaa/error.html
-etc/mp3d/nausicaa/index.html
-etc/mp3d/nausicaa/results.html
-etc/mp3d/nausicaa/search.html
-etc/mp3d/nausicaa/stats.html
-etc/mp3d/simple/config.ini
-etc/mp3d/simple/error.html
-etc/mp3d/simple/index.html
-etc/mp3d/simple/results.html
-etc/mp3d/simple/search.html
-etc/mp3d/simple/stats.html
-etc/mp3d/split/config.ini
-etc/mp3d/split/error.html
-etc/mp3d/split/index.html
-etc/mp3d/split/results.html
-etc/mp3d/split/search.html
-etc/mp3d/split/stats.html
-@dirrm etc/mp3d/split
-@dirrm etc/mp3d/simple
-@dirrm etc/mp3d/nausicaa
-@dirrm etc/mp3d/default
-@dirrm etc/mp3d
+bin/gnump3d
+bin/gnump3d-top
+etc/gnump3d/gnump3d.conf
+etc/gnump3d/default/error.html
+etc/gnump3d/default/index.html
+etc/gnump3d/default/results.html
+etc/gnump3d/default/search.html
+etc/gnump3d/default/stats.html
+etc/gnump3d/default/style.css
+etc/gnump3d/nausicaa/error.html
+etc/gnump3d/nausicaa/index.html
+etc/gnump3d/nausicaa/results.html
+etc/gnump3d/nausicaa/search.html
+etc/gnump3d/nausicaa/stats.html
+etc/gnump3d/simple/config.ini
+etc/gnump3d/simple/error.html
+etc/gnump3d/simple/index.html
+etc/gnump3d/simple/results.html
+etc/gnump3d/simple/search.html
+etc/gnump3d/simple/stats.html
+etc/gnump3d/split/config.ini
+etc/gnump3d/split/error.html
+etc/gnump3d/split/index.html
+etc/gnump3d/split/results.html
+etc/gnump3d/split/search.html
+etc/gnump3d/split/stats.html
+@dirrm etc/gnump3d/split
+@dirrm etc/gnump3d/simple
+@dirrm etc/gnump3d/nausicaa
+@dirrm etc/gnump3d/default
+@dirrm etc/gnump3d