aboutsummaryrefslogtreecommitdiff
path: root/audio/gnump3d
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2003-07-08 06:30:55 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2003-07-08 06:30:55 +0000
commitf050ec2850cf89db040a0262117458b4595bbf9d (patch)
treef5d827069f3b4cb6915732c234605f3e8688deaf /audio/gnump3d
parent381751a823e3b3ccd05b104ebd55dedfca40dc37 (diff)
downloadports-f050ec2850cf89db040a0262117458b4595bbf9d.tar.gz
ports-f050ec2850cf89db040a0262117458b4595bbf9d.zip
Notes
Diffstat (limited to 'audio/gnump3d')
-rw-r--r--audio/gnump3d/Makefile11
-rw-r--r--audio/gnump3d/distinfo2
-rw-r--r--audio/gnump3d/files/patch-bin::gnump3d-index14
-rw-r--r--audio/gnump3d/files/patch-bin::gnump3d221
-rw-r--r--audio/gnump3d/files/patch-etc::gnump3d.conf50
-rw-r--r--audio/gnump3d/pkg-plist125
6 files changed, 165 insertions, 58 deletions
diff --git a/audio/gnump3d/Makefile b/audio/gnump3d/Makefile
index d5acfda29f69..8d8826b885a4 100644
--- a/audio/gnump3d/Makefile
+++ b/audio/gnump3d/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= gnump3d
-PORTVERSION= 2.4
+PORTVERSION= 2.5b
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -22,7 +22,7 @@ USE_BZIP2= yes
USE_PERL5= yes
NO_BUILD= yes
-MAN1= gnump3d.1 gnump3d-top.1 gnump3d.conf.1
+MAN1= gnump3d-index.1 gnump3d-top.1 gnump3d.1 gnump3d.conf.1
CONFDIR= ${PREFIX}/etc/${PORTNAME}
PERL_SITELIBDIR= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}
@@ -35,18 +35,19 @@ BROKEN= "You need at least perl 5.6.0. Do not use FreeBSD 4.x' system perl,\
.endif
post-patch:
-.for file in bin/gnump3d-top bin/gnump3d2 etc/gnump3d.conf man/gnump3d.conf.1
+.for file in bin/gnump3d-index bin/gnump3d-top bin/gnump3d2 etc/gnump3d.conf \
+ man/gnump3d.conf.1
@${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|g ; \
s|%%LOCALBASE%%|${LOCALBASE}|g ; \
s|%%PERL_SITELIBDIR%%|${PERL_SITELIBDIR}|g' ${WRKSRC}/${file}
.endfor
do-install:
-.for file in gnump3d-top gnump3d2
+.for file in gnump3d-index gnump3d-top gnump3d2
${INSTALL_SCRIPT} ${WRKSRC}/bin/${file} ${PREFIX}/bin
.endfor
${LN} -sf gnump3d2 ${PREFIX}/bin/gnump3d
-.for file in gnump3d.1 gnump3d-top.1 gnump3d.conf.1
+.for file in gnump3d-index.1 gnump3d-top.1 gnump3d.1 gnump3d.conf.1
${INSTALL_MAN} ${WRKSRC}/man/${file} ${MANPREFIX}/man/man1
.endfor
${MKDIR} ${PERL_SITELIBDIR}
diff --git a/audio/gnump3d/distinfo b/audio/gnump3d/distinfo
index 06ac7144ee11..ac80e0f036e2 100644
--- a/audio/gnump3d/distinfo
+++ b/audio/gnump3d/distinfo
@@ -1 +1 @@
-MD5 (gnump3d-2.4.tar.bz2) = df712073eed1bdd259d66a7df5015aa8
+MD5 (gnump3d-2.5b.tar.bz2) = a8f01fc73d1f18c3779546d92b74bf75
diff --git a/audio/gnump3d/files/patch-bin::gnump3d-index b/audio/gnump3d/files/patch-bin::gnump3d-index
new file mode 100644
index 000000000000..cb07c9853539
--- /dev/null
+++ b/audio/gnump3d/files/patch-bin::gnump3d-index
@@ -0,0 +1,14 @@
+--- bin/gnump3d-index.orig Thu Jul 3 05:44:16 2003
++++ bin/gnump3d-index Fri Jul 4 23:36:00 2003
+@@ -54,9 +54,9 @@
+ {
+ $CONFIG_FILE = $ENV{"HOME"} . "/.gnump3drc";
+ }
+-elsif ( -e "/etc/gnump3d/gnump3d.conf" )
++elsif ( -e "%%PREFIX%%/etc/gnump3d/gnump3d.conf" )
+ {
+- $CONFIG_FILE = "/etc/gnump3d/gnump3d.conf";
++ $CONFIG_FILE = "%%PREFIX%%/etc/gnump3d/gnump3d.conf";
+ }
+ elsif ( -e "gnump3d.conf" )
+ {
diff --git a/audio/gnump3d/files/patch-bin::gnump3d2 b/audio/gnump3d/files/patch-bin::gnump3d2
index 4306418fb119..39e85ead990a 100644
--- a/audio/gnump3d/files/patch-bin::gnump3d2
+++ b/audio/gnump3d/files/patch-bin::gnump3d2
@@ -1,6 +1,6 @@
---- bin/gnump3d2.orig Fri May 2 18:56:50 2003
-+++ bin/gnump3d2 Sat May 3 00:11:54 2003
-@@ -2457,9 +2457,9 @@
+--- bin/gnump3d2.orig Fri Jul 4 10:20:24 2003
++++ bin/gnump3d2 Fri Jul 4 10:23:13 2003
+@@ -2620,9 +2620,9 @@
{
$CONFIG_FILE = $ENV{"HOME"} . "/.gnump3drc";
}
@@ -12,7 +12,7 @@
}
elsif ( -e "gnump3d.conf" )
{
-@@ -2599,8 +2599,8 @@
+@@ -2764,8 +2764,8 @@
$PORT = getConfig( "port", 8888 );
$bind_address = getConfig( "binding_host", "" );
$host = getConfig( "hostname", "localhost" );
@@ -23,12 +23,14 @@
$always_stream = getConfig( "always_stream", 1 );
$access_log = getConfig( "logfile", "/var/log/gnump3d/access.log" );
$error_log = getConfig( "errorlog", "/var/log/gnump3d/error.log" );
-@@ -2608,10 +2608,10 @@
+@@ -2773,11 +2773,11 @@
$client_host = getConfig( "use_client_host", 1 );
$default_theme = getConfig( "theme", "default" );
$TIMEOUT = getConfig( "read_time", 10 );
- $STATSPROG = getConfig( "stats_program", "/usr/bin/gnump3d-top" );
+- $INDEXPROG = getConfig( "index_program", "/usr/bin/gnump3d-index" );
+ $STATSPROG = getConfig( "stats_program", "%%PREFIX%%/bin/gnump3d-top" );
++ $INDEXPROG = getConfig( "index_program", "%%PREFIX%%/bin/gnump3d-index" );
$STATSARGS = getConfig( "stats_arguments", "" );
$play_rec = getConfig( "play_recursively_text", "Play" );
- $mime_file = getConfig( "mime_file", "/etc/gnump3d/mime.types" );
@@ -36,3 +38,12 @@
$enable_browse = getConfig( "enable_browsing", 1 );
$sort_order = getConfig( "sort_order", '$SONGNAME' );
+@@ -2813,7 +2813,7 @@
+ # Experimental features.
+ #
+ $jukebox = getConfig( "jukebox_mode", 0 );
+- $jukebox_binary = getConfig( "jukebox_player", "/usr/bin/mpg123" );
++ $jukebox_binary = getConfig( "jukebox_player", "%%PREFIX%%/bin/mpg123" );
+ if ( $jukebox )
+ {
+ $always_stream = 0;
diff --git a/audio/gnump3d/files/patch-etc::gnump3d.conf b/audio/gnump3d/files/patch-etc::gnump3d.conf
index 202e486885c7..81c90922baf2 100644
--- a/audio/gnump3d/files/patch-etc::gnump3d.conf
+++ b/audio/gnump3d/files/patch-etc::gnump3d.conf
@@ -1,5 +1,5 @@
---- etc/gnump3d.conf.orig Fri May 2 18:56:50 2003
-+++ etc/gnump3d.conf Sat May 3 00:15:39 2003
+--- etc/gnump3d.conf.orig Fri Jul 4 10:20:24 2003
++++ etc/gnump3d.conf Fri Jul 4 10:27:25 2003
@@ -173,7 +173,7 @@
# path if you don't have it installed upon the $PATH of the user
# who starts the server:
@@ -9,24 +9,16 @@
#
#
# For example you may change the default number of lines which are
-@@ -388,13 +388,13 @@
- # theme variable below you specify which set of templates you wish
- # the server to use.
+@@ -412,7 +412,7 @@
+ # the URL http://server.host.name:port/stats/, and reads in a template
+ # called 'stats.html'
#
-# The theme directory defaults to /usr/share/gnump3d - but may be
+# The theme directory defaults to %%PREFIX%%/share/gnump3d - but may be
# changed via the 'theme_directory' setting given below.
#
--# eg. To use the templates in '/usr/share/gnump3d/simple/' then you
-+# eg. To use the templates in '%%PREFIX%%/share/gnump3d/simple/' then you
- # should set theme to be 'simple'
- #
--# To use the templates in '/usr/share/gnump3d/twin/' then you
-+# To use the templates in '%%PREFIX%%/share/gnump3d/twin/' then you
- # should set theme to be 'twin'
- #
# When the server is running you may set the theme from your browser
-@@ -421,7 +421,7 @@
+@@ -439,7 +439,7 @@
# location.
#
##
@@ -35,7 +27,7 @@
##
-@@ -582,13 +582,13 @@
+@@ -600,13 +600,13 @@
# the string '$FILENAME' will be replaced by the file the user is
# requesting.
#
@@ -56,25 +48,25 @@
#
#
-@@ -611,7 +611,7 @@
- # This next setting allows you to change the location from which the
- # plugins are loaded.
- #
--# plugin_directory = /usr/lib/perl5/gnump3d/plugins
-+# plugin_directory = %%PERL_SITELIBDIR%%/gnump3d/plugins
- #
+@@ -642,7 +642,7 @@
+ # the installation script - if this doesn't happen report this as
+ # a bug.
#
- # NOTE: the following directory should be correctly filled in by
-@@ -683,7 +683,7 @@
- # used by default. If not point this next file to wherever your mime
- # types file is located:
+-plugin_directory = PLUGINDIR/gnump3d/plugins
++plugin_directory = %%PERL_SITELIBDIR%%/gnump3d/plugins
#
--# mime_file = /etc/gnump3d/mime.types
-+# mime_file = %%PREFIX%%/etc/gnump3d/mime.types
+
+
+@@ -736,7 +736,7 @@
#
+ # Normally you shouldn't need to touch this.
#
+-# index_program = /usr/bin/gnump3d-index
++# index_program = %%PREFIX%%/bin/gnump3d-index
-@@ -771,7 +771,7 @@
+
+ #
+@@ -813,7 +813,7 @@
##
#
# jukebox_mode = 1
diff --git a/audio/gnump3d/pkg-plist b/audio/gnump3d/pkg-plist
index c079a0e9fc19..6864cf7860e6 100644
--- a/audio/gnump3d/pkg-plist
+++ b/audio/gnump3d/pkg-plist
@@ -1,11 +1,13 @@
@comment $FreeBSD$
bin/gnump3d
+bin/gnump3d-index
bin/gnump3d-top
bin/gnump3d2
@unexec if cmp -s %D/etc/gnump3d/gnump3d.conf %D/etc/gnump3d/gnump3d.conf-default; then rm -f %D/etc/gnump3d/gnump3d.conf; fi
etc/gnump3d/gnump3d.conf-default
@exec [ -f %B/gnump3d.conf ] || cp %B/%f %B/gnump3d.conf
etc/gnump3d/mime.types
+lib/perl5/site_perl/%%PERL_VER%%/gnump3d/FreezeThaw.pm
lib/perl5/site_perl/%%PERL_VER%%/gnump3d/IP.pm
lib/perl5/site_perl/%%PERL_VER%%/gnump3d/base64.pm
lib/perl5/site_perl/%%PERL_VER%%/gnump3d/config.pm
@@ -15,28 +17,58 @@ lib/perl5/site_perl/%%PERL_VER%%/gnump3d/ogginfo.pm
lib/perl5/site_perl/%%PERL_VER%%/gnump3d/oggtagreader.pm
lib/perl5/site_perl/%%PERL_VER%%/gnump3d/playlist.pm
lib/perl5/site_perl/%%PERL_VER%%/gnump3d/plugins/COPYING.pm
-lib/perl5/site_perl/%%PERL_VER%%/gnump3d/plugins/admin.pm
lib/perl5/site_perl/%%PERL_VER%%/gnump3d/plugins/bug.pm
lib/perl5/site_perl/%%PERL_VER%%/gnump3d/plugins/info.pm
lib/perl5/site_perl/%%PERL_VER%%/gnump3d/plugins/now.pm
-lib/perl5/site_perl/%%PERL_VER%%/gnump3d/plugins/passwords.pm
lib/perl5/site_perl/%%PERL_VER%%/gnump3d/plugins/playlist.pm
lib/perl5/site_perl/%%PERL_VER%%/gnump3d/plugins/prefs.pm
+lib/perl5/site_perl/%%PERL_VER%%/gnump3d/plugins/random.pm
lib/perl5/site_perl/%%PERL_VER%%/gnump3d/plugins/recent.pm
lib/perl5/site_perl/%%PERL_VER%%/gnump3d/plugins/search.pm
lib/perl5/site_perl/%%PERL_VER%%/gnump3d/plugins/stats.pm
+lib/perl5/site_perl/%%PERL_VER%%/gnump3d/tagcache.pm
lib/perl5/site_perl/%%PERL_VER%%/gnump3d/url.pm
-lib/perl5/site_perl/%%PERL_VER%%/gnump3d/tagreader.pm
share/gnump3d/LaFrere/AUTHOR
+share/gnump3d/LaFrere/COPYING.html
+share/gnump3d/LaFrere/bug.html
share/gnump3d/LaFrere/config.ini
share/gnump3d/LaFrere/error.html
share/gnump3d/LaFrere/index.html
+share/gnump3d/LaFrere/info.html
share/gnump3d/LaFrere/logo.png
-share/gnump3d/LaFrere/plugin.html
+share/gnump3d/LaFrere/now.html
+share/gnump3d/LaFrere/playlist.html
+share/gnump3d/LaFrere/prefs.html
+share/gnump3d/LaFrere/random.html
+share/gnump3d/LaFrere/recent.html
share/gnump3d/LaFrere/results.html
share/gnump3d/LaFrere/search.html
share/gnump3d/LaFrere/stats.html
+share/gnump3d/README
+share/gnump3d/Tabular/AUTHOR
+share/gnump3d/Tabular/COPYING.html
+share/gnump3d/Tabular/bug.html
+share/gnump3d/Tabular/config.ini
+share/gnump3d/Tabular/error.html
+share/gnump3d/Tabular/extras.html
+share/gnump3d/Tabular/footer.tmpl
+share/gnump3d/Tabular/header.tmpl
+share/gnump3d/Tabular/index.html
+share/gnump3d/Tabular/info.html
+share/gnump3d/Tabular/now.html
+share/gnump3d/Tabular/playlist.html
+share/gnump3d/Tabular/prefs.html
+share/gnump3d/Tabular/random.html
+share/gnump3d/Tabular/recent.html
+share/gnump3d/Tabular/results.html
+share/gnump3d/Tabular/search.html
+share/gnump3d/Tabular/statistics.html
+share/gnump3d/Tabular/stats.html
+share/gnump3d/Tabular/style.css
+share/gnump3d/Tabular/template.ini
share/gnump3d/Thexder/AUTHOR
+share/gnump3d/Thexder/COPYING.html
+share/gnump3d/Thexder/bug.html
share/gnump3d/Thexder/config.ini
share/gnump3d/Thexder/dig_temp2_01.jpg
share/gnump3d/Thexder/dig_temp2_02.jpg
@@ -50,65 +82,122 @@ share/gnump3d/Thexder/dig_temp2_14.jpg
share/gnump3d/Thexder/error.html
share/gnump3d/Thexder/hr.gif
share/gnump3d/Thexder/index.html
+share/gnump3d/Thexder/info.html
share/gnump3d/Thexder/link_1.jpg
share/gnump3d/Thexder/link_2.jpg
share/gnump3d/Thexder/link_3.jpg
share/gnump3d/Thexder/link_4.jpg
share/gnump3d/Thexder/link_5.jpg
share/gnump3d/Thexder/logo7.jpg
-share/gnump3d/Thexder/plugin.html
+share/gnump3d/Thexder/now.html
+share/gnump3d/Thexder/playlist.html
+share/gnump3d/Thexder/prefs.html
+share/gnump3d/Thexder/random.html
+share/gnump3d/Thexder/recent.html
share/gnump3d/Thexder/results.html
share/gnump3d/Thexder/search.html
share/gnump3d/Thexder/spacer.gif
share/gnump3d/Thexder/stats.html
share/gnump3d/default/AUTHOR
+share/gnump3d/default/COPYING.html
+share/gnump3d/default/bug.html
share/gnump3d/default/error.html
share/gnump3d/default/footer.tmpl
share/gnump3d/default/header.tmpl
share/gnump3d/default/index.html
-share/gnump3d/default/plugin.html
+share/gnump3d/default/info.html
+share/gnump3d/default/now.html
+share/gnump3d/default/playlist.html
+share/gnump3d/default/prefs.html
+share/gnump3d/default/random.html
+share/gnump3d/default/recent.html
share/gnump3d/default/results.html
share/gnump3d/default/search.html
share/gnump3d/default/stats.html
share/gnump3d/default/style.css
+share/gnump3d/dotNET/AUTHOR
+share/gnump3d/dotNET/COPYING.html
+share/gnump3d/dotNET/bug.html
+share/gnump3d/dotNET/config.ini
+share/gnump3d/dotNET/content.tmpl
+share/gnump3d/dotNET/error.html
+share/gnump3d/dotNET/header.tmpl
+share/gnump3d/dotNET/images/ecke_unten_links.gif
+share/gnump3d/dotNET/images/ecke_unten_rechts.gif
+share/gnump3d/dotNET/images/eckeor.gif
+share/gnump3d/dotNET/images/eckeul.gif
+share/gnump3d/dotNET/images/eckeur.gif
+share/gnump3d/dotNET/images/horizontal.jpg
+share/gnump3d/dotNET/images/logo7.jpg
+share/gnump3d/dotNET/images/pfeilrechts.gif
+share/gnump3d/dotNET/images/reiter.jpg
+share/gnump3d/dotNET/images/transparent.gif
+share/gnump3d/dotNET/images/vertikal.jpg
+share/gnump3d/dotNET/index.html
+share/gnump3d/dotNET/info.html
+share/gnump3d/dotNET/now.html
+share/gnump3d/dotNET/playlist.html
+share/gnump3d/dotNET/prefs.html
+share/gnump3d/dotNET/random.html
+share/gnump3d/dotNET/recent.html
+share/gnump3d/dotNET/results.html
+share/gnump3d/dotNET/search.html
+share/gnump3d/dotNET/stats.html
+share/gnump3d/dotNET/style.css
share/gnump3d/nausicaa/AUTHOR
+share/gnump3d/nausicaa/COPYING.html
+share/gnump3d/nausicaa/bug.html
share/gnump3d/nausicaa/config.ini
share/gnump3d/nausicaa/error.html
+share/gnump3d/nausicaa/extras.html
share/gnump3d/nausicaa/index.html
-share/gnump3d/nausicaa/plugin.html
+share/gnump3d/nausicaa/info.html
+share/gnump3d/nausicaa/now.html
+share/gnump3d/nausicaa/playlist.html
+share/gnump3d/nausicaa/prefs.html
+share/gnump3d/nausicaa/random.html
+share/gnump3d/nausicaa/recent.html
share/gnump3d/nausicaa/results.html
share/gnump3d/nausicaa/search.html
share/gnump3d/nausicaa/stats.html
share/gnump3d/nausicaa/style.css
share/gnump3d/redgrey/AUTHOR
+share/gnump3d/redgrey/COPYING.html
+share/gnump3d/redgrey/bug.html
share/gnump3d/redgrey/error.html
share/gnump3d/redgrey/index.html
-share/gnump3d/redgrey/plugin.html
+share/gnump3d/redgrey/info.html
+share/gnump3d/redgrey/now.html
+share/gnump3d/redgrey/playlist.html
+share/gnump3d/redgrey/prefs.html
+share/gnump3d/redgrey/random.html
+share/gnump3d/redgrey/recent.html
share/gnump3d/redgrey/results.html
share/gnump3d/redgrey/search.html
share/gnump3d/redgrey/stats.html
share/gnump3d/simple/AUTHOR
+share/gnump3d/simple/COPYING.html
+share/gnump3d/simple/bug.html
share/gnump3d/simple/config.ini
share/gnump3d/simple/error.html
share/gnump3d/simple/index.html
-share/gnump3d/simple/plugin.html
+share/gnump3d/simple/info.html
+share/gnump3d/simple/now.html
+share/gnump3d/simple/playlist.html
+share/gnump3d/simple/prefs.html
+share/gnump3d/simple/random.html
+share/gnump3d/simple/recent.html
share/gnump3d/simple/results.html
share/gnump3d/simple/search.html
share/gnump3d/simple/stats.html
-share/gnump3d/split/AUTHOR
-share/gnump3d/split/config.ini
-share/gnump3d/split/error.html
-share/gnump3d/split/index.html
-share/gnump3d/split/plugin.html
-share/gnump3d/split/results.html
-share/gnump3d/split/search.html
-share/gnump3d/split/stats.html
-@dirrm share/gnump3d/split
@dirrm share/gnump3d/simple
@dirrm share/gnump3d/redgrey
@dirrm share/gnump3d/nausicaa
+@dirrm share/gnump3d/dotNET/images
+@dirrm share/gnump3d/dotNET
@dirrm share/gnump3d/default
@dirrm share/gnump3d/Thexder
+@dirrm share/gnump3d/Tabular
@dirrm share/gnump3d/LaFrere
@dirrm share/gnump3d
@dirrm lib/perl5/site_perl/%%PERL_VER%%/gnump3d/plugins