aboutsummaryrefslogtreecommitdiff
path: root/audio/gnump3d
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2002-08-14 21:42:10 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2002-08-14 21:42:10 +0000
commita799213341544a1de3c315edfac151a2e55895d1 (patch)
tree2bc48be7259534872927933c89e31b7f29900bf5 /audio/gnump3d
parente4594fd355167eb0de341df5d891dc24269da103 (diff)
downloadports-a799213341544a1de3c315edfac151a2e55895d1.tar.gz
ports-a799213341544a1de3c315edfac151a2e55895d1.zip
Notes
Diffstat (limited to 'audio/gnump3d')
-rw-r--r--audio/gnump3d/Makefile12
-rw-r--r--audio/gnump3d/files/patch-configure.in15
-rw-r--r--audio/gnump3d/files/patch-man_Makefile.in14
-rw-r--r--audio/gnump3d/files/patch-scripts_Makefile.in20
-rw-r--r--audio/gnump3d/files/patch-scripts_gnump3d-top.in14
-rw-r--r--audio/gnump3d/files/patch-templates_gnump3d.conf14
-rw-r--r--audio/gnump3d/pkg-plist1
7 files changed, 84 insertions, 6 deletions
diff --git a/audio/gnump3d/Makefile b/audio/gnump3d/Makefile
index 15b46857338c..726a38c9d02e 100644
--- a/audio/gnump3d/Makefile
+++ b/audio/gnump3d/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gnump3d
PORTVERSION= 0.9.9.9.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -23,11 +23,12 @@ USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= CONFIG_SHELL="${SH}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --libdir=${PREFIX}/lib/gnump3d
-MAN1= gnump3d.1 gnump3d.conf.1 gnump3d-config.1 gnump3d-top.1
+MAN1= gnump3d.1 gnump3d.conf.1 gnump3d-top.1
.if !defined(WITHOUT_VORBIS)
LIB_DEPENDS= vorbis.2:${PORTSDIR}/audio/libvorbis
@@ -45,8 +46,9 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|-D_THREAD_SAFE|${PTHREAD_CFLAGS}|g ; \
s|-pthread|${PTHREAD_LIBS}|g' ${WRKSRC}/aclocal.m4
- @${REINPLACE_CMD} -e \
- 's|#undef socklen_t||g' ${WRKSRC}/src/config.h.in
+# Avoid triggering automake
+ @${TOUCH} -r ${WRKSRC}/aclocal.m4.bak ${WRKSRC}/aclocal.m4
+ @${TOUCH} -r ${WRKSRC}/configure.in.orig ${WRKSRC}/configure.in
pre-configure:
.for dir in . mplib libltdl
diff --git a/audio/gnump3d/files/patch-configure.in b/audio/gnump3d/files/patch-configure.in
new file mode 100644
index 000000000000..849548066e57
--- /dev/null
+++ b/audio/gnump3d/files/patch-configure.in
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- configure.in.orig Wed Aug 14 14:45:44 2002
++++ configure.in Wed Aug 14 14:46:10 2002
+@@ -97,7 +97,8 @@
+
+ dnl check for Unix98 socklen_t
+ AC_MSG_CHECKING(for socklen_t)
+-AC_TRY_COMPILE([#include <sys/socket.h>
++AC_TRY_COMPILE([#include <sys/types.h>
++#include <sys/socket.h>
+ socklen_t x;
+ ],[],[AC_MSG_RESULT(yes)],[
+ AC_TRY_COMPILE([#include <sys/socket.h>
diff --git a/audio/gnump3d/files/patch-man_Makefile.in b/audio/gnump3d/files/patch-man_Makefile.in
new file mode 100644
index 000000000000..7fc35764a52f
--- /dev/null
+++ b/audio/gnump3d/files/patch-man_Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- man/Makefile.in.orig Wed Aug 14 02:19:33 2002
++++ man/Makefile.in Wed Aug 14 02:19:52 2002
+@@ -85,7 +85,7 @@
+ STRIP = @STRIP@
+ VERSION = @VERSION@
+
+-man_MANS = gnump3d.1 gnump3d-top.1 gnump3d.conf.1 gnump3d-config.1
++man_MANS = gnump3d.1 gnump3d-top.1 gnump3d.conf.1
+ mkinstalldirs = $(SHELL) $(top_srcdir)/config/mkinstalldirs
+ CONFIG_HEADER = ../src/config.h
+ CONFIG_CLEAN_FILES =
diff --git a/audio/gnump3d/files/patch-scripts_Makefile.in b/audio/gnump3d/files/patch-scripts_Makefile.in
new file mode 100644
index 000000000000..55dcaebfb1cd
--- /dev/null
+++ b/audio/gnump3d/files/patch-scripts_Makefile.in
@@ -0,0 +1,20 @@
+
+$FreeBSD$
+
+--- scripts/Makefile.in.orig Wed Aug 14 02:16:56 2002
++++ scripts/Makefile.in Wed Aug 14 02:18:25 2002
+@@ -195,11 +195,9 @@
+
+
+ install:
+- mkdir -p $(bindir)
+- cp gnump3d-config $(bindir)
+- cp gnump3d-top $(bindir)
+- chmod 755 $(bindir)/gnump3d-config
+- chmod 755 $(bindir)/gnump3d-top
++ $(mkinstalldirs) $(DESTDIR)$(bindir)
++# $(INSTALL_SCRIPT) gnump3d-config $(DESTDIR)$(bindir)
++ $(INSTALL_SCRIPT) gnump3d-top $(DESTDIR)$(bindir)
+
+ uninstall:
+ rm -f $(bindir)/gnump3d-config
diff --git a/audio/gnump3d/files/patch-scripts_gnump3d-top.in b/audio/gnump3d/files/patch-scripts_gnump3d-top.in
new file mode 100644
index 000000000000..c6767a1914e5
--- /dev/null
+++ b/audio/gnump3d/files/patch-scripts_gnump3d-top.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- scripts/gnump3d-top.in.orig Wed Aug 14 18:45:33 2002
++++ scripts/gnump3d-top.in Wed Aug 14 18:46:04 2002
+@@ -16,7 +16,7 @@
+
+ # The default logfile which we read if there is no
+ # --config options supplied on the command line.
+-my $DEFAULT_CONFIG = "/etc/mp3d/mp3d.conf";
++my $DEFAULT_CONFIG = "@prefix@/etc/gnump3d/gnump3d.conf";
+
+ #
+ # Options set by the command line arguments.
diff --git a/audio/gnump3d/files/patch-templates_gnump3d.conf b/audio/gnump3d/files/patch-templates_gnump3d.conf
new file mode 100644
index 000000000000..6e3f9c69b764
--- /dev/null
+++ b/audio/gnump3d/files/patch-templates_gnump3d.conf
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- templates/gnump3d.conf.orig Wed Aug 14 02:11:42 2002
++++ templates/gnump3d.conf Wed Aug 14 02:13:23 2002
+@@ -143,7 +143,7 @@
+ # you run the server as a user such as 'nobody', and allow people read-only
+ # access to your audio files.
+ #
+-user = nobody
++user = www
+
+
+ #
diff --git a/audio/gnump3d/pkg-plist b/audio/gnump3d/pkg-plist
index 548f6ec6e34e..a03774cabc42 100644
--- a/audio/gnump3d/pkg-plist
+++ b/audio/gnump3d/pkg-plist
@@ -1,6 +1,5 @@
@comment $FreeBSD$
bin/gnump3d
-bin/gnump3d-config
bin/gnump3d-top
etc/gnump3d/default/error.html
etc/gnump3d/default/index.html