aboutsummaryrefslogtreecommitdiff
path: root/audio/gnump3d
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2008-03-18 09:30:27 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2008-03-18 09:30:27 +0000
commitebcb4d14adf19fb4d52aaea01229d80ceb7d980a (patch)
tree1a7e19ffea87ca78ba888c3d66049ff315a8c956 /audio/gnump3d
parent8fb9e5275f463f15e6e5d6aadef2a8c248748c7e (diff)
downloadports-ebcb4d14adf19fb4d52aaea01229d80ceb7d980a.tar.gz
ports-ebcb4d14adf19fb4d52aaea01229d80ceb7d980a.zip
Notes
Diffstat (limited to 'audio/gnump3d')
-rw-r--r--audio/gnump3d/Makefile6
-rw-r--r--audio/gnump3d/distinfo6
-rw-r--r--audio/gnump3d/files/gnump3d.sh.in2
-rw-r--r--audio/gnump3d/files/patch-bin::gnump3d-index12
-rw-r--r--audio/gnump3d/files/patch-bin::gnump3d-top12
-rw-r--r--audio/gnump3d/files/patch-bin::gnump3d216
-rw-r--r--audio/gnump3d/files/patch-etc::gnump3d.conf78
-rw-r--r--audio/gnump3d/pkg-plist36
8 files changed, 95 insertions, 73 deletions
diff --git a/audio/gnump3d/Makefile b/audio/gnump3d/Makefile
index 3b34118aa458..d1f9fc2fa877 100644
--- a/audio/gnump3d/Makefile
+++ b/audio/gnump3d/Makefile
@@ -6,13 +6,12 @@
#
PORTNAME= gnump3d
-PORTVERSION= 2.9.8
-PORTREVISION= 1
+PORTVERSION= 3.0
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= xride@FreeBSD.org
+MAINTAINER= jadawin@FreeBSD.org
COMMENT= Streaming server for MP3, Ogg Vorbis and other streamable audio files
RUN_DEPENDS= lame:${PORTSDIR}/audio/lame \
@@ -60,6 +59,7 @@ do-install:
${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}
${MKDIR} ${CONFDIR}
${INSTALL_DATA} ${WRKSRC}/etc/mime.types ${CONFDIR}
+ ${INSTALL_DATA} ${WRKSRC}/etc/file.types ${CONFDIR}
${INSTALL_DATA} ${WRKSRC}/etc/gnump3d.conf \
${CONFDIR}/gnump3d.conf-default
.if !exists(${PREFIX}/etc/${PORTNAME}/gnump3d.conf)
diff --git a/audio/gnump3d/distinfo b/audio/gnump3d/distinfo
index 83e791e3b6fc..bc1a7a9ff57c 100644
--- a/audio/gnump3d/distinfo
+++ b/audio/gnump3d/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnump3d-2.9.8.tar.bz2) = 60abbe007d5771a072727ea8aab9552a
-SHA256 (gnump3d-2.9.8.tar.bz2) = abe3a6135ba0defbadde6d8048cbe0008d228c2996f43c42fd21909e1535779a
-SIZE (gnump3d-2.9.8.tar.bz2) = 623334
+MD5 (gnump3d-3.0.tar.bz2) = 41786650bbc591484c08014a89478bf9
+SHA256 (gnump3d-3.0.tar.bz2) = 1ac5bd0e850b0e18ccd9d19219f5108fa84b50d8ae3825a361e8b907eab7f19c
+SIZE (gnump3d-3.0.tar.bz2) = 633215
diff --git a/audio/gnump3d/files/gnump3d.sh.in b/audio/gnump3d/files/gnump3d.sh.in
index 9efd9c2c9a62..15bc9cf35bf8 100644
--- a/audio/gnump3d/files/gnump3d.sh.in
+++ b/audio/gnump3d/files/gnump3d.sh.in
@@ -8,7 +8,7 @@
gnump3d_enable=${gnump3d_enable-"NO"}
gnump3d_program=${gnump3d_program:-%%PREFIX%%/bin/gnump3d}
-gnump3d_flags=${gnump3d_flags-"--quiet --background"}
+gnump3d_flags=${gnump3d_flags-"--fast --quiet --background"}
gnump3d_pidfile=${gnump3d_pidfile:-/var/run/gnump3d.pid}
name="gnump3d"
diff --git a/audio/gnump3d/files/patch-bin::gnump3d-index b/audio/gnump3d/files/patch-bin::gnump3d-index
index d98ce62bc3e7..fead1b638b39 100644
--- a/audio/gnump3d/files/patch-bin::gnump3d-index
+++ b/audio/gnump3d/files/patch-bin::gnump3d-index
@@ -1,14 +1,14 @@
---- bin/gnump3d-index.orig Fri Mar 26 03:49:02 2004
-+++ bin/gnump3d-index Fri Mar 26 12:54:24 2004
-@@ -68,9 +68,9 @@
+--- bin/gnump3d-index.orig 2008-01-03 11:24:28.000000000 +0000
++++ bin/gnump3d-index 2008-01-03 11:24:59.000000000 +0000
+@@ -150,9 +150,9 @@
{
- $CONFIG_FILE = $ENV{"HOME"} . "/.gnump3drc";
+ $CONFIG{'file'} = $ENV{"HOME"} . "/.gnump3drc";
}
-elsif ( -e "/etc/gnump3d/gnump3d.conf" )
+elsif ( -e "%%PREFIX%%/etc/gnump3d/gnump3d.conf" )
{
-- $CONFIG_FILE = "/etc/gnump3d/gnump3d.conf";
-+ $CONFIG_FILE = "%%PREFIX%%/etc/gnump3d/gnump3d.conf";
+- $CONFIG{'file'} = "/etc/gnump3d/gnump3d.conf";
++ $CONFIG{'file'} = "%%PREFIX%%/etc/gnump3d/gnump3d.conf";
}
elsif ( -e "gnump3d.conf" )
{
diff --git a/audio/gnump3d/files/patch-bin::gnump3d-top b/audio/gnump3d/files/patch-bin::gnump3d-top
index efb2a64198bf..6c3b37699456 100644
--- a/audio/gnump3d/files/patch-bin::gnump3d-top
+++ b/audio/gnump3d/files/patch-bin::gnump3d-top
@@ -1,8 +1,8 @@
---- bin/gnump3d-top.orig Tue Feb 4 18:25:13 2003
-+++ bin/gnump3d-top Mon Feb 10 09:24:01 2003
-@@ -63,12 +63,12 @@
+--- bin/gnump3d-top.orig 2008-01-03 11:25:59.000000000 +0000
++++ bin/gnump3d-top 2008-01-03 11:26:30.000000000 +0000
+@@ -126,12 +126,12 @@
{
- $DEFAULT_CONFIG = $ENV{"HOME"} . "/.gnump3drc";
+ $CONFIG{'file'} = $ENV{"HOME"} . "/.gnump3drc";
}
-elsif ( -e "/etc/gnump3d/gnump3d.conf" )
+elsif ( -e "%%PREFIX%%/etc/gnump3d/gnump3d.conf" )
@@ -10,8 +10,8 @@
#
# Otherwise the system wide one.
#
-- $DEFAULT_CONFIG = "/etc/gnump3d/gnump3d.conf";
-+ $DEFAULT_CONFIG = "%%PREFIX%%/etc/gnump3d/gnump3d.conf";
+- $CONFIG{'file'} = "/etc/gnump3d/gnump3d.conf";
++ $CONFIG{'file'} = "%%PREFIX%%/etc/gnump3d/gnump3d.conf";
}
elsif ( -e "gnump3d.conf" )
{
diff --git a/audio/gnump3d/files/patch-bin::gnump3d2 b/audio/gnump3d/files/patch-bin::gnump3d2
index aa90cb517a75..e1b5a4b5e521 100644
--- a/audio/gnump3d/files/patch-bin::gnump3d2
+++ b/audio/gnump3d/files/patch-bin::gnump3d2
@@ -1,6 +1,6 @@
---- bin/gnump3d2.orig Fri Mar 26 03:49:02 2004
-+++ bin/gnump3d2 Fri Mar 26 12:57:38 2004
-@@ -3052,10 +3052,10 @@
+--- bin/gnump3d2.orig 2008-01-03 11:26:53.000000000 +0000
++++ bin/gnump3d2 2008-01-03 11:30:54.000000000 +0000
+@@ -3126,10 +3126,10 @@
# This is mainly here for Windows users.
$CONFIG_FILE = "gnump3d.conf";
}
@@ -13,18 +13,18 @@
}
-@@ -3183,8 +3183,8 @@
+@@ -3246,8 +3246,8 @@
$PORT = getConfig( "port", 8888 );
$bind_address = getConfig( "binding_host", "" );
$host = getConfig( "hostname", "localhost" );
- $theme_dir = getConfig( "theme_directory", "/usr/share/gnump3d" );
- $plugin_dir = getConfig( "plugin_directory", "/usr/lib/perl5/gnump3d/plugins" );
+ $theme_dir = getConfig( "theme_directory", "%%PREFIX%%/share/gnump3d" );
-+ $plugin_dir = getConfig( "plugin_directory", "%%SITE_PERL%%/gnump3d/plugins" );
++ $plugin_dir = getConfig( "plugin_directory", "%%SITE_PERL%%/perl5/gnump3d/plugins" );
$always_stream = getConfig( "always_stream", 1 );
$access_log = getConfig( "logfile", "/var/log/gnump3d/access.log" );
$error_log = getConfig( "errorlog", "/var/log/gnump3d/error.log" );
-@@ -3192,11 +3192,11 @@
+@@ -3255,12 +3255,12 @@
$client_host = getConfig( "use_client_host", 1 );
$default_theme = getConfig( "theme", "default" );
$TIMEOUT = getConfig( "read_time", 10 );
@@ -35,11 +35,13 @@
$STATSARGS = getConfig( "stats_arguments", "" );
$play_rec = getConfig( "play_recursively_text", "Play" );
- $mime_file = getConfig( "mime_file", "/etc/gnump3d/mime.types" );
+- $file_types = getConfig( "file_types", "/etc/gnump3d/file.types" );
+ $mime_file = getConfig( "mime_file", "%%PREFIX%%/etc/gnump3d/mime.types" );
++ $file_types = getConfig( "file_types", "%%PREFIX%%/etc/gnump3d/file.types" );
$enable_browse = getConfig( "enable_browsing", 1 );
$sort_order = getConfig( "sort_order", '$FILENAME' );
-@@ -3238,7 +3238,7 @@
+@@ -3316,7 +3316,7 @@
# Experimental features.
#
$jukebox = getConfig( "jukebox_mode", 0 );
diff --git a/audio/gnump3d/files/patch-etc::gnump3d.conf b/audio/gnump3d/files/patch-etc::gnump3d.conf
index 249e1a505d5b..59b7a85fa06a 100644
--- a/audio/gnump3d/files/patch-etc::gnump3d.conf
+++ b/audio/gnump3d/files/patch-etc::gnump3d.conf
@@ -1,6 +1,6 @@
---- etc/gnump3d.conf.orig Tue May 18 22:21:40 2004
-+++ etc/gnump3d.conf Wed May 19 01:39:32 2004
-@@ -184,7 +184,7 @@
+--- etc/gnump3d.conf.orig 2007-10-18 17:34:02.000000000 +0000
++++ etc/gnump3d.conf 2008-01-03 15:27:12.000000000 +0000
+@@ -172,7 +172,7 @@
# path if you don't have it installed upon the $PATH of the user
# who starts the server:
#
@@ -9,7 +9,7 @@
#
#
# For example you may change the default number of lines which are
-@@ -435,7 +435,7 @@
+@@ -393,7 +393,7 @@
# the URL http://server.host.name:port/stats/, and reads in a template
# called 'stats.html'
#
@@ -18,7 +18,7 @@
# changed via the 'theme_directory' setting given below.
#
# When the server is running you may set the theme from your browser
-@@ -462,7 +462,7 @@
+@@ -420,7 +420,7 @@
# location.
#
##
@@ -27,29 +27,73 @@
##
-@@ -686,9 +686,9 @@
+@@ -659,13 +659,13 @@
#
# downsample_"level"_"file suffix" = command args
#
-#downsample_high_mp3 = /usr/bin/lame --mp3input -b 56 $FILENAME -
-#downsample_medium_mp3 = /usr/bin/lame --mp3input -b 32 $FILENAME -
-#downsample_low_mp3 = /usr/bin/lame --mp3input -b 16 $FILENAME -
-+#downsample_high_mp3 = %%LOCALBASE%%/bin/lame --mp3input -b 56 $FILENAME -
-+#downsample_medium_mp3 = %%LOCALBASE%%/bin/lame --mp3input -b 32 $FILENAME -
-+#downsample_low_mp3 = %%LOCALBASE%%/bin/lame --mp3input -b 16 $FILENAME -
- #
- #downsample_high_ogg = sox -t ogg $FILENAME -t raw - | oggenc --raw --downmix -b 96 -
- #downsample_medium_ogg = sox -t ogg $FILENAME -t raw - | oggenc --raw --downmix -b 64 -
-@@ -728,7 +728,7 @@
- # the installation script - if this doesn't happen report this as
+-#
+-#downsample_high_ogg = /usr/bin/sox -t ogg $FILENAME -t raw - | oggenc --raw --downmix -b 96 -
+-#downsample_medium_ogg = /usr/bin/sox -t ogg $FILENAME -t raw - | oggenc --raw --downmix -b 64 -
+-#downsample_low_ogg = /usr/bin/sox -t ogg $FILENAME -t raw - | oggenc --raw --downmix --resample 22050 -b 32 -
++#downsample_high_mp3 = %%PREFIX%%/bin/lame --mp3input -b 56 $FILENAME -
++#downsample_medium_mp3 = %%PREFIX%%/bin/lame --mp3input -b 32 $FILENAME -
++#downsample_low_mp3 = %%PREFIX%%/bin/lame --mp3input -b 16 $FILENAME -
++#
++#downsample_high_ogg = %%PREFIX%%/bin/sox -t ogg $FILENAME -t raw - | oggenc --raw --downmix -b 96 -
++#downsample_medium_ogg = %%PREFIX%%/bin/sox -t ogg $FILENAME -t raw - | oggenc --raw --downmix -b 64 -
++#downsample_low_ogg = %%PREFIX%%/bin/sox -t ogg $FILENAME -t raw - | oggenc --raw --downmix --resample 22050 -b 32 -
+ #
+
+ #
+@@ -702,7 +702,7 @@
# a bug.
#
+
-plugin_directory = PLUGINDIR/gnump3d/plugins
+plugin_directory = %%SITE_PERL%%/gnump3d/plugins
+
+
+ #
+@@ -740,7 +740,7 @@
+ # used by default. If not point this next file to wherever your mime
+ # types file is located:
+ #
+-mime_file = /etc/gnump3d/mime.types
++mime_file = %%PREFIX%%/etc/gnump3d/mime.types
+ #
+ #
+
+@@ -751,7 +751,7 @@
+ # file it is.
+ #
+ # Here is the lookup file.
+-file_types = /etc/gnump3d/file.types
++file_types = %%PREFIX%%/etc/gnump3d/file.types
+
+ #
+ #
+@@ -761,7 +761,7 @@
#
+ # The path under which these files are created in may be set here.
+ #
+-now_playing_path = /var/cache/gnump3d/serving
++now_playing_path = /tmp/gnump3d/serving
-@@ -823,7 +823,7 @@
+ #
+@@ -772,7 +772,7 @@
+ # This next setting controls where that script will write its tag database
+ # to.
+ #
+-tag_cache = /var/cache/gnump3d/song.tags
++tag_cache = /tmp/gnump3d/song.tags
+
+ #
+ # This next setting allows you to control the path to the gnump3d-index
+@@ -780,7 +780,7 @@
#
# Normally you shouldn't need to touch this.
#
@@ -58,12 +102,12 @@
#
-@@ -900,7 +900,7 @@
+@@ -870,7 +870,7 @@
##
#
# jukebox_mode = 1
-# jukebox_player = /usr/bin/mpg123 $FILENAME
-+# jukebox_player = %%LOCALBASE%%/bin/mpg123 $FILENAME
++# jukebox_player = %%LOCALBAS%%/bin/mpg123 $FILENAME
#
##
diff --git a/audio/gnump3d/pkg-plist b/audio/gnump3d/pkg-plist
index 22c5742f1a32..889e49d55150 100644
--- a/audio/gnump3d/pkg-plist
+++ b/audio/gnump3d/pkg-plist
@@ -7,13 +7,18 @@ bin/gnump3d2
etc/gnump3d/gnump3d.conf-default
@exec [ -f %B/gnump3d.conf ] || cp %B/%f %B/gnump3d.conf
etc/gnump3d/mime.types
+etc/gnump3d/file.types
%%SITE_PERL%%/gnump3d/IP.pm
%%SITE_PERL%%/gnump3d/MD5.pm
%%SITE_PERL%%/gnump3d/WMA.pm
+%%SITE_PERL%%/gnump3d/filetypes.pm
+%%SITE_PERL%%/gnump3d/Request.pm
%%SITE_PERL%%/gnump3d/base64.pm
%%SITE_PERL%%/gnump3d/config.pm
%%SITE_PERL%%/gnump3d/files.pm
+%%SITE_PERL%%/gnump3d/HTML/Template.pm
%%SITE_PERL%%/gnump3d/lang/de.pm
+%%SITE_PERL%%/gnump3d/lang/ba.pm
%%SITE_PERL%%/gnump3d/lang/en.pm
%%SITE_PERL%%/gnump3d/lang/es.pm
%%SITE_PERL%%/gnump3d/lang/fr.pm
@@ -21,8 +26,6 @@ etc/gnump3d/mime.types
%%SITE_PERL%%/gnump3d/mp3info.pm
%%SITE_PERL%%/gnump3d/mp4info.pm
%%SITE_PERL%%/gnump3d/ogginfo.pm
-%%SITE_PERL%%/gnump3d/oggtagreader.pm
-%%SITE_PERL%%/gnump3d/plugins/bug.pm
%%SITE_PERL%%/gnump3d/plugins/copying.pm
%%SITE_PERL%%/gnump3d/plugins/info.pm
%%SITE_PERL%%/gnump3d/plugins/now.pm
@@ -41,8 +44,6 @@ etc/gnump3d/mime.types
%%DATADIR%%/Avalon/AUTHOR
%%DATADIR%%/Avalon/COPYING.html
%%DATADIR%%/Avalon/base.css
-%%DATADIR%%/Avalon/bug.html
-%%DATADIR%%/Avalon/config.ini
%%DATADIR%%/Avalon/error.html
%%DATADIR%%/Avalon/gnump3d-logo.jpg
%%DATADIR%%/Avalon/html_footer.tmpl
@@ -65,8 +66,6 @@ etc/gnump3d/mime.types
%%DATADIR%%/BlueBox/AUTHOR
%%DATADIR%%/BlueBox/BlueBox.css
%%DATADIR%%/BlueBox/COPYING.html
-%%DATADIR%%/BlueBox/bug.html
-%%DATADIR%%/BlueBox/config.ini
%%DATADIR%%/BlueBox/error.html
%%DATADIR%%/BlueBox/extras.html
%%DATADIR%%/BlueBox/footer.tmpl
@@ -87,8 +86,6 @@ etc/gnump3d/mime.types
%%DATADIR%%/BlueBox/template.ini
%%DATADIR%%/Clean/AUTHOR
%%DATADIR%%/Clean/COPYING.html
-%%DATADIR%%/Clean/bug.html
-%%DATADIR%%/Clean/config.ini
%%DATADIR%%/Clean/error.html
%%DATADIR%%/Clean/index.html
%%DATADIR%%/Clean/info.html
@@ -106,8 +103,6 @@ etc/gnump3d/mime.types
%%DATADIR%%/Clean/tagbrowse.html
%%DATADIR%%/LaFrere/AUTHOR
%%DATADIR%%/LaFrere/COPYING.html
-%%DATADIR%%/LaFrere/bug.html
-%%DATADIR%%/LaFrere/config.ini
%%DATADIR%%/LaFrere/error.html
%%DATADIR%%/LaFrere/index.html
%%DATADIR%%/LaFrere/info.html
@@ -125,7 +120,6 @@ etc/gnump3d/mime.types
%%DATADIR%%/Liquid/AUTHOR
%%DATADIR%%/Liquid/COPYING.html
%%DATADIR%%/Liquid/bck.gif
-%%DATADIR%%/Liquid/bug.html
%%DATADIR%%/Liquid/cel-bar-anthrazite-act.gif
%%DATADIR%%/Liquid/cel-bar-anthrazite.gif
%%DATADIR%%/Liquid/cel-bar-aqua-act.gif
@@ -142,7 +136,6 @@ etc/gnump3d/mime.types
%%DATADIR%%/Liquid/cel-bar-turqois.gif
%%DATADIR%%/Liquid/cel-bar-yellow-act.gif
%%DATADIR%%/Liquid/cel-bar-yellow.gif
-%%DATADIR%%/Liquid/config.ini
%%DATADIR%%/Liquid/error.html
%%DATADIR%%/Liquid/footer.tmpl
%%DATADIR%%/Liquid/gnump3dskin.webprj
@@ -176,8 +169,6 @@ etc/gnump3d/mime.types
%%DATADIR%%/Liquid/tagbrowse.html
%%DATADIR%%/Musicus/AUTHOR
%%DATADIR%%/Musicus/COPYING.html
-%%DATADIR%%/Musicus/bug.html
-%%DATADIR%%/Musicus/config.ini
%%DATADIR%%/Musicus/error.html
%%DATADIR%%/Musicus/extras.html
%%DATADIR%%/Musicus/footer.tmpl
@@ -202,8 +193,6 @@ etc/gnump3d/mime.types
%%DATADIR%%/Nomad/Nomad_theme.css
%%DATADIR%%/Nomad/SmallHome.gif
%%DATADIR%%/Nomad/bg.gif
-%%DATADIR%%/Nomad/bug.html
-%%DATADIR%%/Nomad/config.ini
%%DATADIR%%/Nomad/error.html
%%DATADIR%%/Nomad/gnump3d_themes_footer.tmpl
%%DATADIR%%/Nomad/gnump3d_themes_header.tmpl
@@ -223,9 +212,7 @@ etc/gnump3d/mime.types
%%DATADIR%%/README
%%DATADIR%%/SchwartzNGrau/AUTHOR
%%DATADIR%%/SchwartzNGrau/COPYING.html
-%%DATADIR%%/SchwartzNGrau/bug.html
%%DATADIR%%/SchwartzNGrau/clear.gif
-%%DATADIR%%/SchwartzNGrau/config.ini
%%DATADIR%%/SchwartzNGrau/error.html
%%DATADIR%%/SchwartzNGrau/index.html
%%DATADIR%%/SchwartzNGrau/info.html
@@ -242,8 +229,6 @@ etc/gnump3d/mime.types
%%DATADIR%%/SchwartzNGrau/tagbrowse.html
%%DATADIR%%/Tabular/AUTHOR
%%DATADIR%%/Tabular/COPYING.html
-%%DATADIR%%/Tabular/bug.html
-%%DATADIR%%/Tabular/config.ini
%%DATADIR%%/Tabular/error.html
%%DATADIR%%/Tabular/extras.html
%%DATADIR%%/Tabular/footer.tmpl
@@ -264,8 +249,6 @@ etc/gnump3d/mime.types
%%DATADIR%%/Tabular/template.ini
%%DATADIR%%/Thexder/AUTHOR
%%DATADIR%%/Thexder/COPYING.html
-%%DATADIR%%/Thexder/bug.html
-%%DATADIR%%/Thexder/config.ini
%%DATADIR%%/Thexder/dig_temp2_01.jpg
%%DATADIR%%/Thexder/dig_temp2_02.jpg
%%DATADIR%%/Thexder/dig_temp2_03.gif
@@ -296,8 +279,6 @@ etc/gnump3d/mime.types
%%DATADIR%%/Thexder/stats.html
%%DATADIR%%/default/AUTHOR
%%DATADIR%%/default/COPYING.html
-%%DATADIR%%/default/bug.html
-%%DATADIR%%/default/config.ini
%%DATADIR%%/default/error.html
%%DATADIR%%/default/footer.tmpl
%%DATADIR%%/default/header.tmpl
@@ -316,8 +297,6 @@ etc/gnump3d/mime.types
%%DATADIR%%/default/tagbrowse.html
%%DATADIR%%/dotNET/AUTHOR
%%DATADIR%%/dotNET/COPYING.html
-%%DATADIR%%/dotNET/bug.html
-%%DATADIR%%/dotNET/config.ini
%%DATADIR%%/dotNET/content.tmpl
%%DATADIR%%/dotNET/error.html
%%DATADIR%%/dotNET/header.tmpl
@@ -344,7 +323,6 @@ etc/gnump3d/mime.types
%%DATADIR%%/dotNET/stats.html
%%DATADIR%%/dotNET/style.css
%%DATADIR%%/handheld/AUTHOR
-%%DATADIR%%/handheld/config.ini
%%DATADIR%%/handheld/error.html
%%DATADIR%%/handheld/index.html
%%DATADIR%%/handheld/random.html
@@ -352,8 +330,6 @@ etc/gnump3d/mime.types
%%DATADIR%%/handheld/search.html
%%DATADIR%%/nausicaa/AUTHOR
%%DATADIR%%/nausicaa/COPYING.html
-%%DATADIR%%/nausicaa/bug.html
-%%DATADIR%%/nausicaa/config.ini
%%DATADIR%%/nausicaa/error.html
%%DATADIR%%/nausicaa/extras.html
%%DATADIR%%/nausicaa/index.html
@@ -369,7 +345,6 @@ etc/gnump3d/mime.types
%%DATADIR%%/nausicaa/style.css
%%DATADIR%%/redgrey/AUTHOR
%%DATADIR%%/redgrey/COPYING.html
-%%DATADIR%%/redgrey/bug.html
%%DATADIR%%/redgrey/error.html
%%DATADIR%%/redgrey/header.tmpl
%%DATADIR%%/redgrey/index.html
@@ -402,6 +377,7 @@ etc/gnump3d/mime.types
@dirrm %%DATADIR%%
@dirrm %%SITE_PERL%%/gnump3d/plugins
@dirrm %%SITE_PERL%%/gnump3d/lang
+@dirrm %%SITE_PERL%%/gnump3d/HTML
@dirrm %%SITE_PERL%%/gnump3d
@dirrmtry etc/gnump3d
@unexec rmdir /var/log/gnump3d 2>/dev/null || true