aboutsummaryrefslogtreecommitdiff
path: root/audio/gnump3d
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2003-01-02 02:10:13 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2003-01-02 02:10:13 +0000
commit563c3d6931962d07b2905dc7031e01c658f4ae1a (patch)
treeb0b9834f183776da4654b21c4733bed67c7bf4d7 /audio/gnump3d
parent6bb8303324c6e2b364fd934bc829009107864c5f (diff)
downloadports-563c3d6931962d07b2905dc7031e01c658f4ae1a.tar.gz
ports-563c3d6931962d07b2905dc7031e01c658f4ae1a.zip
Notes
Diffstat (limited to 'audio/gnump3d')
-rw-r--r--audio/gnump3d/Makefile18
-rw-r--r--audio/gnump3d/distinfo2
-rw-r--r--audio/gnump3d/files/patch-config::ltmain.sh9
-rw-r--r--audio/gnump3d/files/patch-plugins_bug.cc14
-rw-r--r--audio/gnump3d/files/patch-plugins_last20.cc14
-rw-r--r--audio/gnump3d/files/patch-plugins_now.cc14
-rw-r--r--audio/gnump3d/files/patch-plugins_playlist.cc15
-rw-r--r--audio/gnump3d/files/patch-plugins_search.cc15
-rw-r--r--audio/gnump3d/files/patch-plugins_stats.cc14
-rw-r--r--audio/gnump3d/files/patch-plugins_theme.cc15
-rw-r--r--audio/gnump3d/files/patch-plugins_version.cc15
-rw-r--r--audio/gnump3d/files/patch-scripts_gnump3d-top.in8
-rw-r--r--audio/gnump3d/files/patch-src_request.cc13
-rw-r--r--audio/gnump3d/pkg-plist20
14 files changed, 162 insertions, 24 deletions
diff --git a/audio/gnump3d/Makefile b/audio/gnump3d/Makefile
index 727bc7ea9d89..001eae0eb3ac 100644
--- a/audio/gnump3d/Makefile
+++ b/audio/gnump3d/Makefile
@@ -7,26 +7,26 @@
#
PORTNAME= gnump3d
-PORTVERSION= 1.0.p1
+PORTVERSION= 1.0
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-1.0-pre1
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf
-
USE_BZIP2= yes
USE_PERL5= yes
USE_REINPLACE= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+USE_AUTOCONF_VER= 253
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CONFIG_SHELL="${SH}" \
CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --libdir=${PREFIX}/lib/gnump3d
+# Avoid triggering automake
+MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOHEADER="${TRUE}" \
+ AUTOMAKE="${TRUE}"
MAN1= gnump3d.1 gnump3d.conf.1 gnump3d-top.1
@@ -44,15 +44,13 @@ pre-everything::
.endif
post-patch:
- @${TOUCH} -r ${WRKSRC}/aclocal.m4 ${WRKSRC}/aclocal.m4.time
@${REINPLACE_CMD} -e 's|-D_THREAD_SAFE|${PTHREAD_CFLAGS}|g ; \
s|-pthread|${PTHREAD_LIBS}|g' ${WRKSRC}/aclocal.m4
-# Avoid triggering automake
- @${TOUCH} -r ${WRKSRC}/aclocal.m4.time ${WRKSRC}/aclocal.m4
pre-configure:
-.for dir in . mplib libltdl
- @cd ${WRKSRC}/${dir} && ${LOCALBASE}/bin/autoconf
+.for dir in libltdl mplib
+ @(cd ${WRKSRC}/${dir} && ${SETENV} ${AUTOCONF_ENV} ${AUTOCONF} \
+ ${AUTOCONF_ARGS})
.endfor
post-install:
diff --git a/audio/gnump3d/distinfo b/audio/gnump3d/distinfo
index 2306bff35f12..4f9d9e969208 100644
--- a/audio/gnump3d/distinfo
+++ b/audio/gnump3d/distinfo
@@ -1 +1 @@
-MD5 (gnump3d-1.0-pre1.tar.bz2) = bd89ca74bc354ad65827be3cd572dad9
+MD5 (gnump3d-1.0.tar.bz2) = 842d03a1e0421422c1a94c2c86273991
diff --git a/audio/gnump3d/files/patch-config::ltmain.sh b/audio/gnump3d/files/patch-config::ltmain.sh
index 8015c0c75789..de649ecde73f 100644
--- a/audio/gnump3d/files/patch-config::ltmain.sh
+++ b/audio/gnump3d/files/patch-config::ltmain.sh
@@ -11,12 +11,3 @@ $FreeBSD$
avoid_version=yes
continue
;;
-@@ -1061,7 +1062,7 @@
- esac
- elif test "X$arg" = "X-lc_r"; then
- case $host in
-- *-*-openbsd* | *-*-freebsd*)
-+ *-*-openbsd*)
- # Do not include libc_r directly, use -pthread flag.
- continue
- ;;
diff --git a/audio/gnump3d/files/patch-plugins_bug.cc b/audio/gnump3d/files/patch-plugins_bug.cc
new file mode 100644
index 000000000000..5a5cfc56ccc8
--- /dev/null
+++ b/audio/gnump3d/files/patch-plugins_bug.cc
@@ -0,0 +1,14 @@
+--- plugins/bug.cc.orig Fri Nov 29 04:33:21 2002
++++ plugins/bug.cc Mon Dec 2 19:27:02 2002
+@@ -40,6 +40,11 @@
+ #include <sys/utsname.h>
+
+
++#ifdef HAVE_PTHREAD
++# include <pthread.h>
++#endif
++
++
+ #include "debug.h"
+ #include "iplugin.h"
+ #include "request.h"
diff --git a/audio/gnump3d/files/patch-plugins_last20.cc b/audio/gnump3d/files/patch-plugins_last20.cc
new file mode 100644
index 000000000000..72baad51021c
--- /dev/null
+++ b/audio/gnump3d/files/patch-plugins_last20.cc
@@ -0,0 +1,14 @@
+--- plugins/last20.cc.orig Fri Nov 29 04:33:21 2002
++++ plugins/last20.cc Mon Dec 2 19:29:11 2002
+@@ -40,6 +40,11 @@
+ #include <fstream.h>
+
+
++#ifdef HAVE_PTHREAD
++# include <pthread.h>
++#endif
++
++
+ #include "debug.h"
+ #include "files.h"
+ #include "iplugin.h"
diff --git a/audio/gnump3d/files/patch-plugins_now.cc b/audio/gnump3d/files/patch-plugins_now.cc
new file mode 100644
index 000000000000..4cc4b6268411
--- /dev/null
+++ b/audio/gnump3d/files/patch-plugins_now.cc
@@ -0,0 +1,14 @@
+--- plugins/now.cc.orig Fri Nov 29 04:33:21 2002
++++ plugins/now.cc Mon Dec 2 19:30:10 2002
+@@ -40,6 +40,11 @@
+ #include <fstream.h>
+
+
++#ifdef HAVE_PTHREAD
++# include <pthread.h>
++#endif
++
++
+ #include "debug.h"
+ #include "iplugin.h"
+ #include "files.h"
diff --git a/audio/gnump3d/files/patch-plugins_playlist.cc b/audio/gnump3d/files/patch-plugins_playlist.cc
new file mode 100644
index 000000000000..d0593e6e51fb
--- /dev/null
+++ b/audio/gnump3d/files/patch-plugins_playlist.cc
@@ -0,0 +1,15 @@
+--- plugins/playlist.cc.orig Fri Nov 29 04:33:21 2002
++++ plugins/playlist.cc Mon Dec 2 19:35:39 2002
+@@ -39,6 +39,12 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+
++
++#ifdef HAVE_PTHREAD
++# include <pthread.h>
++#endif
++
++
+ #include "debug.h"
+ #include "iplugin.h"
+ #include "files.h"
diff --git a/audio/gnump3d/files/patch-plugins_search.cc b/audio/gnump3d/files/patch-plugins_search.cc
new file mode 100644
index 000000000000..3b0bdb477e1d
--- /dev/null
+++ b/audio/gnump3d/files/patch-plugins_search.cc
@@ -0,0 +1,15 @@
+--- plugins/search.cc.orig Fri Nov 29 04:33:21 2002
++++ plugins/search.cc Mon Dec 2 19:31:03 2002
+@@ -38,6 +38,12 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+
++
++#ifdef HAVE_PTHREAD
++# include <pthread.h>
++#endif
++
++
+ #include "files.h"
+ #include "debug.h"
+ #include "dirs.h"
diff --git a/audio/gnump3d/files/patch-plugins_stats.cc b/audio/gnump3d/files/patch-plugins_stats.cc
new file mode 100644
index 000000000000..8c07c8ca29ed
--- /dev/null
+++ b/audio/gnump3d/files/patch-plugins_stats.cc
@@ -0,0 +1,14 @@
+--- plugins/stats.cc.orig Fri Nov 29 04:33:21 2002
++++ plugins/stats.cc Mon Dec 2 19:32:09 2002
+@@ -39,6 +39,11 @@
+ #include <stdlib.h>
+
+
++#ifdef HAVE_PTHREAD
++# include <pthread.h>
++#endif
++
++
+ #include "debug.h"
+ #include "request.h"
+ #include "settings.h"
diff --git a/audio/gnump3d/files/patch-plugins_theme.cc b/audio/gnump3d/files/patch-plugins_theme.cc
new file mode 100644
index 000000000000..25932a587ede
--- /dev/null
+++ b/audio/gnump3d/files/patch-plugins_theme.cc
@@ -0,0 +1,15 @@
+--- plugins/theme.cc.orig Fri Nov 29 04:33:21 2002
++++ plugins/theme.cc Mon Dec 2 19:34:54 2002
+@@ -39,6 +39,12 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+
++
++#ifdef HAVE_PTHREAD
++# include <pthread.h>
++#endif
++
++
+ #include "debug.h"
+ #include "dirs.h"
+ #include "files.h"
diff --git a/audio/gnump3d/files/patch-plugins_version.cc b/audio/gnump3d/files/patch-plugins_version.cc
new file mode 100644
index 000000000000..a9e6b4a1bb57
--- /dev/null
+++ b/audio/gnump3d/files/patch-plugins_version.cc
@@ -0,0 +1,15 @@
+--- plugins/version.cc.orig Fri Nov 29 04:33:21 2002
++++ plugins/version.cc Mon Dec 2 19:36:44 2002
+@@ -38,6 +38,12 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+
++
++#ifdef HAVE_PTHREAD
++# include <pthread.h>
++#endif
++
++
+ #include "debug.h"
+ #include "iplugin.h"
+ #include "plugin.h"
diff --git a/audio/gnump3d/files/patch-scripts_gnump3d-top.in b/audio/gnump3d/files/patch-scripts_gnump3d-top.in
index c6767a1914e5..7bb80ad6d316 100644
--- a/audio/gnump3d/files/patch-scripts_gnump3d-top.in
+++ b/audio/gnump3d/files/patch-scripts_gnump3d-top.in
@@ -1,13 +1,13 @@
$FreeBSD$
---- scripts/gnump3d-top.in.orig Wed Aug 14 18:45:33 2002
-+++ scripts/gnump3d-top.in Wed Aug 14 18:46:04 2002
-@@ -16,7 +16,7 @@
+--- scripts/gnump3d-top.in.orig Fri Nov 29 04:33:21 2002
++++ scripts/gnump3d-top.in Mon Dec 2 19:13:54 2002
+@@ -30,7 +30,7 @@
# The default logfile which we read if there is no
# --config options supplied on the command line.
--my $DEFAULT_CONFIG = "/etc/mp3d/mp3d.conf";
+-my $DEFAULT_CONFIG = "/etc/gnump3d/gnump3d.conf";
+my $DEFAULT_CONFIG = "@prefix@/etc/gnump3d/gnump3d.conf";
#
diff --git a/audio/gnump3d/files/patch-src_request.cc b/audio/gnump3d/files/patch-src_request.cc
new file mode 100644
index 000000000000..d919523d46cb
--- /dev/null
+++ b/audio/gnump3d/files/patch-src_request.cc
@@ -0,0 +1,13 @@
+--- src/request.cc.orig Fri Nov 29 04:33:21 2002
++++ src/request.cc Mon Dec 2 19:25:06 2002
+@@ -54,6 +54,10 @@
+ # include <unistd.h>
+ #endif /* HAVE_UNISTD_H */
+
++#ifdef HAVE_PTHREAD
++# include <pthread.h>
++#endif
++
+
+ #include "base64.h"
+ #include "debug.h"
diff --git a/audio/gnump3d/pkg-plist b/audio/gnump3d/pkg-plist
index ba0f0cde3db0..f9990113064f 100644
--- a/audio/gnump3d/pkg-plist
+++ b/audio/gnump3d/pkg-plist
@@ -1,6 +1,14 @@
@comment $FreeBSD$
bin/gnump3d
bin/gnump3d-top
+etc/gnump3d/LaFrere/config.ini
+etc/gnump3d/LaFrere/error.html
+etc/gnump3d/LaFrere/index.html
+etc/gnump3d/LaFrere/logo.png
+etc/gnump3d/LaFrere/plugin.html
+etc/gnump3d/LaFrere/results.html
+etc/gnump3d/LaFrere/search.html
+etc/gnump3d/LaFrere/stats.html
etc/gnump3d/default/error.html
etc/gnump3d/default/index.html
etc/gnump3d/default/plugin.html
@@ -18,6 +26,12 @@ etc/gnump3d/nausicaa/results.html
etc/gnump3d/nausicaa/search.html
etc/gnump3d/nausicaa/stats.html
etc/gnump3d/nausicaa/style.css
+etc/gnump3d/redgrey/error.html
+etc/gnump3d/redgrey/index.html
+etc/gnump3d/redgrey/plugin.html
+etc/gnump3d/redgrey/results.html
+etc/gnump3d/redgrey/search.html
+etc/gnump3d/redgrey/stats.html
etc/gnump3d/simple/config.ini
etc/gnump3d/simple/error.html
etc/gnump3d/simple/index.html
@@ -36,6 +50,10 @@ lib/gnump3d/bug.la
lib/gnump3d/bug.so
lib/gnump3d/last20.la
lib/gnump3d/last20.so
+lib/gnump3d/now.la
+lib/gnump3d/now.so
+lib/gnump3d/playlist.la
+lib/gnump3d/playlist.so
lib/gnump3d/search.la
lib/gnump3d/search.so
lib/gnump3d/stats.la
@@ -49,6 +67,8 @@ lib/gnump3d/version.so
@unexec rmdir /var/log/gnump3d 2>/dev/null || true
@dirrm etc/gnump3d/split
@dirrm etc/gnump3d/simple
+@dirrm etc/gnump3d/redgrey
@dirrm etc/gnump3d/nausicaa
@dirrm etc/gnump3d/default
+@dirrm etc/gnump3d/LaFrere
@dirrm etc/gnump3d