aboutsummaryrefslogtreecommitdiff
path: root/audio/gnupod/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2007-05-29 07:22:08 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2007-05-29 07:22:08 +0000
commit261649a9a615a4dbb7ba319b1111e1acf3b2718f (patch)
treed0049b100ff7781aa32dcac94a077fd83ca440ce /audio/gnupod/Makefile
parente26089a2cf5236da0379ee63c917b69cd924bfbf (diff)
Notes
Diffstat (limited to 'audio/gnupod/Makefile')
-rw-r--r--audio/gnupod/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/audio/gnupod/Makefile b/audio/gnupod/Makefile
index ab55e6c1f8f6..d6e002b33d53 100644
--- a/audio/gnupod/Makefile
+++ b/audio/gnupod/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnupod
-PORTVERSION= 0.99
+PORTVERSION= 0.99.2
CATEGORIES= audio perl5
MASTER_SITES= ${MASTER_SITE_SAVANNAH} \
http://www.blinkenlights.ch/gnupod-dist/stable/
@@ -34,15 +34,27 @@ USE_PERL5= yes
HAS_CONFIGURE= yes
NO_BUILD= yes
-CONFIGURE_ARGS= --prefix=${PREFIX}
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --infodir=${PREFIX}/info \
+ --mandir=${PREFIX}/man
CONFIGURE_ENV= ac_cv_path_PERL=${PERL}
+OPTIONS= FLAC "Enable FLAC support" off
+
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500800
IGNORE= gnupod only support perl 5.8 or above
.endif
+.if exists(${SITE_PERL}/${PERL_ARCH}/Audio/FLAC/Header.pm)
+WITH_FLAC= YES
+.endif
+
+.if defined(WITH_FLAC)
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Audio/FLAC/Header.pm:${PORTSDIR}/audio/p5-Audio-FLAC-Header
+.endif
+
.ifndef(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}