aboutsummaryrefslogtreecommitdiff
path: root/audio/gnupod/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-05-02 19:27:35 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-05-02 19:27:35 +0000
commit1c06325a32b113015bc688a05921c651285abb84 (patch)
tree3f41ff9b2c4bddf71c2fb4cab6a003bd72e58769 /audio/gnupod/Makefile
parent224b687744c74840ea55c6c3974787b907a8889f (diff)
downloadports-1c06325a32b113015bc688a05921c651285abb84.tar.gz
ports-1c06325a32b113015bc688a05921c651285abb84.zip
Notes
Diffstat (limited to 'audio/gnupod/Makefile')
-rw-r--r--audio/gnupod/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/audio/gnupod/Makefile b/audio/gnupod/Makefile
index 575e31d453cc..30d2e3f3ed36 100644
--- a/audio/gnupod/Makefile
+++ b/audio/gnupod/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnupod
-PORTVERSION= 0.99.2
+PORTVERSION= 0.99.6
CATEGORIES= audio perl5
MASTER_SITES= ${MASTER_SITE_SAVANNAH} \
http://www.blinkenlights.ch/gnupod-dist/stable/
@@ -31,24 +31,24 @@ MAN1= gnupod_addsong.pl.1 gnupod_check.pl.1 gnupod_INIT.pl.1 \
MANCOMPRESSED= yes
USE_PERL5= 5.8.0+
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
NO_BUILD= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} \
- --infodir=${PREFIX}/info \
- --mandir=${MANPREFIX}/man
+CONFIGURE_ARGS= --prefix=${PREFIX}
CONFIGURE_ENV= ac_cv_path_PERL=${PERL}
-OPTIONS= FLAC "Enable FLAC support" off
+OPTIONS= FLAC "Enable FLAC support" off \
+ VORBIS "Enable Ogg Vorbis support" off
.include <bsd.port.pre.mk>
-.if exists(${SITE_PERL}/${PERL_ARCH}/Audio/FLAC/Header.pm)
-WITH_FLAC= YES
+.if defined(WITH_FLAC) || exists(${SITE_PERL}/${PERL_ARCH}/Audio/FLAC/Header.pm)
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Audio/FLAC/Header.pm:${PORTSDIR}/audio/p5-Audio-FLAC-Header
.endif
-.if defined(WITH_FLAC)
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Audio/FLAC/Header.pm:${PORTSDIR}/audio/p5-Audio-FLAC-Header
+.if defined(WITH_VORBIS) || exists(${SITE_PERL}/Ogg/Vorbis/Header/PurePerl.pm)
+BUILD_DEPENDS+= ${SITE_PERL}/Ogg/Vorbis/Header/PurePerl.pm:${PORTSDIR}/audio/p5-Ogg-Vorbis-Header-PurePerl
+BUILD_DEPENDS+= oggdec:${PORTSDIR}/audio/vorbis-tools
.endif
.ifndef(NOPORTDOCS)