aboutsummaryrefslogtreecommitdiff
path: root/audio/gnupod
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2003-01-15 16:38:04 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2003-01-15 16:38:04 +0000
commit1009089b696c19f3acfa03009675a51d389cc759 (patch)
tree28cd740e1e9a39c7b760b19cea62845dc22b521a /audio/gnupod
parente38242ea19653e1e29b30bedfe77fbb881ba248b (diff)
downloadports-1009089b696c19f3acfa03009675a51d389cc759.tar.gz
ports-1009089b696c19f3acfa03009675a51d389cc759.zip
Notes
Diffstat (limited to 'audio/gnupod')
-rw-r--r--audio/gnupod/Makefile50
-rw-r--r--audio/gnupod/distinfo1
-rw-r--r--audio/gnupod/pkg-comment1
-rw-r--r--audio/gnupod/pkg-descr7
-rw-r--r--audio/gnupod/pkg-message17
-rw-r--r--audio/gnupod/pkg-plist15
6 files changed, 91 insertions, 0 deletions
diff --git a/audio/gnupod/Makefile b/audio/gnupod/Makefile
new file mode 100644
index 000000000000..9c27884d7cad
--- /dev/null
+++ b/audio/gnupod/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: gnupod
+# Date created: 30 November 2002
+# Whom: David Le Brun <david@dyn-ns.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnupod
+PORTVERSION= 0.25
+CATEGORIES= audio perl5
+MASTER_SITES= http://www.blinkenlights.ch/gnupod/
+DISTNAME= ${PORTNAME}-tools-${PORTVERSION}
+
+MAINTAINER= david@dyn-ns.net
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/MP3/Info.pm:${PORTSDIR}/audio/p5-MP3-Info \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Unicode/String.pm:${PORTSDIR}/converters/p5-Unicode-String \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Copy.pm:${PORTSDIR}/devel/p5-File-Tools
+
+USE_PERL5= yes
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-tools
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/gnupod_INITpod.pl ${PREFIX}/bin/gnupod_INITpod
+ ${INSTALL_SCRIPT} ${WRKSRC}/gnupod_addsong.pl ${PREFIX}/bin/gnupod_addsong
+ ${INSTALL_SCRIPT} ${WRKSRC}/gnupod_connect.pl ${PREFIX}/bin/gnupod_connect
+ ${INSTALL_SCRIPT} ${WRKSRC}/gnupod_delete.pl ${PREFIX}/bin/gnupod_delete
+ ${INSTALL_SCRIPT} ${WRKSRC}/mktunes.pl ${PREFIX}/bin/mktunes
+ ${INSTALL_SCRIPT} ${WRKSRC}/tunes2pod.pl ${PREFIX}/bin/tunes2pod
+
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
+ @${CHMOD} 0755 ${PREFIX}/share/doc/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/CHANGES ${PREFIX}/share/doc/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/TODO ${PREFIX}/share/doc/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/doc/index-de.html ${PREFIX}/share/doc/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/doc/index.html ${PREFIX}/share/doc/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/doc/logo.png ${PREFIX}/share/doc/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/doc/gnutunesdb.example ${PREFIX}/share/doc/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/doc/ipod.svg ${PREFIX}/share/doc/${PORTNAME}
+.endif
+
+post-install:
+ @${CAT} pkg-message
+
+.include <bsd.port.mk>
diff --git a/audio/gnupod/distinfo b/audio/gnupod/distinfo
new file mode 100644
index 000000000000..75956976d38f
--- /dev/null
+++ b/audio/gnupod/distinfo
@@ -0,0 +1 @@
+MD5 (gnupod-tools-0.25.tar.gz) = dbcf6d0dc757cff0a36de9a22881899a
diff --git a/audio/gnupod/pkg-comment b/audio/gnupod/pkg-comment
new file mode 100644
index 000000000000..e07d5439c2c3
--- /dev/null
+++ b/audio/gnupod/pkg-comment
@@ -0,0 +1 @@
+A set of Perl scripts for using an Apple iPod
diff --git a/audio/gnupod/pkg-descr b/audio/gnupod/pkg-descr
new file mode 100644
index 000000000000..e4e6c1dc3ad6
--- /dev/null
+++ b/audio/gnupod/pkg-descr
@@ -0,0 +1,7 @@
+gnuPod is a collection of tools which allow you to use your iPod.
+FAT32 formatted iPods are supported.
+To convert Mac iPod to Win iPod, follow instructions on the web site.
+
+WWW: http://www.blinkenlights.ch/cgi-bin/fm.pl?get=ipode
+
+- QuiRK <david@dyn-ns.net>
diff --git a/audio/gnupod/pkg-message b/audio/gnupod/pkg-message
new file mode 100644
index 000000000000..f448fa6ff902
--- /dev/null
+++ b/audio/gnupod/pkg-message
@@ -0,0 +1,17 @@
+===> Please Note:
+*******************************************************************************
+
+gnuPod < 0.25 had a bad typo:
+the 'genere=' tag should be (of course) 'genre='.
+It's corrected in gnuPod 0.25, but if you used the
+'Genre' tag in older versions you'll have to do this
+(To correct your GNUtunesDB)
+
+1) Mount your iPod
+2) Run: tunes2pod -m $IPOD_MOUNTPOINT
+(Make sure to run tunes2pod from gnupod 0.25!)
+
+This will re-parse your iTunesDB and create a
+GNUtunesDB without the typo
+
+*******************************************************************************
diff --git a/audio/gnupod/pkg-plist b/audio/gnupod/pkg-plist
new file mode 100644
index 000000000000..37a71eb2ca47
--- /dev/null
+++ b/audio/gnupod/pkg-plist
@@ -0,0 +1,15 @@
+bin/gnupod_INITpod
+bin/gnupod_addsong
+bin/gnupod_connect
+bin/gnupod_delete
+bin/mktunes
+bin/tunes2pod
+%%PORTDOCS%%share/doc/gnupod/README
+%%PORTDOCS%%share/doc/gnupod/CHANGES
+%%PORTDOCS%%share/doc/gnupod/TODO
+%%PORTDOCS%%share/doc/gnupod/index-de.html
+%%PORTDOCS%%share/doc/gnupod/index.html
+%%PORTDOCS%%share/doc/gnupod/logo.png
+%%PORTDOCS%%share/doc/gnupod/gnutunesdb.example
+%%PORTDOCS%%share/doc/gnupod/ipod.svg
+%%PORTDOCS%%@dirrm share/doc/gnupod