aboutsummaryrefslogtreecommitdiff
path: root/audio/gogglesmm/Makefile
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2010-07-18 21:27:09 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2010-07-18 21:27:09 +0000
commit9838803f59d1dcea26b0c1af23aab2c807d3bbe5 (patch)
treeaa4e71fb6f7d3e8621b08c264086271a73a14990 /audio/gogglesmm/Makefile
parent8a410ee27ac6064d23eee5487fa592561432cf5b (diff)
downloadports-9838803f59d1dcea26b0c1af23aab2c807d3bbe5.tar.gz
ports-9838803f59d1dcea26b0c1af23aab2c807d3bbe5.zip
Notes
Diffstat (limited to 'audio/gogglesmm/Makefile')
-rw-r--r--audio/gogglesmm/Makefile51
1 files changed, 34 insertions, 17 deletions
diff --git a/audio/gogglesmm/Makefile b/audio/gogglesmm/Makefile
index ae1c7520dcd5..97af3a958f66 100644
--- a/audio/gogglesmm/Makefile
+++ b/audio/gogglesmm/Makefile
@@ -6,45 +6,62 @@
#
PORTNAME= gmm
-PORTVERSION= 0.10.22
-PORTREVISION= 1
+PORTVERSION= 0.10.26
CATEGORIES= audio
MASTER_SITES= http://gogglesmm.googlecode.com/files/
-DISTNAME= musicmanager-${PORTVERSION}
+DISTNAME= gogglesmm-${PORTVERSION}
-MAINTAINER= sklauder@trimind.de
+MAINTAINER= baptiste.daroussin@gmail.com
COMMENT= Music collection manager and player
-BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
LIB_DEPENDS= FOX-1.6:${PORTSDIR}/x11-toolkits/fox16 \
xine.1:${PORTSDIR}/multimedia/libxine \
tag.1:${PORTSDIR}/audio/taglib \
- sqlite3.8:${PORTSDIR}/databases/sqlite3 \
- dbus-1:${PORTSDIR}/devel/dbus \
- curl.6:${PORTSDIR}/ftp/curl
+ sqlite3.8:${PORTSDIR}/databases/sqlite3
+
+OPTIONS= DBUS "Add DBUS support" on \
+ CURL "Add Curl support" on \
+ NLS "Add support for nls" on \
+ NEWREMOTE "Use new remote player" on
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
USE_GMAKE= yes
-USE_BZIP2= yes
-USE_GETTEXT= yes
-USE_GNOME= gtk20
+USE_XZ= yes
INSTALLS_ICONS= yes
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
PORTDOCS= README AUTHORS
CONFIGURE_ENV= OPT_CFLAGS=" "
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
+.if defined(WITHOUT_DBUS)
+CONFIGURE_ARGS+= --without-dbus
+.else
+LIB_DEPENDS+= dbus-1:${PORTSDIR}/devel/dbus
+.endif
+
+.if defined(WITHOUT_CURL)
+CONFIGURE_ARGS+= --without-curl
+.else
+LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
+.endif
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB= NLS="@comment "
+.else
+PLIST_SUB= NLS=""
+USE_GETTEXT= yes
+.endif
.if defined(WITHOUT_NEWREMOTE)
CONFIGURE_ARGS+=--without-new-remote
.endif
-post-patch:
- @${REINPLACE_CMD} -i '' -e "s|/bin/bash|${LOCALBASE}/bin/bash|; \
- s|/usr/local|${LOCALBASE}|" ${WRKSRC}/configure
-
post-configure:
@${REINPLACE_CMD} -i '' -e 's| -[DT] | |g' \
${WRKSRC}/Makefile
@@ -57,4 +74,4 @@ post-install:
. endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>