aboutsummaryrefslogtreecommitdiff
path: root/audio/gogglesmm/files
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2010-11-17 10:47:56 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2010-11-17 10:47:56 +0000
commit1ce56c6c8825a280e6d687510549bf01b531da10 (patch)
tree627b9a078265a3d864cbd9d4fd5a0ea079eb7275 /audio/gogglesmm/files
parent86aaeae1b7cff2fb5b01c5fa3cde10ca428f82fc (diff)
downloadports-1ce56c6c8825a280e6d687510549bf01b531da10.tar.gz
ports-1ce56c6c8825a280e6d687510549bf01b531da10.zip
Notes
Diffstat (limited to 'audio/gogglesmm/files')
-rw-r--r--audio/gogglesmm/files/patch-Makefile30
-rw-r--r--audio/gogglesmm/files/patch-build__functions20
-rw-r--r--audio/gogglesmm/files/patch-configure17
3 files changed, 67 insertions, 0 deletions
diff --git a/audio/gogglesmm/files/patch-Makefile b/audio/gogglesmm/files/patch-Makefile
new file mode 100644
index 000000000000..1714b800e54b
--- /dev/null
+++ b/audio/gogglesmm/files/patch-Makefile
@@ -0,0 +1,30 @@
+--- ./Makefile.orig 2010-11-09 17:21:47.000000000 +0100
++++ ./Makefile 2010-11-17 11:43:24.638891288 +0100
+@@ -153,19 +153,22 @@
+ #----------------------------------------------------------
+ install: $(BINNAME)
+ @echo " Installing $(INSTALL_DIR)/bin/gogglesmm ..."
+- @$(INSTALL) -m 755 -D src/gogglesmm $(INSTALL_DIR)/bin/gogglesmm
++ @$(INSTALL) -m 755 src/gogglesmm $(INSTALL_DIR)/bin/gogglesmm
+ @echo " Installing $(INSTALL_DIR)/share/applications/gogglesmm.desktop"
+- @$(INSTALL) -m 644 -D extra/gogglesmm.desktop $(INSTALL_DIR)/share/applications/gogglesmm.desktop
++ @mkdir -p $(INSTALL_DIR)/share/applications/
++ @$(INSTALL) -m 644 extra/gogglesmm.desktop $(INSTALL_DIR)/share/applications/gogglesmm.desktop
+ @echo " Installing $(INSTALL_DIR)/share/icons/hicolor/48x48/apps/gogglesmm.png"
+- @$(INSTALL) -m 644 -D extra/gogglesmm.png $(INSTALL_DIR)/share/icons/hicolor/48x48/apps/gogglesmm.png
++ @mkdir -p $(INSTALL_DIR)/share/icons/hicolor/48x48/apps/
++ @$(INSTALL) -m 644 extra/gogglesmm.png $(INSTALL_DIR)/share/icons/hicolor/48x48/apps/gogglesmm.png
+ @echo " Installing $(INSTALL_MANDIR)/man1/gogglesmm.1"
+- @$(INSTALL) -m 644 -D extra/gogglesmm.1 $(INSTALL_MANDIR)/man1/gogglesmm.1
++ @$(INSTALL) -m 644 extra/gogglesmm.1 $(INSTALL_MANDIR)/man1/gogglesmm.1
+ ifneq (,$(findstring nls,$(OPTIONS)))
+ @echo " Installing Translations"
+ @linguas='$(filter $(TRANSLATIONS),$(LINGUAS))'; \
+ for tr in $$linguas ; do \
+ echo " Installing $(INSTALL_LOCALEDIR)/$$tr/LC_MESSAGES/gogglesmm.mo" ;\
+- $(INSTALL) -m 644 -D po/$$tr.mo -T $(INSTALL_LOCALEDIR)/$$tr/LC_MESSAGES/gogglesmm.mo ; \
++ mkdir -p $(INSTALL_LOCALEDIR)/$$tr/LC_MESSAGES/; \
++ $(INSTALL) -m 644 po/$$tr.mo $(INSTALL_LOCALEDIR)/$$tr/LC_MESSAGES/gogglesmm.mo ; \
+ done;
+ endif
+
diff --git a/audio/gogglesmm/files/patch-build__functions b/audio/gogglesmm/files/patch-build__functions
new file mode 100644
index 000000000000..6154f10fdee8
--- /dev/null
+++ b/audio/gogglesmm/files/patch-build__functions
@@ -0,0 +1,20 @@
+--- ./build/functions.orig 2010-11-09 17:21:47.000000000 +0100
++++ ./build/functions 2010-11-17 11:42:12.745161258 +0100
+@@ -108,7 +108,7 @@
+ if [ "$?" -eq "0" ] ; then
+ exit -1
+ fi
+- PACKAGES="$PACKAGES $1 "
++ GMMPKG="$GMMPKG $1 "
+ add_config "$2"
+ return 1
+ }
+@@ -119,7 +119,7 @@
+ if [ "$?" -eq "0" ] ; then
+ return 0
+ fi
+- PACKAGES="$PACKAGES $1 "
++ GMMPKG="$GMMPKG $1 "
+ add_config "$2"
+ return 1
+ }
diff --git a/audio/gogglesmm/files/patch-configure b/audio/gogglesmm/files/patch-configure
new file mode 100644
index 000000000000..57e81d84bf40
--- /dev/null
+++ b/audio/gogglesmm/files/patch-configure
@@ -0,0 +1,17 @@
+--- ./configure.orig 2010-11-09 17:21:47.000000000 +0100
++++ ./configure 2010-11-17 11:42:22.565124308 +0100
+@@ -187,10 +187,10 @@
+ fi
+
+
+-PKG_LDFLAGS=$(pkg-config --libs-only-L $PACKAGES)
+-PKG_LIBS=$(pkg-config --libs-only-l --libs-only-other $PACKAGES)
+-PKG_CFLAGS=$(pkg-config --cflags-only-other $PACKAGES)
+-PKG_CPPFLAGS=$(pkg-config --cflags-only-I $PACKAGES)
++PKG_LDFLAGS=$(pkg-config --libs-only-L $GMMPKG)
++PKG_LIBS=$(pkg-config --libs-only-l --libs-only-other $GMMPKG)
++PKG_CFLAGS=$(pkg-config --cflags-only-other $GMMPKG)
++PKG_CPPFLAGS=$(pkg-config --cflags-only-I $GMMPKG)
+
+ if [ -n "$PKG_LDFLAGS" ] ; then LIBS="$LIBS $PKG_LDFLAGS"; fi
+ if [ -n "$PKG_LIBS" ] ; then LIBS="$LIBS $PKG_LIBS"; fi