aboutsummaryrefslogtreecommitdiff
path: root/audio/gogglesmm
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2014-08-27 12:53:29 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2014-08-27 12:53:29 +0000
commitbebcb5351f55f2b08798af4cb9354b44c35b8a76 (patch)
tree73fa9fffa58faa5d8929dfdded2ac17ae2dcdf62 /audio/gogglesmm
parente5ee82f004d3f659a5316fc7b61e3094647dc0b7 (diff)
downloadports-bebcb5351f55f2b08798af4cb9354b44c35b8a76.tar.gz
ports-bebcb5351f55f2b08798af4cb9354b44c35b8a76.zip
Notes
Diffstat (limited to 'audio/gogglesmm')
-rw-r--r--audio/gogglesmm/Makefile130
-rw-r--r--audio/gogglesmm/distinfo4
-rw-r--r--audio/gogglesmm/files/patch-src__gap__ap_reactor.cpp30
-rw-r--r--audio/gogglesmm/files/patch-src__gap__ap_socket.cpp10
-rw-r--r--audio/gogglesmm/files/patch-src__gap__ap_utils.cpp30
-rw-r--r--audio/gogglesmm/files/patch-src__gap__plugins__ap_oss_plugin.cpp11
-rw-r--r--audio/gogglesmm/pkg-descr2
-rw-r--r--audio/gogglesmm/pkg-plist29
8 files changed, 188 insertions, 58 deletions
diff --git a/audio/gogglesmm/Makefile b/audio/gogglesmm/Makefile
index d8ef71f7ab00..5cf2a9eb1ce4 100644
--- a/audio/gogglesmm/Makefile
+++ b/audio/gogglesmm/Makefile
@@ -2,63 +2,113 @@
# $FreeBSD$
PORTNAME= gogglesmm
-PORTVERSION= 0.12.7
-PORTREVISION= 8
+PORTVERSION= 0.13.2
CATEGORIES= audio
-MASTER_SITES= GOOGLE_CODE
MAINTAINER= ports@FreeBSD.org
COMMENT= Music collection manager and player
LICENSE= GPLv3
-LIB_DEPENDS= libxine.so:${PORTSDIR}/multimedia/libxine \
- libtag.so:${PORTSDIR}/audio/taglib \
- libsqlite3.so:${PORTSDIR}/databases/sqlite3
+LIB_DEPENDS= libtag.so:${PORTSDIR}/audio/taglib \
+ libGLEW.so:${PORTSDIR}/graphics/glew \
+ libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libFOX-1.7.so:${PORTSDIR}/x11-toolkits/fox17
-OPTIONS_DEFINE= DBUS CURL NLS NEWREMOTE GCRYPT DOCS
-OPTIONS_SINGLE= FOX
-OPTIONS_SINGLE_FOX= FOX16 FOX17
-OPTIONS_DEFAULT= DBUS CURL NEWREMOTE FOX16
-
-FOX16_DESC= Use stable branch of FOX
-FOX17_DESC= Use development branch of FOX
-NEWREMOTE_DESC= Use new remote player
-GCRYPT_DESC= Use libgcrypt for md5 calculation
-
-OPTIONS_SUB= yes
+USE_GITHUB= yes
+GH_ACCOUNT= ${PORTNAME}
+GH_COMMIT= ea16b55
+USES= compiler:nestedfct desktop-file-utils gmake pkgconfig
+USE_SQLITE= yes
HAS_CONFIGURE= yes
-CONFIGURE_ARGS+= --mandir=${PREFIX}/man --prefix=${PREFIX}
-
-USES= tar:xz pkgconfig gmake desktop-file-utils
-MAKE_ARGS= CXX="${CXX}" LINK="${CXX}"
+CONFIGURE_ENV= LINK="${CXX}" \
+ OPT_CFLAGS="${CXXFLAGS}" \
+ OPT_LDFLAGS="${LDFLAGS}" \
+ RESWRAP="${LOCALBASE}/bin/fox-1.7/reswrap"
+CONFIGURE_ARGS= --prefix=${PREFIX} --fox-prefix=${LOCALBASE} \
+ --without-rsound --without-mpcdec
INSTALLS_ICONS= yes
-PORTDOCS= README AUTHORS
-
-FOX16_LIB_DEPENDS= libFOX-1.6.so:${PORTSDIR}/x11-toolkits/fox16
-FOX17_LIB_DEPENDS= libFOX-1.7.so:${PORTSDIR}/x11-toolkits/fox17
-
+CFLAGS+= -Wno-error=return-type
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -pthread
+
+OPTIONS_DEFINE= ALSA CDIO DBUS DOCS FAAD FFMPEG FLAC GCRYPT JACK \
+ MAD MMS NLS OPUS PULSEAUDIO SAMPLERATE SMB TREMOR \
+ VORBIS WAVPACK
+OPTIONS_DEFAULT= CDIO DBUS FAAD FLAC MAD OPUS SAMPLERATE SMB \
+ VORBIS WAVPACK
+OPTIONS_SUB= yes
+
+ALSA_LIB_DEPENDS= libasound.so:${PORTSDIR}/audio/alsa-lib
+ALSA_CONFIGURE_OFF= --without-alsa
+CDIO_LIB_DEPENDS= libcdio.so:${PORTSDIR}/sysutils/libcdio
+CDIO_CONFIGURE_OFF= --without-cdda
+DBUS_LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus
+DBUS_CONFIGURE_OFF= --without-dbus
+FAAD_LIB_DEPENDS= libfaad.so:${PORTSDIR}/audio/faad
+FAAD_CONFIGURE_ON= --faad-prefix=${LOCALBASE}
+FAAD_CONFIGURE_OFF= --without-faad
+FFMPEG_LIB_DEPENDS= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
+FFMPEG_CONFIGURE_ON= --with-avcodec
+FLAC_LIB_DEPENDS= libFLAC.so:${PORTSDIR}/audio/flac
+FLAC_CONFIGURE_OFF= --without-flac
+GCRYPT_DESC= Use libgcrypt for md5 calculation
GCRYPT_LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt
GCRYPT_CONFIGURE_ON= --with-md5=gcrypt
GCRYPT_CONFIGURE_OFF= --with-md5=internal
-
-DBUS_LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus
-DBUS_CONFIGURE_OFF= --with-dbus
-
-CURL_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
-CURL_CONFIGURE_OFF= --without-curl
-
+JACK_LIB_DEPENDS= libjack.so:${PORTSDIR}/audio/jack
+JACK_CONFIGURE_OFF= --without-jack
+MAD_LIB_DEPENDS= libmad.so:${PORTSDIR}/audio/libmad
+MAD_CONFIGURE_ON= --mad-prefix=${LOCALBASE}
+MAD_CONFIGURE_OFF= --without-mad
+MMS_LIB_DEPENDS= libmms.so:${PORTSDIR}/net/libmms
+MMS_CONFIGURE_OFF= --without-mms
NLS_USES= gettext
-NLS_LDFLAGS= -lintl
-NLS_CONFIGURE_OFF= --disable-nls
-
-NEWREMOTE_CONFIGURE_OFF= --without-new-remote
+NLS_LIBS= -lintl
+NLS_CONFIGURE_OFF= --without-nls
+OPUS_DESC= Opus decoding with libopus
+OPUS_LIB_DEPENDS= libopus.so:${PORTSDIR}/audio/opus
+OPUSE_CONFIGURE_OFF= --without-opus
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
+PULSEAUDIO_CONFIGURE_OFF= --without-pulse
+SAMPLERATE_LIB_DEPENDS= libsamplerate.so:${PORTSDIR}/audio/libsamplerate
+SAMPLERATE_CONFIGURE_OFF= --without-samplerate
+SMB_LIB_DEPENDS= libsmbclient.so:${PORTSDIR}/net/samba-libsmbclient
+SMB_CONFIGURE_ON= --smb-prefix=${LOCALBASE}
+SMB_CONFIGURE_OFF= --without-smb
+TREMOR_LIB_DEPENDS= libvorbisidec.so:${PORTSDIR}/audio/libtremor
+TREMOR_CONFIGURE_ON= --with-tremor
+VORBIS_LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis
+VORBIS_CONFIGURE_OFF= --without-off --without-vorbis
+WAVPACK_LIB_DEPENDS= libwavpack.so:${PORTSDIR}/audio/wavpack
+WAVPACK_CONFIGURE_OFF= --without-wavpack
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|share/man|man|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|$$(sharedir)/man|$$(installdir)/man| ; \
+ /INSTALL/s|-D|-c| ; \
+ s|@$$(CXX)|$$(CXX)|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e \
+ 's|@$$(LINK)|$$(LINK)|' ${WRKSRC}/build/*.mk
+
+pre-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/gogglesmm
+ @${MKDIR} ${STAGEDIR}${DATADIR}/utils
+.for i in 16 22 24 32 48
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${i}x${i}/apps
+.endfor
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps
post-install:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC}; ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for i in AUTHORS ChangeLog README
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${STAGEDIR}${DOCSDIR})
+.endfor
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/gogglesmm/libgap_*.so
.include <bsd.port.mk>
diff --git a/audio/gogglesmm/distinfo b/audio/gogglesmm/distinfo
index 47754a60df27..f5e2a2de0575 100644
--- a/audio/gogglesmm/distinfo
+++ b/audio/gogglesmm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gogglesmm-0.12.7.tar.xz) = ceaec9a6b3f492901adc5c4a9331a8f2e05c38e292dd1b8f9e31219b215cbbf4
-SIZE (gogglesmm-0.12.7.tar.xz) = 344652
+SHA256 (gogglesmm-0.13.2.tar.gz) = d6f577c06b420dcab813a56672c07434b034f30aad0cfc379b9b2a6c20d75e3f
+SIZE (gogglesmm-0.13.2.tar.gz) = 1336120
diff --git a/audio/gogglesmm/files/patch-src__gap__ap_reactor.cpp b/audio/gogglesmm/files/patch-src__gap__ap_reactor.cpp
new file mode 100644
index 000000000000..0b0b30472c6e
--- /dev/null
+++ b/audio/gogglesmm/files/patch-src__gap__ap_reactor.cpp
@@ -0,0 +1,30 @@
+--- src/gap/ap_reactor.cpp.orig
++++ src/gap/ap_reactor.cpp
+@@ -98,17 +98,27 @@
+ #ifndef WIN32
+ FXint n;
+ if (timeout>=0) {
++#ifdef _GNU_SOURCE
+ struct timespec ts;
+ ts.tv_sec = timeout / 1000000000;
+ ts.tv_nsec = timeout % 1000000000;
++#endif
+ do {
++#ifdef _GNU_SOURCE
+ n = ppoll(pfds,nfds,&ts,NULL);
++#else
++ n = poll(pfds,nfds,-1);
++#endif
+ }
+ while(n==-1 && errno==EINTR);
+ }
+ else {
+ do {
++#ifdef _GNU_SOURCE
+ n = ppoll(pfds,nfds,NULL,NULL);
++#else
++ n = poll(pfds,nfds,0);
++#endif
+ }
+ while(n==-1 && errno==EINTR);
+ }
diff --git a/audio/gogglesmm/files/patch-src__gap__ap_socket.cpp b/audio/gogglesmm/files/patch-src__gap__ap_socket.cpp
new file mode 100644
index 000000000000..5c9e03302b01
--- /dev/null
+++ b/audio/gogglesmm/files/patch-src__gap__ap_socket.cpp
@@ -0,0 +1,10 @@
+--- src/gap/ap_socket.cpp.orig
++++ src/gap/ap_socket.cpp
+@@ -18,6 +18,7 @@
+ ********************************************************************************/
+ #include "ap_defs.h"
+ #include "ap_socket.h"
++#include "ap_utils.h"
+
+
+ #ifndef WIN32
diff --git a/audio/gogglesmm/files/patch-src__gap__ap_utils.cpp b/audio/gogglesmm/files/patch-src__gap__ap_utils.cpp
new file mode 100644
index 000000000000..394915bc3239
--- /dev/null
+++ b/audio/gogglesmm/files/patch-src__gap__ap_utils.cpp
@@ -0,0 +1,30 @@
+--- src/gap/ap_utils.cpp.orig
++++ src/gap/ap_utils.cpp
+@@ -247,17 +247,27 @@
+ nfds=2;
+ }
+ if (timeout) {
++#ifdef _GNU_SOURCE
+ struct timespec ts;
+ ts.tv_sec = (timeout / 1000000000);
+ ts.tv_nsec = (timeout % 1000000000);
++#endif
+ do {
++#ifdef _GNU_SOURCE
+ n=ppoll(fds,nfds,&ts,NULL);
++#else
++ n=poll(fds,nfds,-1);
++#endif
+ }
+ while(n==-1 && (errno==EAGAIN || errno==EINTR));
+ }
+ else {
+ do {
++#ifdef _GNU_SOURCE
+ n=ppoll(fds,nfds,NULL,NULL);
++#else
++ n=poll(fds,nfds,0);
++#endif
+ }
+ while(n==-1 && (errno==EAGAIN || errno==EINTR));
+ }
diff --git a/audio/gogglesmm/files/patch-src__gap__plugins__ap_oss_plugin.cpp b/audio/gogglesmm/files/patch-src__gap__plugins__ap_oss_plugin.cpp
new file mode 100644
index 000000000000..c6efc2a53d46
--- /dev/null
+++ b/audio/gogglesmm/files/patch-src__gap__plugins__ap_oss_plugin.cpp
@@ -0,0 +1,11 @@
+--- src/gap/plugins/ap_oss_plugin.cpp.orig
++++ src/gap/plugins/ap_oss_plugin.cpp
+@@ -117,7 +117,7 @@
+ #ifdef SNDCTL_DSP_COOKEDMODE
+ /// Turn off automatic resampling.
+ FXint enabled=(config.flags&OSSConfig::DeviceNoResample) ? 0 : 1;
+- if (ioctl(fd,SNDCTL_DSP_COOKEDMODE,&enabled)==-1)
++ if (ioctl(handle,SNDCTL_DSP_COOKEDMODE,&enabled)==-1)
+ GM_DEBUG_PRINT("[oss] unable to set cooked mode\n");
+ #endif
+
diff --git a/audio/gogglesmm/pkg-descr b/audio/gogglesmm/pkg-descr
index ae569373e065..a705211c8c0e 100644
--- a/audio/gogglesmm/pkg-descr
+++ b/audio/gogglesmm/pkg-descr
@@ -2,4 +2,4 @@ Goggles Music Manager is a music collection manager and player that
automatically categorizes your music files based on genre, artist, album,
and song. It supports gapless playback and features easy tag editing.
-WWW: http://code.google.com/p/gogglesmm/
+WWW: http://gogglesmm.github.io/
diff --git a/audio/gogglesmm/pkg-plist b/audio/gogglesmm/pkg-plist
index 47be3b6ab67b..1e5b6d745333 100644
--- a/audio/gogglesmm/pkg-plist
+++ b/audio/gogglesmm/pkg-plist
@@ -1,30 +1,29 @@
bin/gogglesmm
+%%ALSA%%lib/gogglesmm/libgap_alsa.so
+lib/gogglesmm/libgap_oss.so
+%%PULSEAUDIO%%lib/gogglesmm/libgap_pulse.so
+lib/gogglesmm/libgap_wav.so
man/man1/gogglesmm.1.gz
share/applications/gogglesmm.desktop
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%DATADIR%%/utils/import_banshee_stats.py
+%%DATADIR%%/utils/import_gogglesmm12.py
+%%DATADIR%%/utils/import_gogglesmm12_stats.py
share/icons/hicolor/16x16/apps/gogglesmm.png
share/icons/hicolor/22x22/apps/gogglesmm.png
share/icons/hicolor/24x24/apps/gogglesmm.png
share/icons/hicolor/32x32/apps/gogglesmm.png
share/icons/hicolor/48x48/apps/gogglesmm.png
share/icons/hicolor/scalable/apps/gogglesmm.svg
-%%NLS%%share/locale/cs/LC_MESSAGES/gogglesmm.mo
%%NLS%%share/locale/de/LC_MESSAGES/gogglesmm.mo
%%NLS%%share/locale/es/LC_MESSAGES/gogglesmm.mo
%%NLS%%share/locale/fr/LC_MESSAGES/gogglesmm.mo
%%NLS%%share/locale/hu/LC_MESSAGES/gogglesmm.mo
%%NLS%%share/locale/pt/LC_MESSAGES/gogglesmm.mo
%%NLS%%share/locale/ru/LC_MESSAGES/gogglesmm.mo
-@dirrmtry share/icons/hicolor/scalable/apps
-@dirrmtry share/icons/hicolor/scalable
-@dirrmtry share/icons/hicolor/48x48/apps
-@dirrmtry share/icons/hicolor/48x48
-@dirrmtry share/icons/hicolor/32x32/apps
-@dirrmtry share/icons/hicolor/32x32
-@dirrmtry share/icons/hicolor/24x24/apps
-@dirrmtry share/icons/hicolor/24x24
-@dirrmtry share/icons/hicolor/22x22/apps
-@dirrmtry share/icons/hicolor/22x22
-@dirrmtry share/icons/hicolor/16x16/apps
-@dirrmtry share/icons/hicolor/16x16
-@dirrmtry share/icons/hicolor
-@dirrmtry share/icons
+@dirrm %%DATADIR%%/utils
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm lib/gogglesmm