aboutsummaryrefslogtreecommitdiff
path: root/audio/gogglesmm
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-03 13:23:09 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-03 13:23:09 +0000
commit8d5af6670f9a126a1d40573bb575ebd23ebb080a (patch)
tree4eae952f49a71885245d9baf155795187bc412e0 /audio/gogglesmm
parent1f1fa3bf10fcb8a4636bbbe79f4810160c27f1ab (diff)
downloadports-8d5af6670f9a126a1d40573bb575ebd23ebb080a.tar.gz
ports-8d5af6670f9a126a1d40573bb575ebd23ebb080a.zip
Notes
Diffstat (limited to 'audio/gogglesmm')
-rw-r--r--audio/gogglesmm/Makefile60
-rw-r--r--audio/gogglesmm/distinfo3
-rw-r--r--audio/gogglesmm/pkg-descr5
3 files changed, 68 insertions, 0 deletions
diff --git a/audio/gogglesmm/Makefile b/audio/gogglesmm/Makefile
new file mode 100644
index 000000000000..70b97a1de4f1
--- /dev/null
+++ b/audio/gogglesmm/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: ggm
+# Date created: 28 May 2008
+# Whom: Sascha Klauder <sklauder@trimind.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmm
+PORTVERSION= 0.9.10
+CATEGORIES= audio
+MASTER_SITES= http://gogglesmm.googlecode.com/files/
+DISTNAME= musicmanager-${PORTVERSION}
+
+MAINTAINER= sklauder@trimind.de
+COMMENT= Music collection manager and player
+
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
+LIB_DEPENDS= FOX-1.6:${PORTSDIR}/x11-toolkits/fox16 \
+ xine.1:${PORTSDIR}/multimedia/libxine \
+ tag.5:${PORTSDIR}/audio/taglib \
+ sqlite3.8:${PORTSDIR}/databases/sqlite3
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_BZIP2= yes
+
+PORTDOCS= README AUTHORS
+PLIST_FILES= bin/gmm \
+ share/pixmaps/gmm.png \
+ %%PORTDOCS%%%%DOCSDIR%%/AUTHORS \
+ %%PORTDOCS%%%%DOCSDIR%%/README
+
+CONFIGURE_ARGS= --prefix=${PREFIX}
+CONFIGURE_ENV= OPT_CFLAGS=" "
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_NEWREMOTE)
+CONFIGURE_ARGS+=--without-new-remote
+.endif
+
+.if defined(WITH_DBUS)
+CONFIGURE_ARGS+=--with-dbus
+LIB_DEPENDS+= dbus-1:${PORTSDIR}/devel/dbus
+.endif
+
+post-extract:
+ ${REINPLACE_CMD} -i '' -e "s|/bin/bash|${PREFIX}/bin/bash|" \
+ ${WRKSRC}/configure
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for FILE in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+. endfor
+.endif
+ ${INSTALL_DATA} ${WRKSRC}/extra/gmm.png ${PREFIX}/share/pixmaps
+
+.include <bsd.port.post.mk>
diff --git a/audio/gogglesmm/distinfo b/audio/gogglesmm/distinfo
new file mode 100644
index 000000000000..20a79a4a33ce
--- /dev/null
+++ b/audio/gogglesmm/distinfo
@@ -0,0 +1,3 @@
+MD5 (musicmanager-0.9.10.tar.bz2) = 8ece5f1f550072d7d16f553b229ff142
+SHA256 (musicmanager-0.9.10.tar.bz2) = df2f80ce7750b37ed024148d8a5c6f41af1f23ea412fa434d4a52cb6aca4b08b
+SIZE (musicmanager-0.9.10.tar.bz2) = 266688
diff --git a/audio/gogglesmm/pkg-descr b/audio/gogglesmm/pkg-descr
new file mode 100644
index 000000000000..ae569373e065
--- /dev/null
+++ b/audio/gogglesmm/pkg-descr
@@ -0,0 +1,5 @@
+Goggles Music Manager is a music collection manager and player that
+automatically categorizes your music files based on genre, artist, album,
+and song. It supports gapless playback and features easy tag editing.
+
+WWW: http://code.google.com/p/gogglesmm/