aboutsummaryrefslogtreecommitdiff
path: root/audio/gogo-petit/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-11-06 09:03:04 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-11-06 09:03:04 +0000
commit81cfb0358e4b69eef6fbb8b00f0afc4527a08bb6 (patch)
tree930be3f7e86a5ed04b9b1e8a172c8b22aca46a7f /audio/gogo-petit/Makefile
parentc3c8326e859f87e9f3da63dd47c76362226163c0 (diff)
downloadports-81cfb0358e4b69eef6fbb8b00f0afc4527a08bb6.tar.gz
ports-81cfb0358e4b69eef6fbb8b00f0afc4527a08bb6.zip
Notes
Diffstat (limited to 'audio/gogo-petit/Makefile')
-rw-r--r--audio/gogo-petit/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/audio/gogo-petit/Makefile b/audio/gogo-petit/Makefile
new file mode 100644
index 000000000000..f139317007ae
--- /dev/null
+++ b/audio/gogo-petit/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: GOGO-no-coda-petit
+# Date created: 06 November, 2003
+# Whom: Evgueni V. Gavrilov <aquatique@rusunix.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gogo
+PORTVERSION= 3.11
+CATEGORIES= audio
+MASTER_SITES= http://homepage1.nifty.com/herumi/soft/petit/ \
+ ftp://rusunix.org/pub/FreeBSD/distfiles/
+PKGNAMESUFFIX= petit
+DISTNAME= petit311p1
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= aquatique@rusunix.org
+COMMENT= New variant of well-known GOGO-no-coda mp3 encoder
+
+BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
+
+WRKSRC= ${WRKDIR}/petit
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CFLAGS+= ${PTHREAD_CFLAGS}
+CONFIGURE_ENV+= LIBS="${PTHREAD_LIBS}"
+
+ONLY_FOR_ARCHS= i386
+
+.include <bsd.port.mk>