aboutsummaryrefslogtreecommitdiff
path: root/audio/gogo-petit
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-11-06 09:03:04 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-11-06 09:03:04 +0000
commit81cfb0358e4b69eef6fbb8b00f0afc4527a08bb6 (patch)
tree930be3f7e86a5ed04b9b1e8a172c8b22aca46a7f /audio/gogo-petit
parentc3c8326e859f87e9f3da63dd47c76362226163c0 (diff)
downloadports-81cfb0358e4b69eef6fbb8b00f0afc4527a08bb6.tar.gz
ports-81cfb0358e4b69eef6fbb8b00f0afc4527a08bb6.zip
Notes
Diffstat (limited to 'audio/gogo-petit')
-rw-r--r--audio/gogo-petit/Makefile31
-rw-r--r--audio/gogo-petit/distinfo1
-rw-r--r--audio/gogo-petit/files/patch-Makefile.in15
-rw-r--r--audio/gogo-petit/files/patch-engine-common.h12
-rw-r--r--audio/gogo-petit/files/patch-main.c12
-rw-r--r--audio/gogo-petit/pkg-descr10
-rw-r--r--audio/gogo-petit/pkg-plist1
7 files changed, 82 insertions, 0 deletions
diff --git a/audio/gogo-petit/Makefile b/audio/gogo-petit/Makefile
new file mode 100644
index 000000000000..f139317007ae
--- /dev/null
+++ b/audio/gogo-petit/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: GOGO-no-coda-petit
+# Date created: 06 November, 2003
+# Whom: Evgueni V. Gavrilov <aquatique@rusunix.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gogo
+PORTVERSION= 3.11
+CATEGORIES= audio
+MASTER_SITES= http://homepage1.nifty.com/herumi/soft/petit/ \
+ ftp://rusunix.org/pub/FreeBSD/distfiles/
+PKGNAMESUFFIX= petit
+DISTNAME= petit311p1
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= aquatique@rusunix.org
+COMMENT= New variant of well-known GOGO-no-coda mp3 encoder
+
+BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
+
+WRKSRC= ${WRKDIR}/petit
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CFLAGS+= ${PTHREAD_CFLAGS}
+CONFIGURE_ENV+= LIBS="${PTHREAD_LIBS}"
+
+ONLY_FOR_ARCHS= i386
+
+.include <bsd.port.mk>
diff --git a/audio/gogo-petit/distinfo b/audio/gogo-petit/distinfo
new file mode 100644
index 000000000000..80803ecc8968
--- /dev/null
+++ b/audio/gogo-petit/distinfo
@@ -0,0 +1 @@
+MD5 (petit311p1.tgz) = aaf9f56549985ef0a166213578954a90
diff --git a/audio/gogo-petit/files/patch-Makefile.in b/audio/gogo-petit/files/patch-Makefile.in
new file mode 100644
index 000000000000..c1303a3c0455
--- /dev/null
+++ b/audio/gogo-petit/files/patch-Makefile.in
@@ -0,0 +1,15 @@
+diff -ruN petit.orig/Makefile.in petit/Makefile.in
+--- Makefile.in.orig Fri Nov 22 15:54:18 2002
++++ Makefile.in Thu Nov 6 13:22:21 2003
+@@ -108,9 +108,8 @@
+ $(CC) $(OBJS) -o $@ $(LIBS)
+
+ install: $(TARGET)
+- $(INSTALL_PROGRAM) $< $(INSTDIR)/
+-
+-# $(STRIP) $(INSTDIR)/$(TARGET)
++ $(INSTALL_PROGRAM) $< $(PREFIX)/bin/gogo-petit
++ $(STRIP) $(PREFIX)/bin/gogo-petit
+
+ uninstall:
+ $(RM) $(INSTDIR)/$(TARGET)
diff --git a/audio/gogo-petit/files/patch-engine-common.h b/audio/gogo-petit/files/patch-engine-common.h
new file mode 100644
index 000000000000..a51ff9254fc8
--- /dev/null
+++ b/audio/gogo-petit/files/patch-engine-common.h
@@ -0,0 +1,12 @@
+diff -ruN petit.orig/engine/common.h petit/engine/common.h
+--- engine/common.h.orig Sat Mar 16 16:19:29 2002
++++ engine/common.h Thu Nov 6 13:18:32 2003
+@@ -18,7 +18,7 @@
+ #endif
+
+ /* 全然一般的でない */
+-#if defined(WIN32) || defined(__linux__) || defined(DOS) || defined(_M_IX86) || defined(__os2__) || defined(_X86_)
++#if defined(WIN32) || defined(__linux__) || defined(DOS) || defined(_M_IX86) || defined(__os2__) || defined(_X86_) || defined(__FreeBSD__)
+ #define CPU_I386
+ #define MIE_LITTLE_ENDIAN
+ #elif define(__MWERKS__)
diff --git a/audio/gogo-petit/files/patch-main.c b/audio/gogo-petit/files/patch-main.c
new file mode 100644
index 000000000000..cd6787168918
--- /dev/null
+++ b/audio/gogo-petit/files/patch-main.c
@@ -0,0 +1,12 @@
+diff -ruN petit.orig/main.c petit/main.c
+--- main.c.orig Sat Nov 23 19:32:22 2002
++++ main.c Thu Nov 6 13:21:06 2003
+@@ -9,7 +9,7 @@
+ #include <sys/time.h>
+ #include <signal.h>
+ #endif
+-#if defined(__linux__) || defined(__os2__)
++#if defined(__linux__) || defined(__os2__) || defined (__FreeBSD__)
+ # define min(x,y) (((x)<(y))?(x):(y))
+ # define max(x,y) (((x)>(y))?(x):(y))
+ #endif
diff --git a/audio/gogo-petit/pkg-descr b/audio/gogo-petit/pkg-descr
new file mode 100644
index 000000000000..c99c10ee668e
--- /dev/null
+++ b/audio/gogo-petit/pkg-descr
@@ -0,0 +1,10 @@
+GOGO-no-coda-petit is new variant of well-known GOGO-no-coda
+mp3 encoder optimized with MMX, 3DNow!, Enhanced 3DNow! and SSE
+
+*** DO NOT OVERCLOCK YOUR CPUs ***
+GOGO heavily uses the part of processors that almost sleeps in usual,
+so makes them very hot even it runs standard clock.
+Overclocking may cause serious internal errors and crazy results.
+Or you need gigantic heatsink and extra-noisy fans. :-)
+
+WWW: http://homepage1.nifty.com/herumi/gogo_e.html
diff --git a/audio/gogo-petit/pkg-plist b/audio/gogo-petit/pkg-plist
new file mode 100644
index 000000000000..b320cca44f38
--- /dev/null
+++ b/audio/gogo-petit/pkg-plist
@@ -0,0 +1 @@
+bin/gogo-petit