aboutsummaryrefslogtreecommitdiff
path: root/audio/gsi/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-12-07 18:05:12 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-12-07 18:05:12 +0000
commit2a64cbe5960bcd31c0dc83ef393d7fbcde3d8b3a (patch)
treef156be516fa9ab5097b0e814ea96ea50cab34533 /audio/gsi/Makefile
parentce13902f3da6ca0d781a8c441333d00623ddaf71 (diff)
downloadports-2a64cbe5960bcd31c0dc83ef393d7fbcde3d8b3a.tar.gz
ports-2a64cbe5960bcd31c0dc83ef393d7fbcde3d8b3a.zip
Notes
Diffstat (limited to 'audio/gsi/Makefile')
-rw-r--r--audio/gsi/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/audio/gsi/Makefile b/audio/gsi/Makefile
new file mode 100644
index 000000000000..b1fde7c07fff
--- /dev/null
+++ b/audio/gsi/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: gsi
+# Date created: 3 October 2000
+# Whom: Sean Farley <sean-freebsd@farley.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gsi
+PORTVERSION= 0.9.4
+CATEGORIES= audio
+MASTER_SITES= http://www.farley.org/ \
+ http://www.xs4all.nl/~whs/gsi/bestanden/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+MANCOMPRESSED= no
+
+MAN1= gsifile.1 gsiplay.1
+MAN3= gsi.3 gsi_commands.3 gsi_events.3 gsif.3 gsipcm.3
+MAN5= gsi.conf.5
+MAN7= gsi_overview.7
+MAN8= gsi_server.8
+
+pre-configure:
+ @${SH} ${FILESDIR}/configure.sh ${PREFIX} ${WRKSRC}
+
+post-install:
+ @${INSTALL_DATA} ${WRKSRC}/server.conf/gsi.conf.fbsd \
+ ${PREFIX}/etc/gsi.conf.sample
+.for fileNdx in gsi_server gsifile gsiplay
+ @strip ${PREFIX}/bin/${fileNdx}
+.endfor
+.for lib in "" cd f midi_pcm mixer pcm synth
+ @strip ${PREFIX}/lib/libgsi${lib}.so.[02]
+.endfor
+ @${ECHO} "A sample configuration file was installed as" \
+ ${PREFIX}/etc/gsi.conf.sample.
+ @${ECHO} "Copy and edit it to fit the system."
+ @${ECHO}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>