aboutsummaryrefslogtreecommitdiff
path: root/audio/gstreamer1-plugins-sndio/Makefile
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2017-02-16 10:23:40 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2017-02-16 10:23:40 +0000
commitdc7c0f4c7dca0ac01ee33019cc7d1bbc0ce25623 (patch)
tree21c791109342525823513cb8b260789104586b9a /audio/gstreamer1-plugins-sndio/Makefile
parent6517e014288c68034ca63b7d1142fa6ff5b9fda2 (diff)
downloadports-dc7c0f4c7dca0ac01ee33019cc7d1bbc0ce25623.tar.gz
ports-dc7c0f4c7dca0ac01ee33019cc7d1bbc0ce25623.zip
Notes
Diffstat (limited to 'audio/gstreamer1-plugins-sndio/Makefile')
-rw-r--r--audio/gstreamer1-plugins-sndio/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/audio/gstreamer1-plugins-sndio/Makefile b/audio/gstreamer1-plugins-sndio/Makefile
new file mode 100644
index 000000000000..a15702e5399a
--- /dev/null
+++ b/audio/gstreamer1-plugins-sndio/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= gstreamer1-plugins-sndio
+PORTVERSION= 1.8.0
+DISTVERSIONPREFIX= v
+CATEGORIES= audio
+
+MAINTAINER= tobik@FreeBSD.org
+COMMENT= Sndio audio sink and source for GStreamer
+
+LICENSE= ISCL
+
+LIB_DEPENDS= libgstaudio-1.0.so:multimedia/gstreamer1-plugins \
+ libgstbase-1.0.so:multimedia/gstreamer1 \
+ libsndio.so:audio/sndio
+
+USE_GITHUB= yes
+GH_ACCOUNT= t6
+
+USES= gettext-runtime pkgconfig
+USE_GNOME= glib20
+USE_LDCONFIG= yes
+
+PLIST_FILES= lib/gstreamer-1.0/libgstsndio.so
+
+.include <bsd.port.mk>