aboutsummaryrefslogtreecommitdiff
path: root/audio/gtkguitune
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-10-20 09:40:33 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-10-20 09:40:33 +0000
commitad5bc8bb0fed136d5cc01847bec1f187b66d256e (patch)
treea093a76f609e21f8cffa92e27b5fe612ec09ed75 /audio/gtkguitune
parentd74f3a6914991dfed15cc1833d2413b42c7b8a7a (diff)
downloadports-ad5bc8bb0fed136d5cc01847bec1f187b66d256e.tar.gz
ports-ad5bc8bb0fed136d5cc01847bec1f187b66d256e.zip
Notes
Diffstat (limited to 'audio/gtkguitune')
-rw-r--r--audio/gtkguitune/Makefile20
-rw-r--r--audio/gtkguitune/distinfo6
-rw-r--r--audio/gtkguitune/files/patch-guitune.cc14
-rw-r--r--audio/gtkguitune/files/patch-main.cc14
4 files changed, 19 insertions, 35 deletions
diff --git a/audio/gtkguitune/Makefile b/audio/gtkguitune/Makefile
index affc8482b289..2dbc4838c074 100644
--- a/audio/gtkguitune/Makefile
+++ b/audio/gtkguitune/Makefile
@@ -6,18 +6,30 @@
#
PORTNAME= gtkguitune
-PORTVERSION= 0.7
-PORTREVISION= 3
+PORTVERSION= 0.8
CATEGORIES= audio
MASTER_SITES= http://www.geocities.com/harpin_floh/mysoft/
+DISTNAME= ${PORTNAME}-gtk2-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A guitar (and other instruments) tuner for GTK
-LIB_DEPENDS= gtkmm-1.2.2:${PORTSDIR}/x11-toolkits/gtkmm12
+LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/icons/hicolor/scalable/apps/guitune_logo.svg
-PLIST_FILES= bin/gtkguitune
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|VERSION=0.7|VERSION=${PORTVERSION}|g' ${WRKSRC}/configure
+.for file in guitune.cc main.cc
+ @${REINPLACE_CMD} -e \
+ 's|<linux/soundcard.h>|<sys/soundcard.h>|' ${WRKSRC}/${file}
+.endfor
.include <bsd.port.mk>
diff --git a/audio/gtkguitune/distinfo b/audio/gtkguitune/distinfo
index 968d674ed3ae..af1d78f4d5f4 100644
--- a/audio/gtkguitune/distinfo
+++ b/audio/gtkguitune/distinfo
@@ -1,3 +1,3 @@
-MD5 (gtkguitune-0.7.tar.gz) = 1fa82bf4034b45750c831902a1a96bdf
-SHA256 (gtkguitune-0.7.tar.gz) = a2816ab63d85c86d2e352ec2c2d3b4cb6d607f7593798533da0993bfb2db5bf3
-SIZE (gtkguitune-0.7.tar.gz) = 54992
+MD5 (gtkguitune-gtk2-0.8.tar.gz) = aeed6895e76af1fd0bce500fbe3e492a
+SHA256 (gtkguitune-gtk2-0.8.tar.gz) = be0e8a8b8085498201d3674a1a719d4841a4f79cd7bcff3e14fec83512c30849
+SIZE (gtkguitune-gtk2-0.8.tar.gz) = 660808
diff --git a/audio/gtkguitune/files/patch-guitune.cc b/audio/gtkguitune/files/patch-guitune.cc
deleted file mode 100644
index 711d88d5d22b..000000000000
--- a/audio/gtkguitune/files/patch-guitune.cc
+++ /dev/null
@@ -1,14 +0,0 @@
---- guitune.cc.orig Sat Feb 12 11:14:56 2005
-+++ guitune.cc Sat Feb 12 11:15:02 2005
-@@ -24,7 +24,11 @@
- #include <sys/stat.h>
- #include <fcntl.h>
- #include <sys/ioctl.h>
-+#ifdef __linux__
- #include <linux/soundcard.h>
-+#else
-+#include <sys/soundcard.h>
-+#endif
-
- #include <gtk--/main.h>
- #include <gtk--/box.h>
diff --git a/audio/gtkguitune/files/patch-main.cc b/audio/gtkguitune/files/patch-main.cc
deleted file mode 100644
index 62f1005164f8..000000000000
--- a/audio/gtkguitune/files/patch-main.cc
+++ /dev/null
@@ -1,14 +0,0 @@
---- main.cc.orig Sat May 31 16:31:12 2003
-+++ main.cc Sat Feb 12 11:22:19 2005
-@@ -24,7 +24,11 @@
- #include <fcntl.h>
- #include <unistd.h>
- #include <sys/ioctl.h>
-+#ifdef __linux__
- #include <linux/soundcard.h>
-+#else
-+#include <sys/soundcard.h>
-+#endif
-
- #include <gtk/gtk.h>
- #include <gtk--/window.h>