aboutsummaryrefslogtreecommitdiff
path: root/audio/gtkpod/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2009-08-24 20:39:42 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2009-08-24 20:39:42 +0000
commit7be7bfd4f1411bdf6d7d4c5fb6a8b633a611a88b (patch)
treedb5d852e7f1c00ffff329ef42ae17b08c129bd7b /audio/gtkpod/Makefile
parent20fc645e9ff5a3dbf96d9fea5dfdd4be294c87a3 (diff)
downloadports-7be7bfd4f1411bdf6d7d4c5fb6a8b633a611a88b.tar.gz
ports-7be7bfd4f1411bdf6d7d4c5fb6a8b633a611a88b.zip
Notes
Diffstat (limited to 'audio/gtkpod/Makefile')
-rw-r--r--audio/gtkpod/Makefile33
1 files changed, 18 insertions, 15 deletions
diff --git a/audio/gtkpod/Makefile b/audio/gtkpod/Makefile
index 96eb427cb4b4..a78b4b87ea41 100644
--- a/audio/gtkpod/Makefile
+++ b/audio/gtkpod/Makefile
@@ -6,49 +6,57 @@
#
PORTNAME= gtkpod
-PORTVERSION= 0.99.12
-PORTREVISION= 5
+PORTVERSION= 0.99.14
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= danfe@FreeBSD.org
-COMMENT= GUI for Apple iPods using GTK2
+COMMENT= GUI for Apple iPod using GTK2
LIB_DEPENDS= id3tag.0:${PORTSDIR}/audio/libid3tag \
gpod.5:${PORTSDIR}/audio/libgpod
RUN_DEPENDS= mp3gain:${PORTSDIR}/audio/mp3gain \
iconv:${PORTSDIR}/converters/libiconv
-BROKEN= does not build
-
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GNOME= gtk20 libglade2 libgnomecanvas
+USE_GNOME= gtk20 libglade2
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
INSTALLS_ICONS= yes
WANT_GNOME= yes
+MAN1= gtkpod.1
+
+PORTDOCS= ChangeLog README TODOandBUGS.txt TROUBLESHOOTING
OPTIONS= MPEG4IP "Enable AAC and H.264 support with MPEG4IP" off \
- VORBIS "Enable Ogg/Vorbis support" on \
- FLAC "Enable FLAC support" on \
+ VORBIS "Enable Ogg/Vorbis support (decoding)" on \
+ FLAC "Enable FLAC support (decoding)" on \
+ LAME "Enable encoding to MP3 format" on \
GNOMEVFS "Enable iPod autodetection support" off \
HAL "Enable HAL support" off \
- CURL "Build with coverart download support" off
+ CURL "Build with coverart download support" on
.include <bsd.port.pre.mk>
.if defined(WITH_MPEG4IP) || exists(${LOCALBASE}/lib/libmp4v2.so)
LIB_DEPENDS+= mp4v2.0:${PORTSDIR}/multimedia/mpeg4ip-libmp4v2
+RUN_DEPENDS+= faac:${PORTSDIR}/audio/faac faad:${PORTSDIR}/audio/faad
.endif
.if defined(WITH_VORBIS) || exists(${LOCALBASE}/lib/libvorbis.so)
LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+RUN_DEPENDS+= oggdec:${PORTSDIR}/audio/vorbis-tools
.endif
.if defined(WITH_FLAC) || exists(${LOCALBASE}/lib/libFLAC.so)
LIB_DEPENDS+= FLAC.10:${PORTSDIR}/audio/flac
.endif
+.if defined(WITH_LAME) || exists(${LOCALBASE}/bin/lame)
+RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame
+.endif
+
.if defined(WITH_GNOMEVFS) || ${HAVE_GNOME:Mgnomevfs2}
USE_GNOME+= gnomevfs2
.endif
@@ -61,9 +69,6 @@ LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
LIB_DEPENDS+= curl.5:${PORTSDIR}/ftp/curl
.endif
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include"
-CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
-
pre-configure: .SILENT
# install locale correctly (share dir instead of lib dir)
${REINPLACE_CMD} -e 's|DATADIRNAME=lib|DATADIRNAME=share|' \
@@ -72,9 +77,7 @@ pre-configure: .SILENT
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for f in ChangeLog README TODOandBUGS.txt TROUBLESHOOTING
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
.include <bsd.port.post.mk>