aboutsummaryrefslogtreecommitdiff
path: root/audio/gtkpod
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-07-28 11:08:32 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-07-28 11:08:32 +0000
commit1ba7697f6aee06b7999ef809e8e8d600f6cf52b6 (patch)
tree9ed991a20dde44dee225ba8b0931c4a2e8781be7 /audio/gtkpod
parentfad33c4f8792768c64f54a4884559b01678adf66 (diff)
downloadports-1ba7697f6aee06b7999ef809e8e8d600f6cf52b6.tar.gz
ports-1ba7697f6aee06b7999ef809e8e8d600f6cf52b6.zip
Notes
Diffstat (limited to 'audio/gtkpod')
-rw-r--r--audio/gtkpod/Makefile2
-rw-r--r--audio/gtkpod/distinfo4
-rw-r--r--audio/gtkpod/files/patch-src::mp4file.c12
3 files changed, 16 insertions, 2 deletions
diff --git a/audio/gtkpod/Makefile b/audio/gtkpod/Makefile
index 13d184c60088..636228d41636 100644
--- a/audio/gtkpod/Makefile
+++ b/audio/gtkpod/Makefile
@@ -7,9 +7,11 @@
PORTNAME= gtkpod
PORTVERSION= 0.80
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-2
MAINTAINER= david@dyn-ns.net
COMMENT= GUI for Apple iPods using GTK2
diff --git a/audio/gtkpod/distinfo b/audio/gtkpod/distinfo
index 51e6d0a59c1b..f98f9c147de9 100644
--- a/audio/gtkpod/distinfo
+++ b/audio/gtkpod/distinfo
@@ -1,2 +1,2 @@
-MD5 (gtkpod-0.80.tar.gz) = 369790286247a9634944aba9f1ac2587
-SIZE (gtkpod-0.80.tar.gz) = 672614
+MD5 (gtkpod-0.80-2.tar.gz) = 50cc19b1a535df4c37e588baa08bf3c4
+SIZE (gtkpod-0.80-2.tar.gz) = 673639
diff --git a/audio/gtkpod/files/patch-src::mp4file.c b/audio/gtkpod/files/patch-src::mp4file.c
new file mode 100644
index 000000000000..70356b63983c
--- /dev/null
+++ b/audio/gtkpod/files/patch-src::mp4file.c
@@ -0,0 +1,12 @@
+--- src/mp4file.c.orig Wed Jul 28 00:22:05 2004
++++ src/mp4file.c Wed Jul 28 00:22:50 2004
+@@ -108,7 +108,8 @@
+ #define MP4V2_HAS_METADATA_BUG TRUE
+
+ #include <sys/types.h>
+-#include <stdint.h>
++#include <sys/param.h>
++#include <inttypes.h>
+ #include <stdlib.h>
+ #include <string.h>
+ #include "mp4.h"