aboutsummaryrefslogtreecommitdiff
path: root/audio/hawkvoice/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-03-25 11:56:00 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-03-25 11:56:00 +0000
commitc0bb62a2125e083d5c87106f8d889523f4369ec1 (patch)
tree2ce13c03068dd024cf2aad29ea8760232495c1aa /audio/hawkvoice/Makefile
parent920d7855a11e145654ecb73fecbd8f02c6107828 (diff)
downloadports-c0bb62a2125e083d5c87106f8d889523f4369ec1.tar.gz
ports-c0bb62a2125e083d5c87106f8d889523f4369ec1.zip
Notes
Diffstat (limited to 'audio/hawkvoice/Makefile')
-rw-r--r--audio/hawkvoice/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/audio/hawkvoice/Makefile b/audio/hawkvoice/Makefile
new file mode 100644
index 000000000000..98f5ac4bf9d3
--- /dev/null
+++ b/audio/hawkvoice/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: hawkvoice
+# Date created: 2006-03-05
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hawkvoice
+PORTVERSION= 0.91
+CATEGORIES= audio devel
+MASTER_SITES= http://www.hawksoft.com/download/files/
+DISTNAME= HawkVoiceDI091src
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= Portable sound and speech compression library
+
+USE_ZIP= yes
+USE_DOS2UNIX= yes
+USE_GMAKE= yes
+MAKEFILE= makefile.linux
+INSTALLS_SHLIB= yes
+
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include
+MAKE_ENV= CC="${CC}" CFLAGS="${CFLAGS} ${OPTFLAGS}" \
+ LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}" \
+ MAKE="${GMAKE}"
+
+WRKSRC= ${WRKDIR}/HawkVoiceDI/src
+
+OPTIONS= OPTIMIZATION "Enable optimization" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_OPTIMIZATION)
+CFLAGS+= -funroll-all-loops -ffast-math -fomit-frame-pointer -D_GNU_SOURCE -D_REENTRANT
+.endif
+
+post-patch:
+ ${FIND} ${WRKSRC} -type f -exec ${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|g' "{}" \;
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for FILE in api.txt HVDIchanges.txt readme.txt cryptapi.txt
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>