aboutsummaryrefslogtreecommitdiff
path: root/audio/headsetcontrol
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2020-10-26 13:32:47 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2020-10-26 13:32:47 +0000
commit81ccfc431df59835cace1fb4e32b332521c17bb1 (patch)
treeb2eb6253b5da90787556c8e1c2b4f393742ee5c5 /audio/headsetcontrol
parentb84457ef19dc921a3244ffed89d858ba1f7a789c (diff)
downloadports-81ccfc431df59835cace1fb4e32b332521c17bb1.tar.gz
ports-81ccfc431df59835cace1fb4e32b332521c17bb1.zip
Notes
Diffstat (limited to 'audio/headsetcontrol')
-rw-r--r--audio/headsetcontrol/Makefile41
-rw-r--r--audio/headsetcontrol/distinfo3
-rw-r--r--audio/headsetcontrol/pkg-descr3
-rw-r--r--audio/headsetcontrol/pkg-message19
4 files changed, 66 insertions, 0 deletions
diff --git a/audio/headsetcontrol/Makefile b/audio/headsetcontrol/Makefile
new file mode 100644
index 000000000000..1748b0d760d6
--- /dev/null
+++ b/audio/headsetcontrol/Makefile
@@ -0,0 +1,41 @@
+# Created by: Alexander Vereeken <Alexander88207@protonmail.com>
+# $FreeBSD$
+
+PORTNAME= headsetcontrol
+PORTVERSION= 2.3
+CATEGORIES= audio
+
+MAINTAINER= Alexander88207@protonmail.com
+COMMENT= Tool to setup sidetone for various gaming headsets
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/license
+
+BUILD_DEPENDS= hidapi>=0:comms/hidapi
+LIB_DEPENDS+= libhidapi.so:comms/hidapi
+
+USES= cmake
+
+USE_GITHUB= yes
+GH_ACCOUNT= Sapd
+GH_PROJECT= HeadsetControl
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/etc/udev/|/usr/local/etc/udev/|g' ${WRKSRC}/CMakeLists.txt
+
+PLIST_FILES= ${LOCALBASE}/bin/headsetcontrol \
+ ${LOCALBASE}/etc/udev/rules.d/50-corsair-void-pro-usb.rules \
+ ${LOCALBASE}/etc/udev/rules.d/50-corsair-void-pro.rules \
+ ${LOCALBASE}/etc/udev/rules.d/50-corsair-void.rules \
+ ${LOCALBASE}/etc/udev/rules.d/50-corsair_void_rgb_usb.rules \
+ ${LOCALBASE}/etc/udev/rules.d/50-logitech-g430.rules \
+ ${LOCALBASE}/etc/udev/rules.d/50-logitech-g533.rules \
+ ${LOCALBASE}/etc/udev/rules.d/50-logitech-g633.rules \
+ ${LOCALBASE}/etc/udev/rules.d/50-logitech-g930.rules \
+ ${LOCALBASE}/etc/udev/rules.d/50-logitech-g933.rules \
+ ${LOCALBASE}/etc/udev/rules.d/50-logitech-g935.rules \
+ ${LOCALBASE}/etc/udev/rules.d/50-steelseries-arctis-7-2019.rules \
+ ${LOCALBASE}/etc/udev/rules.d/50-steelseries-arctis-7.rules \
+ ${LOCALBASE}/etc/udev/rules.d/50-steelseries-arctis-pro-2019.rules
+
+.include <bsd.port.mk>
diff --git a/audio/headsetcontrol/distinfo b/audio/headsetcontrol/distinfo
new file mode 100644
index 000000000000..98500aeaabd7
--- /dev/null
+++ b/audio/headsetcontrol/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1580335600
+SHA256 (Sapd-HeadsetControl-2.3_GH0.tar.gz) = 4969f13b5c5e2fee3b4b75d09f1a3ef1b707615aababf40d1f7cac60eab1fc21
+SIZE (Sapd-HeadsetControl-2.3_GH0.tar.gz) = 28045
diff --git a/audio/headsetcontrol/pkg-descr b/audio/headsetcontrol/pkg-descr
new file mode 100644
index 000000000000..4d01ca330545
--- /dev/null
+++ b/audio/headsetcontrol/pkg-descr
@@ -0,0 +1,3 @@
+HeadsetControl allows you to setup sidetone for various of gaming headsets.
+
+WWW: https://github.com/Sapd/HeadsetControl
diff --git a/audio/headsetcontrol/pkg-message b/audio/headsetcontrol/pkg-message
new file mode 100644
index 000000000000..8a2ecbd856e5
--- /dev/null
+++ b/audio/headsetcontrol/pkg-message
@@ -0,0 +1,19 @@
+[
+{
+ message: <<EOM
+Type headsetcontrol -h to get all available options.
+
+headsetcontrol -s 128 sets the sidetone to 128 (REAL loud). You can silence it with 0. I recommend a loudness of 16.
+
+Following options don't work on all devices yet:
+
+headsetcontrol -b check battery level. Returns a value from 0 to 100 or loading.
+
+headsetcontrol -n 0|1 sends a notification sound, made by the headset. 0 or 1 are currently supported as values.
+
+headsetcontrol -l 0|1 switches LED off/on (off almost doubles battery lifetime!).
+
+headsetcontrol -c cut unnecessary output, for reading by other scripts or applications.
+EOM
+}
+]