aboutsummaryrefslogtreecommitdiff
path: root/audio/herrie/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-04-15 18:55:20 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-04-15 18:55:20 +0000
commit32704f5009658751d3bba21ecb6ea0088a239e36 (patch)
tree31a5507748f8846ea9555d1340da78177feee040 /audio/herrie/Makefile
parent9d1d001794f0ebf42bb227b6d86a7b5c38baba97 (diff)
Notes
Diffstat (limited to 'audio/herrie/Makefile')
-rw-r--r--audio/herrie/Makefile23
1 files changed, 19 insertions, 4 deletions
diff --git a/audio/herrie/Makefile b/audio/herrie/Makefile
index 54b06a37af25..07190eb3c044 100644
--- a/audio/herrie/Makefile
+++ b/audio/herrie/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= herrie
-PORTVERSION= 1.5.1
+PORTVERSION= 1.6
CATEGORIES= audio
-MASTER_SITES= http://g-rave.nl/projects/herrie/distfiles/ \
+MASTER_SITES= http://herrie.info/distfiles/ \
http://www.il.fontys.nl/~ed/projects/herrie/distfiles/ \
http://www.stack.nl/~ed/projects/herrie/distfiles/
@@ -20,16 +20,17 @@ LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
HAS_CONFIGURE= yes
CONFIGURE_ENV+= PREFIX=${PREFIX}
+USE_BZIP2= yes
USE_OPENSSL= yes
USE_GNOME= glib20
-USE_GETTEXT= yes
OPTIONS= MAD "MAD MP3 support" on \
VORBIS "Ogg Vorbis support" on \
SNDFILE "libsndfile support" on \
MODPLUG "libmodplug support" off \
LIBAO "LibAO support (breaks chroot)" off \
- XCURSES "Build XCurses version" off
+ XCURSES "Build XCurses version" off \
+ XSPF "Support for XSPF playlists" on
MAN1= herrie.1
MANCOMPRESSED= yes
@@ -65,5 +66,19 @@ CONFIGURE_ARGS+=ao
LIB_DEPENDS+= XCurses.2:${PORTSDIR}/devel/pdcurses
CONFIGURE_ARGS+=xcurses
.endif
+.if !defined(WITHOUT_XSPF)
+# We need 0.6.3, which has proper C bindings
+BUILD_DEPENDS+= libspiff>=0.6.3:${PORTSDIR}/multimedia/libspiff
+RUN_DEPENDS+= libspiff>=0.6.3:${PORTSDIR}/multimedia/libspiff
+.else
+CONFIGURE_ARGS+=no_xspf
+.endif
+.if !defined(WITHOUT_NLS)
+PLIST_SUB+= NLS=""
+USE_GETTEXT= yes
+.else
+PLIST_SUB+= NLS="@comment "
+CONFIGURE_ARGS+=no_trans
+.endif
.include <bsd.port.post.mk>