aboutsummaryrefslogtreecommitdiff
path: root/audio/herrie
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2012-12-18 03:16:17 +0000
committerWesley Shields <wxs@FreeBSD.org>2012-12-18 03:16:17 +0000
commit760cc63a9ed1e538a5ca5962605c6ab8d9fdc8af (patch)
tree79ee7f48e053f06f973f624538fc6e2ebf45e711 /audio/herrie
parent6ac054bbd965c2eff73c3b52317b2568c55444a9 (diff)
downloadports-760cc63a9ed1e538a5ca5962605c6ab8d9fdc8af.tar.gz
ports-760cc63a9ed1e538a5ca5962605c6ab8d9fdc8af.zip
Notes
Diffstat (limited to 'audio/herrie')
-rw-r--r--audio/herrie/Makefile56
1 files changed, 25 insertions, 31 deletions
diff --git a/audio/herrie/Makefile b/audio/herrie/Makefile
index 7d73f7c0cc7b..9043a26ae0cb 100644
--- a/audio/herrie/Makefile
+++ b/audio/herrie/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: herrie
-# Date created: 01 August 2006
-# Whom: Ed Schouten <ed@fxq.nl>
-#
+# Created by: Ed Schouten <ed@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= herrie
PORTVERSION= 2.2
@@ -22,64 +18,62 @@ CONFIGURE_ENV+= PREFIX=${PREFIX}
USE_BZIP2= yes
USE_GNOME= glib20
-OPTIONS= MAD "MAD MP3 support" on \
- VORBIS "Ogg Vorbis support" on \
- SNDFILE "libsndfile support" off \
- MODPLUG "libmodplug support" off \
- HTTP "HTTP streams and AudioScrobbler support" on \
- LIBAO "LibAO support (breaks chroot)" off \
- XCURSES "Build XCurses version" off \
- XSPF "Support for XSPF playlists" on
+OPTIONS_DEFINE= MAD VORBIS SNDFILE MODPLUG HTTP LIBAO XCURSES XSPF
+OPTIONS_DEFAULT= MAD VORBIS HTTP XSPF
+
+HTTP_DESC= HTTP streams and AudioScrobbler support
+LIBAO_DESC= LibAO support (breaks chroot)
+XCURSES_DESC= Build XCurses version
MAN1= herrie.1
MANCOMPRESSED= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${OSVERSION} < 700033
CONFIGURE_ARGS+=ncurses
.endif
-.if !defined(WITHOUT_MAD)
-LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/mad \
- id3tag.0:${PORTSDIR}/audio/libid3tag
+.if ${PORT_OPTIONS:MMAD}
+LIB_DEPENDS+= mad:${PORTSDIR}/audio/mad \
+ id3tag:${PORTSDIR}/audio/libid3tag
.else
CONFIGURE_ARGS+=no_mp3
.endif
-.if !defined(WITHOUT_VORBIS)
-LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+.if ${PORT_OPTIONS:MVORBIS}
+LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
.else
CONFIGURE_ARGS+=no_vorbis
.endif
-.if !defined(WITHOUT_SNDFILE)
-LIB_DEPENDS+= sndfile.1:${PORTSDIR}/audio/libsndfile
+.if ${PORT_OPTIONS:MSNDFILE}
+LIB_DEPENDS+= sndfile:${PORTSDIR}/audio/libsndfile
.else
CONFIGURE_ARGS+=no_sndfile
.endif
-.if !defined(WITHOUT_MODPLUG)
+.if ${PORT_OPTIONS:MMODPLUG}
LIB_DEPENDS+= modplug:${PORTSDIR}/audio/libmodplug
.else
CONFIGURE_ARGS+=no_modplug
.endif
-.if !defined(WITHOUT_HTTP)
+.if ${PORT_OPTIONS:MHTTP}
LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
.else
CONFIGURE_ARGS+=no_http no_scrobbler
.endif
-.if !defined(WITHOUT_LIBAO)
-LIB_DEPENDS+= ao.4:${PORTSDIR}/audio/libao
+.if ${PORT_OPTIONS:MLIBAO}
+LIB_DEPENDS+= ao:${PORTSDIR}/audio/libao
CONFIGURE_ARGS+=ao
.endif
-.if !defined(WITHOUT_XCURSES)
-LIB_DEPENDS+= XCurses.2:${PORTSDIR}/devel/pdcurses
+.if ${PORT_OPTIONS:MXCURSES}
+LIB_DEPENDS+= XCurses:${PORTSDIR}/devel/pdcurses
CONFIGURE_ARGS+=xcurses
.endif
-.if !defined(WITHOUT_XSPF)
-LIB_DEPENDS+= xspf.4:${PORTSDIR}/multimedia/libxspf
+.if ${PORT_OPTIONS:MXSPF}
+LIB_DEPENDS+= xspf:${PORTSDIR}/multimedia/libxspf
.else
CONFIGURE_ARGS+=no_xspf
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
PLIST_SUB+= NLS=""
USE_GETTEXT= yes
.else
@@ -87,4 +81,4 @@ PLIST_SUB+= NLS="@comment "
CONFIGURE_ARGS+=no_nls
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>