aboutsummaryrefslogtreecommitdiff
path: root/audio/icecast
diff options
context:
space:
mode:
authorDonald Burr <dburr@FreeBSD.org>1999-10-05 04:59:12 +0000
committerDonald Burr <dburr@FreeBSD.org>1999-10-05 04:59:12 +0000
commitefc5be687408dea314e22136693ee4237b55cb5d (patch)
treea75c02226f2c1fb6d3200b6bfd8930e971b4aa5a /audio/icecast
parent6584d445503e69137cfa902669b4c515a1e0219a (diff)
downloadports-efc5be687408dea314e22136693ee4237b55cb5d.tar.gz
ports-efc5be687408dea314e22136693ee4237b55cb5d.zip
Notes
Diffstat (limited to 'audio/icecast')
-rw-r--r--audio/icecast/Makefile33
-rw-r--r--audio/icecast/distinfo2
-rw-r--r--audio/icecast/pkg-descr2
-rw-r--r--audio/icecast/pkg-plist43
4 files changed, 61 insertions, 19 deletions
diff --git a/audio/icecast/Makefile b/audio/icecast/Makefile
index 8dc5c0e6782f..ac3cd551aacf 100644
--- a/audio/icecast/Makefile
+++ b/audio/icecast/Makefile
@@ -1,37 +1,60 @@
# New ports collection makefile for: icecast
-# Version required: 1.1.4
+# Version required: 1.3.0
# Date created: 28 Jan 1999
# Whom: Chip Marshall <chip@eboai.org>
#
# $FreeBSD$
#
-DISTNAME= icecast-1.1.4
+DISTNAME= icecast-1.3.0
CATEGORIES= audio net
-MASTER_SITES= http://icecast.linuxpower.org/releases/ \
+MASTER_SITES= http://www.icecast.org/releases/ \
ftp://ftp.eboai.org/pub/icecast/
MAINTAINER= chip@eboai.org
+WRKSRC= ${WRKDIR}/icecast-1.3
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-crypt --with-libwrap
+CONFIGURE_ARGS= --with-libwrap
+
+do-configure:
+ cd ${WRKSRC} && ${SH} ./configure ${CONFIGURE_ARGS}
+ cd ${WRKSRC}/liveice && ${SH} ./configure ${CONFIGURE_ARGS}
+
+do-build:
+ cd ${WRKSRC} && ${MAKE}
+ cd ${WRKSRC} && ${MAKE} mkpasswd
+ cd ${WRKSRC}/liveice && ${MAKE}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/icecast ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/mkpasswd ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/shout/listen ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/shout/shout ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/shout/calibrate ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/shout/stresstest ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/liveice/liveice ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/misc/iceplay ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/shout/iceplay ${PREFIX}/bin
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/icecast
${INSTALL_MAN} ${WRKSRC}/doc/* ${PREFIX}/share/doc/icecast
+ ${INSTALL_MAN} ${WRKSRC}/liveice/README.liveice ${PREFIX}/share/doc/icecast
+ ${INSTALL_MAN} ${WRKSRC}/liveice/README.xingmp3enc ${PREFIX}/share/doc/icecast
+ ${INSTALL_MAN} ${WRKSRC}/liveice/README_new_mixer.txt ${PREFIX}/share/doc/icecast
${MKDIR} ${PREFIX}/share/examples/icecast
+ ${INSTALL_MAN} ${WRKSRC}/icecast.conf ${PREFIX}/share/examples/icecast
${INSTALL_MAN} ${WRKSRC}/liveice/liveice.cfg ${PREFIX}/share/examples/icecast
${INSTALL_MAN} ${WRKSRC}/shout/shoutrc.example ${PREFIX}/share/examples/icecast
${INSTALL_MAN} ${WRKSRC}/shout/playlist.example ${PREFIX}/share/examples/icecast
${INSTALL_MAN} ${WRKSRC}/shout/radio.tcl.example ${PREFIX}/share/examples/icecast
${MKDIR} ${PREFIX}/share/examples/icecast/icedir
${INSTALL_MAN} ${WRKSRC}/icedir/* ${PREFIX}/share/examples/icecast/icedir
+ ${MKDIR} ${PREFIX}/share/examples/icecast/templates
+ ${INSTALL_MAN} ${WRKSRC}/templates/* ${PREFIX}/share/examples/icecast/templates
+ ${INSTALL_MAN} ${WRKSRC}/liveice/frontend.tcl ${PREFIX}/share/examples/icecast
+ ${INSTALL_MAN} ${WRKSRC}/liveice/liveiceconfigure.tk ${PREFIX}/share/examples/icecast
.endif
+ @${CAT} ${PKGDIR}/MESSAGE
.include <bsd.port.mk>
diff --git a/audio/icecast/distinfo b/audio/icecast/distinfo
index 0383d4934bac..45815d8e8ec7 100644
--- a/audio/icecast/distinfo
+++ b/audio/icecast/distinfo
@@ -1 +1 @@
-MD5 (icecast-1.1.4.tar.gz) = 1015de18c670afa15791258d03905227
+MD5 (icecast-1.3.0.tar.gz) = d322cc60b5f3185a764bf65adca282e4
diff --git a/audio/icecast/pkg-descr b/audio/icecast/pkg-descr
index 6578c748ceba..2d2606179da3 100644
--- a/audio/icecast/pkg-descr
+++ b/audio/icecast/pkg-descr
@@ -4,4 +4,4 @@ It can also add itself to a directory server such as our own
icecast.linuxpower.org or Nullsoft's yp.shoutcast.com. It does not yet
support redirection of streams from other icecast servers, but soon will.
-WWW: http://icecast.linuxpower.org
+WWW: http://www.icecast.org/
diff --git a/audio/icecast/pkg-plist b/audio/icecast/pkg-plist
index 09a947fb7f86..3195443ba037 100644
--- a/audio/icecast/pkg-plist
+++ b/audio/icecast/pkg-plist
@@ -1,34 +1,53 @@
-bin/iceplay
+bin/mkpasswd
bin/listen
-bin/liveice
bin/shout
+bin/calibrate
+bin/stresstest
+bin/liveice
+bin/iceplay
sbin/icecast
share/doc/icecast/AUTHORS
share/doc/icecast/BUGS
-share/doc/icecast/BUGS.iceplay
share/doc/icecast/CHANGES
share/doc/icecast/COPYING
-share/doc/icecast/CREDITS.shout
share/doc/icecast/FAQ
share/doc/icecast/INSTALL
share/doc/icecast/README
-share/doc/icecast/README.icedir
-share/doc/icecast/README.iceplay
-share/doc/icecast/README.shout
share/doc/icecast/TESTED
-share/doc/icecast/TODO.shout
+share/doc/icecast/TODO
+share/doc/icecast/manual.html
+share/doc/icecast/README.liveice
+share/doc/icecast/README.xingmp3enc
+share/doc/icecast/README_new_mixer.txt
+share/examples/icecast/icecast.conf
+share/examples/icecast/liveice.cfg
+share/examples/icecast/shoutrc.example
+share/examples/icecast/playlist.example
share/examples/icecast/icedir/addsrv
+share/examples/icecast/icedir/byserver.php3
+share/examples/icecast/icedir/bystream.php3
+share/examples/icecast/icedir/db_mysql.inc
+share/examples/icecast/icedir/example.html
share/examples/icecast/icedir/example.phtml
share/examples/icecast/icedir/functions.phps
share/examples/icecast/icedir/gen-playlist
+share/examples/icecast/icedir/gen-playlist.pls
share/examples/icecast/icedir/icedir_cleanup.pl
share/examples/icecast/icedir/remsrv
-share/examples/icecast/icedir/server_tbl.sql
+share/examples/icecast/icedir/servers.sql
+share/examples/icecast/icedir/sources.sql
share/examples/icecast/icedir/tchsrv
-share/examples/icecast/liveice.cfg
-share/examples/icecast/playlist.example
+share/examples/icecast/icedir/touch
+share/examples/icecast/icedir/yp.inc
share/examples/icecast/radio.tcl.example
-share/examples/icecast/shoutrc.example
+share/examples/icecast/templates/bodytag.html
+share/examples/icecast/templates/info.html
+share/examples/icecast/templates/list_directory.html
+share/examples/icecast/templates/mountlist.html
+share/examples/icecast/templates/statistics.html
+share/examples/icecast/frontend.tcl
+share/examples/icecast/liveiceconfigure.tk
@dirrm share/doc/icecast
@dirrm share/examples/icecast/icedir
+@dirrm share/examples/icecast/templates
@dirrm share/examples/icecast