aboutsummaryrefslogtreecommitdiff
path: root/audio/icegenerator
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-10-13 23:33:46 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-10-13 23:33:46 +0000
commit1e9bcc9e2590c3a328c45014d617242cd481e9e2 (patch)
treed2bf361a6fc6ad383765fd955a5deaca84c62ed3 /audio/icegenerator
parent8ce861a35fecd86689f47727945d3014e1474030 (diff)
downloadports-1e9bcc9e2590c3a328c45014d617242cd481e9e2.tar.gz
ports-1e9bcc9e2590c3a328c45014d617242cd481e9e2.zip
Notes
Diffstat (limited to 'audio/icegenerator')
-rw-r--r--audio/icegenerator/Makefile31
-rw-r--r--audio/icegenerator/distinfo2
-rw-r--r--audio/icegenerator/pkg-descr13
-rw-r--r--audio/icegenerator/pkg-message8
-rw-r--r--audio/icegenerator/pkg-plist4
5 files changed, 58 insertions, 0 deletions
diff --git a/audio/icegenerator/Makefile b/audio/icegenerator/Makefile
new file mode 100644
index 000000000000..38eb2720c750
--- /dev/null
+++ b/audio/icegenerator/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: icegenerator
+# Date created: 18 August 2004
+# Whom: Nadelyaev Stanislav <funkblaster@n11.bmstu.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= icegenerator
+PORTVERSION= 0.5.4
+CATEGORIES= audio net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= funkblaster@n11.bmstu.ru
+COMMENT= Direct streaming generator for Icecast/Shoutcast
+
+LIB_DEPENDS= shout.3:${PORTSDIR}/audio/libshout2
+
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+.endif
+ ${INSTALL_DATA} ${WRKSRC}/etc/icegenerator.conf.dist ${PREFIX}/etc
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/audio/icegenerator/distinfo b/audio/icegenerator/distinfo
new file mode 100644
index 000000000000..06493896797d
--- /dev/null
+++ b/audio/icegenerator/distinfo
@@ -0,0 +1,2 @@
+MD5 (icegenerator-0.5.4.tar.gz) = 931d94fce16d062e446dc1b8ce36c8ab
+SIZE (icegenerator-0.5.4.tar.gz) = 129206
diff --git a/audio/icegenerator/pkg-descr b/audio/icegenerator/pkg-descr
new file mode 100644
index 000000000000..c457213bb39e
--- /dev/null
+++ b/audio/icegenerator/pkg-descr
@@ -0,0 +1,13 @@
+IceGenerator is a direct streaming generator for Icecast/Shoutcast. It runs
+as a daemon.Three child processes handle all the stuff. A fourth (optional)
+child cares about telnet communication. Main idea for this program is radio
+automation on a Icecast/Shoutcast server. If you have many server processes and
+CPU saving is your priority, u can use IceGenerator. Obviously mp3s/oggs will b
+e
+already resampled to allow their streaming on your bandwidth capability.
+For more information see share/doc/icegenerator/README.
+
+WWW: http://tortugalabs.it
+
+- Stanislav Nadelyaev
+funkblaster@n11.bmstu.ru
diff --git a/audio/icegenerator/pkg-message b/audio/icegenerator/pkg-message
new file mode 100644
index 000000000000..2b1e24d2638a
--- /dev/null
+++ b/audio/icegenerator/pkg-message
@@ -0,0 +1,8 @@
+==========================================================================
+
+ Icegenerator has now been installed. To get it up and running, copy
+ ${PREFIX}/etc/icegenerator.conf.dist to ${PREFIX}/etc/icegenerator.conf
+ and modify it to match your setup.
+ For more information see ${PREFIX}/share/doc/icegenerator/README
+
+==========================================================================
diff --git a/audio/icegenerator/pkg-plist b/audio/icegenerator/pkg-plist
new file mode 100644
index 000000000000..b1e2216e430c
--- /dev/null
+++ b/audio/icegenerator/pkg-plist
@@ -0,0 +1,4 @@
+bin/icegenerator
+etc/icegenerator.conf.dist
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%