aboutsummaryrefslogtreecommitdiff
path: root/audio/ices
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-16 13:57:52 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-16 13:57:52 +0000
commited41ba1ef5cff7d9f42523259ab0c31e95a5281c (patch)
tree74ea0cc7b31daa32840ebecdf0ea77528fcb7db8 /audio/ices
parent558023c2da7d53c8f91978feb55ae9467a3319ec (diff)
Notes
Diffstat (limited to 'audio/ices')
-rw-r--r--audio/ices/Makefile19
1 files changed, 7 insertions, 12 deletions
diff --git a/audio/ices/Makefile b/audio/ices/Makefile
index 6a9766dbdbcf..ffb4dff6bb7a 100644
--- a/audio/ices/Makefile
+++ b/audio/ices/Makefile
@@ -13,11 +13,11 @@ COMMENT= Vorbis streaming source client for icecast 2
LICENSE= GPLv2
-LIB_DEPENDS= ogg:${PORTSDIR}/audio/libogg \
- shout:${PORTSDIR}/audio/libshout2 \
- vorbis:${PORTSDIR}/audio/libvorbis \
- speex:${PORTSDIR}/audio/speex \
- theora:${PORTSDIR}/multimedia/libtheora
+LIB_DEPENDS= libogg.so:${PORTSDIR}/audio/libogg \
+ libshout.so:${PORTSDIR}/audio/libshout2 \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis \
+ libspeex.so:${PORTSDIR}/audio/speex \
+ libtheora.so:${PORTSDIR}/multimedia/libtheora
OPTIONS_DEFINE= ALSA
@@ -30,12 +30,7 @@ CONFIGURE_ARGS= --disable-roaraudio --disable-sun-audio
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MALSA}
-LIB_DEPENDS+= asound:${PORTSDIR}/audio/alsa-lib
-.else
-CONFIGURE_ARGS+=--disable-alsa
-.endif
+ALSA_LIB_DEPENDS+= libasound.so:${PORTSDIR}/audio/alsa-lib
+ALSA_CONFIGURE_ENABLE+= alsa
.include <bsd.port.mk>