aboutsummaryrefslogtreecommitdiff
path: root/audio/id3lib/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-10-28 07:19:07 +0000
committerWill Andrews <will@FreeBSD.org>2000-10-28 07:19:07 +0000
commit16e7216f9055b891bb26d6e63d07991351fbf519 (patch)
tree81a047551fe11f582cf25551b66ffa2800159cce /audio/id3lib/Makefile
parent6866ae8ed3c415ba8162df5c334fa899844edcf9 (diff)
downloadports-16e7216f9055b891bb26d6e63d07991351fbf519.tar.gz
ports-16e7216f9055b891bb26d6e63d07991351fbf519.zip
Notes
Diffstat (limited to 'audio/id3lib/Makefile')
-rw-r--r--audio/id3lib/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/audio/id3lib/Makefile b/audio/id3lib/Makefile
new file mode 100644
index 000000000000..88fe86145e4e
--- /dev/null
+++ b/audio/id3lib/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: id3lib
+# Date Created: 26 Oct 2000
+# Whom: Roman Shterenzon <roman@xpert.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= id3lib
+PORTVERSION= 3.7.13
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= roman@xpert.com
+
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LDFLAGS="-L${PREFIX}/lib" CPPFLAGS="-I${PREFIX}/include"
+
+post-extract:
+.for i in zlib popt
+ ${RM} -rf ${WRKSRC}/$i
+.endfor
+
+.include <bsd.port.mk>