aboutsummaryrefslogtreecommitdiff
path: root/audio/id3lib
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-01-28 12:59:13 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-01-28 12:59:13 +0000
commitfac6d01e3858560316350e421a3aeb0e46d45b19 (patch)
treeeab7f1389d6f4179917a9589ff3865e63609fed4 /audio/id3lib
parent01c4395870ce978b4197934aa5b22a46ac2507f9 (diff)
downloadports-fac6d01e3858560316350e421a3aeb0e46d45b19.tar.gz
ports-fac6d01e3858560316350e421a3aeb0e46d45b19.zip
Notes
Diffstat (limited to 'audio/id3lib')
-rw-r--r--audio/id3lib/Makefile9
-rw-r--r--audio/id3lib/files/patch-configure10
2 files changed, 13 insertions, 6 deletions
diff --git a/audio/id3lib/Makefile b/audio/id3lib/Makefile
index 5502b5487047..e9f0a9bbae35 100644
--- a/audio/id3lib/Makefile
+++ b/audio/id3lib/Makefile
@@ -15,11 +15,11 @@ MAINTAINER= roman@xpert.com
LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
-INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+INSTALLS_SHLIB= yes
+CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
.if ${CC} == cc || ${CC} == gcc
@@ -41,7 +41,4 @@ CPPFLAGS+= -I${LOCALBASE}/include/stlport
post-extract:
@${RM} -rf ${WRKSRC}/zlib
-post-install:
- @${RM} -f ${LOCALBASE}/lib/libid3.la
-
.include <bsd.port.post.mk>
diff --git a/audio/id3lib/files/patch-configure b/audio/id3lib/files/patch-configure
new file mode 100644
index 000000000000..f77a7f57db5a
--- /dev/null
+++ b/audio/id3lib/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Sun Nov 24 09:23:00 2002
++++ configure Fri Jan 24 01:05:47 2003
+@@ -7612,6 +7612,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'