aboutsummaryrefslogtreecommitdiff
path: root/audio/ifp-line/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-02-05 09:11:19 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-02-05 09:11:19 +0000
commit6aeedb77c9c80c24393e991a1e9bed1e5729f4bc (patch)
tree91fefa51eeeec849073fc203023dec667e99c6b7 /audio/ifp-line/Makefile
parent3a9c52e8b2b0f57705f620264f9d4d104d65ce64 (diff)
- Update to 0.38
PR: 175594 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=311676
Diffstat (limited to 'audio/ifp-line/Makefile')
-rw-r--r--audio/ifp-line/Makefile39
1 files changed, 25 insertions, 14 deletions
diff --git a/audio/ifp-line/Makefile b/audio/ifp-line/Makefile
index 9e618e3821b5..f1bb76cf04cf 100644
--- a/audio/ifp-line/Makefile
+++ b/audio/ifp-line/Makefile
@@ -1,36 +1,47 @@
-# ex:ts=8
-# New ports collection makefile for: ifp-line
-# Date created: Sep 21, 2004
-# Whom: riggs
-#
+# Created by: riggs
# $FreeBSD$
-#
PORTNAME= ifp-line
-PORTVERSION= 0.2.4.6
+PORTVERSION= 0.3
CATEGORIES= audio
MASTER_SITES= SF/ifp-driver/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Command line interface to iRiver music players
-MAN1= ifp.1
+LICENSE= GPLv2
+
+USE_ICONV= yes
+USE_AUTOTOOLS= aclocal autoheader automake autoconf
+ACLOCAL_ARGS= -I m4
+MAKE_JOBS_UNSAFE= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+MAN1= ifp.1
+PORTDOCS= NEWS README TIPS nonroot.sh
PLIST_FILES+= bin/ifp
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 800069
LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+.else
+LDFLAGS+= -lusb
.endif
post-patch:
-.if ${OSVERSION} >= 800069
- @${REINPLACE_CMD} -E -e 's,`libusb-config --cflags`,,g' \
- -e 's,`libusb-config --libs`,-lusb,g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e \
+ '/LIBUSB/s|ERROR|WARN|' ${WRKSRC}/configure.ac
+
+do-install:
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} ifp ${PREFIX}/bin)
+ (cd ${WRKSRC} && ${INSTALL_MAN} ifp.1 ${MANPREFIX}/man/man1)
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
.endif
-
-post-install:
- @${CAT} ${.CURDIR}/pkg-message
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>