aboutsummaryrefslogtreecommitdiff
path: root/audio/jack/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-12-16 17:34:13 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-12-16 17:34:13 +0000
commit23cacded34908af4abc44904d4759241673ddb85 (patch)
treee1b37c71e65fdbbd5f0120dd376f234b03a6d8fd /audio/jack/Makefile
parent4258f13dc4a47e053cee92b6e892014850084d68 (diff)
Notes
Diffstat (limited to 'audio/jack/Makefile')
-rw-r--r--audio/jack/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/audio/jack/Makefile b/audio/jack/Makefile
index 3ba9d30424f4..cd86227c542f 100644
--- a/audio/jack/Makefile
+++ b/audio/jack/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jackit
PORTVERSION= 0.118.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= http://jackaudio.org/downloads/
DISTNAME= jack-audio-connection-kit-${PORTVERSION}
@@ -18,7 +18,6 @@ COMMENT= A low-latency audio server
LIB_DEPENDS= portaudio.0:${PORTSDIR}/audio/portaudio \
sndfile.1:${PORTSDIR}/audio/libsndfile \
samplerate.1:${PORTSDIR}/audio/libsamplerate \
- asound.2:${PORTSDIR}/audio/alsa-lib \
celt.0:${PORTSDIR}/audio/celt
LATEST_LINK= jack
@@ -34,6 +33,8 @@ USE_GNOME= pkgconfig gnometarget gnomehack
MAN1= jackd.1 jackstart.1
+OPTIONS= ALSA "Build with ALSA compatibility library" off
+
.include <bsd.port.pre.mk>
.if !defined(NOPORTDOCS)
@@ -46,6 +47,14 @@ CONFIGURE_ENV+= ac_cv_prog_HAVE_DOXYGEN="false"
LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
.endif
+.if defined(WITH_ALSA)
+LIB_DEPENDS+= asound.2:${PORTSDIR}/audio/alsa-lib
+PLIST_SUB+= ALSA=""
+.else
+CONFIGURE_ARGS+=--disable-alsa
+PLIST_SUB+= ALSA="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|define USE_MLOCK|undef USE_MLOCK|' \
${WRKSRC}/configure