aboutsummaryrefslogtreecommitdiff
path: root/audio/jack/Makefile
diff options
context:
space:
mode:
authorEdward Tomasz Napierala <trasz@FreeBSD.org>2009-05-11 19:08:02 +0000
committerEdward Tomasz Napierala <trasz@FreeBSD.org>2009-05-11 19:08:02 +0000
commitb1bfc203bf4b0a76886bfbf872428d65ccc88479 (patch)
treeb4236536f989724f62ccd432d7919e51a4c734eb /audio/jack/Makefile
parent3863928550a9b8c0782cc63a973c0a18fcf4b4eb (diff)
Fix plist. The source tarball is strange - it comes with HTML documentation,
but it refuses to install it if there is no doxygen installed. If there is Doxygen installed, it regenerates the docs. While here, remove that weird DOCS handling and make it respect NOPORTDOCS. Tested by: itetcu@
Notes
Notes: svn path=/head/; revision=233718
Diffstat (limited to 'audio/jack/Makefile')
-rw-r--r--audio/jack/Makefile22
1 files changed, 3 insertions, 19 deletions
diff --git a/audio/jack/Makefile b/audio/jack/Makefile
index df591ac0dc54..10485caad276 100644
--- a/audio/jack/Makefile
+++ b/audio/jack/Makefile
@@ -7,6 +7,7 @@
PORTNAME= jackit
PORTVERSION= 0.116.2
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://jackaudio.org/downloads/
DISTNAME= jack-audio-connection-kit-${PORTVERSION}
@@ -19,8 +20,6 @@ LIB_DEPENDS= portaudio.0:${PORTSDIR}/audio/portaudio \
samplerate.1:${PORTSDIR}/audio/libsamplerate \
celt.0:${PORTSDIR}/audio/celt
-OPTIONS= DOCS "Build HTML documentation. Requires doxygen/TeX." off
-
LATEST_LINK= jack
CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}" LDFLAGS="-L${LOCALBASE}/lib" \
CPPFLAGS="-I${LOCALBASE}/include" \
@@ -36,32 +35,16 @@ MAN1= jackd.1 jackstart.1
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/bin/doxygen) && !defined(WITH_GNOKII)
-DOCS_OVERRIDE= yes
-WITH_DOCS= yes
-.endif
-
-.if defined(WITH_DOCS) || defined(PACKAGE_BUILDING)
+.if !defined(NOPORTDOCS)
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
-PLIST_SUB+= DOCS=""
.else
CONFIGURE_ENV+= ac_cv_prog_HAVE_DOXYGEN="false"
-PLIST_SUB+= DOCS="@comment "
.endif
.if exists(${LOCALBASE}/lib/libreadline.so.5)
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
.endif
-pre-everything::
-.if defined(DOCS_OVERRIDE)
- @${ECHO_MSG}
- @${ECHO_MSG} "**********************************************************"
- @${ECHO_MSG} "* Doxygen has been detected, documentation will be built *"
- @${ECHO_MSG} "**********************************************************"
- @${ECHO_MSG}
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|define USE_MLOCK|undef USE_MLOCK|' \
${WRKSRC}/configure
@@ -76,6 +59,7 @@ post-patch:
${WRKSRC}/example-clients/Makefile.in
@${REINPLACE_CMD} -e 's|md5sum|md5 -q|g' \
${WRKSRC}/jackd/Makefile.in
+ @${RM} -f ${WRKSRC}/doc/reference/html/*
post-build:
@${RM} -f ${WRKSRC}/doc/reference/html/dir__2F*