aboutsummaryrefslogtreecommitdiff
path: root/audio/jack_mixer/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2010-08-18 15:45:03 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2010-08-18 15:45:03 +0000
commit82bef7476472b7c95abf8a741aa0f27f82868470 (patch)
tree765681cca6a981a05ea952c4858944a6d6505ba9 /audio/jack_mixer/Makefile
parenta5556229b961a31f018dd63c457f04dafc894818 (diff)
downloadports-82bef7476472b7c95abf8a741aa0f27f82868470.tar.gz
ports-82bef7476472b7c95abf8a741aa0f27f82868470.zip
Notes
Diffstat (limited to 'audio/jack_mixer/Makefile')
-rw-r--r--audio/jack_mixer/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/audio/jack_mixer/Makefile b/audio/jack_mixer/Makefile
new file mode 100644
index 000000000000..8e260dfdfa5d
--- /dev/null
+++ b/audio/jack_mixer/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# New ports collection Makefile for: jack_mixer
+# Date created: 13 August 2010
+# Whom: gahr
+#
+# $FreeBSD$
+#
+
+PORTNAME= jack_mixer
+PORTVERSION= 8
+CATEGORIES= audio
+MASTER_SITES= http://download.gna.org/${PORTNAME:S/_//}/
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= A mixer for the jack audio connection kit
+
+LIB_DEPENDS= jack.0:${PORTSDIR}/audio/jack
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/fpconst.py:${PORTSDIR}/math/py-fpconst \
+ ${LOCALBASE}/include/pygtk-2.0/pygtk/pygtk.h:${PORTSDIR}/x11-toolkits/py-gtk2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= yes
+USE_GNOME= gconf2
+GCONF_SCHEMAS= jack_mixer.schemas
+INSTALLS_ICONS= yes
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>