aboutsummaryrefslogtreecommitdiff
path: root/audio/jack_mixer
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2010-08-18 15:45:03 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2010-08-18 15:45:03 +0000
commit82bef7476472b7c95abf8a741aa0f27f82868470 (patch)
tree765681cca6a981a05ea952c4858944a6d6505ba9 /audio/jack_mixer
parenta5556229b961a31f018dd63c457f04dafc894818 (diff)
downloadports-82bef7476472b7c95abf8a741aa0f27f82868470.tar.gz
ports-82bef7476472b7c95abf8a741aa0f27f82868470.zip
Notes
Diffstat (limited to 'audio/jack_mixer')
-rw-r--r--audio/jack_mixer/Makefile29
-rw-r--r--audio/jack_mixer/distinfo3
-rw-r--r--audio/jack_mixer/pkg-descr5
-rw-r--r--audio/jack_mixer/pkg-plist34
4 files changed, 71 insertions, 0 deletions
diff --git a/audio/jack_mixer/Makefile b/audio/jack_mixer/Makefile
new file mode 100644
index 000000000000..8e260dfdfa5d
--- /dev/null
+++ b/audio/jack_mixer/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# New ports collection Makefile for: jack_mixer
+# Date created: 13 August 2010
+# Whom: gahr
+#
+# $FreeBSD$
+#
+
+PORTNAME= jack_mixer
+PORTVERSION= 8
+CATEGORIES= audio
+MASTER_SITES= http://download.gna.org/${PORTNAME:S/_//}/
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= A mixer for the jack audio connection kit
+
+LIB_DEPENDS= jack.0:${PORTSDIR}/audio/jack
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/fpconst.py:${PORTSDIR}/math/py-fpconst \
+ ${LOCALBASE}/include/pygtk-2.0/pygtk/pygtk.h:${PORTSDIR}/x11-toolkits/py-gtk2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= yes
+USE_GNOME= gconf2
+GCONF_SCHEMAS= jack_mixer.schemas
+INSTALLS_ICONS= yes
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/audio/jack_mixer/distinfo b/audio/jack_mixer/distinfo
new file mode 100644
index 000000000000..44d5f2a6c2cb
--- /dev/null
+++ b/audio/jack_mixer/distinfo
@@ -0,0 +1,3 @@
+MD5 (jack_mixer-8.tar.gz) = 5c0ae2d8825f326625c3aac2de3f358d
+SHA256 (jack_mixer-8.tar.gz) = 47f451b7ca730bc81f9becf87d6d3b981c2333101f3808c8e30e809bdd1e9826
+SIZE (jack_mixer-8.tar.gz) = 380897
diff --git a/audio/jack_mixer/pkg-descr b/audio/jack_mixer/pkg-descr
new file mode 100644
index 000000000000..354a97e72546
--- /dev/null
+++ b/audio/jack_mixer/pkg-descr
@@ -0,0 +1,5 @@
+jack_mixer is a GTK+ JACK audio mixer app with a look similar
+to its hardware counterpart. It has lot of useful features,
+apart from being able to mix multiple JACK audio streams.
+
+WWW: http://home.gna.org/jackmixer/
diff --git a/audio/jack_mixer/pkg-plist b/audio/jack_mixer/pkg-plist
new file mode 100644
index 000000000000..2eebbb496a84
--- /dev/null
+++ b/audio/jack_mixer/pkg-plist
@@ -0,0 +1,34 @@
+bin/jack_mixer.py
+bin/jack_mixer
+share/icons/hicolor/16x16/apps/jack_mixer.png
+share/icons/hicolor/22x22/apps/jack_mixer.png
+share/icons/hicolor/24x24/apps/jack_mixer.png
+share/icons/hicolor/32x32/apps/jack_mixer.png
+share/icons/hicolor/48x48/apps/jack_mixer.png
+share/icons/hicolor/scalable/apps/jack_mixer.svg
+share/applications/jack_mixer.desktop
+%%DATADIR%%/abspeak.py
+%%DATADIR%%/channel.py
+%%DATADIR%%/gui.py
+%%DATADIR%%/meter.py
+%%DATADIR%%/scale.py
+%%DATADIR%%/serialization.py
+%%DATADIR%%/serialization_xml.py
+%%DATADIR%%/slider.py
+%%DATADIR%%/preferences.py
+%%PYTHON_SITELIBDIR%%/jack_mixer_c.so
+%%PYTHON_SITELIBDIR%%/jack_mixer_c.la
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/16x16
+@dirrmtry share/icons/hicolor/22x22/apps
+@dirrmtry share/icons/hicolor/22x22
+@dirrmtry share/icons/hicolor/24x24/apps
+@dirrmtry share/icons/hicolor/24x24
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/scalable/apps
+@dirrmtry share/icons/hicolor/scalable
+@dirrmtry share/applications
+@dirrm %%DATADIR%%