aboutsummaryrefslogtreecommitdiff
path: root/audio/juk/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-03-03 16:46:40 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-03-03 16:46:40 +0000
commit6fab1031e2f5b165ed723adbc9d160303d8baece (patch)
treef22835c1d378234f817e0277dfa99fd45e2a18ad /audio/juk/Makefile
parent57e369771f303b581f9b6def0d70b34510dcb6c2 (diff)
Notes
Diffstat (limited to 'audio/juk/Makefile')
-rw-r--r--audio/juk/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/audio/juk/Makefile b/audio/juk/Makefile
new file mode 100644
index 000000000000..931d006056b1
--- /dev/null
+++ b/audio/juk/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: JuK
+# Date created: Saturday 7 December 2002
+# Whom: Lauri Watts <lauri@kde.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= juk
+PORTVERSION= 1.0
+CATEGORIES= audio kde
+MASTER_SITES= http://www.slackorama.net/oss/juk/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-1
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= JuK, a music manager and jukebox for KDE
+
+LIB_DEPENDS= id3-3.8.2:${PORTSDIR}/audio/id3lib
+RUN_DEPENDS= ${LOCALBASE}/lib/kde3/kfile_mp3.so:${PORTSDIR}/multimedia/kdemultimedia3 \
+ ${LOCALBASE}/lib/kde3/kfile_ogg.so:${PORTSDIR}/multimedia/kdemultimedia3
+
+USE_KDELIBS_VER=3
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --program-transform-name=''
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+.include <bsd.port.mk>