aboutsummaryrefslogtreecommitdiff
path: root/audio/kid3-kde4
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-10-23 10:49:47 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-10-23 10:49:47 +0000
commit681d6a01b5aa1807d2fc660f465da8a4f7f65082 (patch)
tree9c8b2af2819356aa54781ce28a8b1b120b2c0433 /audio/kid3-kde4
parentfb76121bb79a1db9fee521e99fc6f19eeee6e43a (diff)
downloadports-681d6a01b5aa1807d2fc660f465da8a4f7f65082.tar.gz
ports-681d6a01b5aa1807d2fc660f465da8a4f7f65082.zip
Notes
Diffstat (limited to 'audio/kid3-kde4')
-rw-r--r--audio/kid3-kde4/Makefile1
-rw-r--r--audio/kid3-kde4/files/patch-ffmpeg211
2 files changed, 11 insertions, 1 deletions
diff --git a/audio/kid3-kde4/Makefile b/audio/kid3-kde4/Makefile
index 9dcd5a4b8e56..53e1f1d0c5a2 100644
--- a/audio/kid3-kde4/Makefile
+++ b/audio/kid3-kde4/Makefile
@@ -12,7 +12,6 @@ COMMENT= MP3/Ogg/FLAC tag editor for KDE
LICENSE= GPLv2
USE_KDE4= kdelibs kdeprefix kdehier automoc4
-NO_STAGE= yes
USE_QT4= qmake_build moc_build rcc_build uic_build
USES= cmake gettext
diff --git a/audio/kid3-kde4/files/patch-ffmpeg2 b/audio/kid3-kde4/files/patch-ffmpeg2
new file mode 100644
index 000000000000..be6b80f969b4
--- /dev/null
+++ b/audio/kid3-kde4/files/patch-ffmpeg2
@@ -0,0 +1,11 @@
+--- ./src/core/import/ffmpegfingerprintdecoder.cpp.orig 2013-03-10 08:02:19.000000000 +0000
++++ ./src/core/import/ffmpegfingerprintdecoder.cpp 2013-10-22 17:55:27.124150487 +0000
+@@ -67,7 +67,7 @@
+
+ namespace {
+
+-const int BUFFER_SIZE = AVCODEC_MAX_AUDIO_FRAME_SIZE * 2;
++const int BUFFER_SIZE = 192000 * 2;
+
+ /*
+ * The following classes are used to benefit from the C++