aboutsummaryrefslogtreecommitdiff
path: root/audio/ksmp3play/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-01-13 11:00:48 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-01-13 11:00:48 +0000
commit837ac1383f32226ac351c5a823cbfeb8c3b5db64 (patch)
tree2f8f1425836375410f2ef3e4af5d335aff2fc612 /audio/ksmp3play/Makefile
parentb163e79e9af42ee30d0b976a4a4882eb94d3054c (diff)
Notes
Diffstat (limited to 'audio/ksmp3play/Makefile')
-rw-r--r--audio/ksmp3play/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/audio/ksmp3play/Makefile b/audio/ksmp3play/Makefile
index ec3bcc04a900..dc602b910c23 100644
--- a/audio/ksmp3play/Makefile
+++ b/audio/ksmp3play/Makefile
@@ -13,24 +13,26 @@ MASTER_SITES= http://www.xanadunet.net/ksmp3play/
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
- smpeg:${PORTSDIR}/graphics/smpeg \
- gnugetopt:${PORTSDIR}/devel/libgnugetopt
+LIB_DEPENDS= smpeg.1:${PORTSDIR}/graphics/smpeg
-USE_REINPLACE= yes
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= SDL_CONFIG=${SDL_CONFIG} \
- LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+ CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+
MAN1= ksmp3play.1
post-patch:
@${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/configure
-.if !defined(NOPORTDOCS)
post-install:
+.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${CP} -R ${WRKSRC}/doc/ksmp3play* ${DOCSDIR}
+ ${TAR} -C ${WRKSRC}/doc --exclude "CVS" -cf - . | \
+ ${TAR} -C ${DOCSDIR} --unlink -xf -
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
.endif
.include <bsd.port.mk>