aboutsummaryrefslogtreecommitdiff
path: root/audio/ladspa/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-30 16:47:22 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-30 16:47:22 +0000
commit97f54f04dc434ae6665ac329cb59ea170c926986 (patch)
tree6dce9a223a89549eb0f211d00141f43c18693965 /audio/ladspa/Makefile
parentd2dda23309920854785d061730b37e458a515e4c (diff)
downloadports-97f54f04dc434ae6665ac329cb59ea170c926986.tar.gz
ports-97f54f04dc434ae6665ac329cb59ea170c926986.zip
Notes
Diffstat (limited to 'audio/ladspa/Makefile')
-rw-r--r--audio/ladspa/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/audio/ladspa/Makefile b/audio/ladspa/Makefile
new file mode 100644
index 000000000000..3e6f900a80b8
--- /dev/null
+++ b/audio/ladspa/Makefile
@@ -0,0 +1,35 @@
+# New ports collection Makefile for: ladspa
+# Date created: 11 May 2002
+# Whom: Tilman Linneweh <freebsdports@arved.de
+#
+# $FreeBSD$
+
+PORTNAME= ladspa
+PORTVERSION= 0
+CATEGORIES= audio
+MASTER_SITES= http://www.ladspa.org/download/
+DISTNAME= ladspa_sdk
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= freebsdports@arved.de
+
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+MAKEFILE= makefile
+ALL_TARGET= targets
+
+PROGRAM_FILES= analyseplugin applyplugin listplugins
+PLUGIN_FILES= amp.so delay.so filter.so noise.so sine.so
+PLUGIN_DIR= ${PREFIX}/lib/ladspa/
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/ladspa.h ${PREFIX}/include
+.for file in ${PROGRAM_FILES}
+ @${INSTALL_PROGRAM} ${WRKSRC}/../bin/${file} ${PREFIX}/bin
+.endfor
+ @${MKDIR} ${PLUGIN_DIR}
+.for file in ${PLUGIN_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/../plugins/${file} ${PLUGIN_DIR}
+.endfor
+
+.include <bsd.port.mk>