aboutsummaryrefslogtreecommitdiff
path: root/audio/ladspa
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2010-07-03 14:15:17 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2010-07-03 14:15:17 +0000
commitef07084079a0eb64ed5577e92b901836c72ddc55 (patch)
tree1f63debcfd30bf1aa7e5387251f6a114d5129176 /audio/ladspa
parent81db2a60c44b8930a7d2ee5ea53576468e836816 (diff)
downloadports-ef07084079a0eb64ed5577e92b901836c72ddc55.tar.gz
ports-ef07084079a0eb64ed5577e92b901836c72ddc55.zip
Notes
Diffstat (limited to 'audio/ladspa')
-rw-r--r--audio/ladspa/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/audio/ladspa/Makefile b/audio/ladspa/Makefile
index f5baf9596435..5ec467b61bc0 100644
--- a/audio/ladspa/Makefile
+++ b/audio/ladspa/Makefile
@@ -23,13 +23,15 @@ USE_LDCONFIG= yes
PROGRAM_FILES= analyseplugin applyplugin listplugins
PLUGIN_FILES= amp.so delay.so filter.so noise.so sine.so
PLUGIN_DIR?= ${PREFIX}/lib/ladspa/
+MAKEFILE= makefile
+ALL_TARGET= targets
+BUILD_WRKSRC= ${WRKSRC}/src
+MAKE_JOBS_SAFE= yes
post-patch:
${REINPLACE_CMD} -e 's,-ldl,,; s,-O3,${CFLAGS},; \
- s,^CC,#CC,;s,^CPP,#CPP,;s,CPP,CXX,' ${WRKSRC}/src/makefile
-
-do-build:
- cd ${WRKSRC}/src; ${SETENV} ${MAKE_ENV} ${GMAKE} -f makefile targets
+ s,^CC,#CC,;s,^CPP,#CPP,;s,CPP,CXX,; s,^CXXFLAGS.*=,CXXFLAGS+=,' \
+ ${WRKSRC}/src/makefile
do-install:
@${INSTALL_DATA} ${WRKSRC}/src/ladspa.h ${PREFIX}/include