aboutsummaryrefslogtreecommitdiff
path: root/audio/lame
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2010-06-03 08:55:01 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2010-06-03 08:55:01 +0000
commita23bcd1501bb611248b21d5853863730a3d17896 (patch)
treea25244f0fa8cd2aab763c48efcea308cd6e30cfc /audio/lame
parent4856ce32ec50144a37ce7d5515961be224c2436c (diff)
downloadports-a23bcd1501bb611248b21d5853863730a3d17896.tar.gz
ports-a23bcd1501bb611248b21d5853863730a3d17896.zip
Notes
Diffstat (limited to 'audio/lame')
-rw-r--r--audio/lame/Makefile4
-rw-r--r--audio/lame/distinfo6
-rw-r--r--audio/lame/files/patch-libmp3lame-lame.c72
3 files changed, 4 insertions, 78 deletions
diff --git a/audio/lame/Makefile b/audio/lame/Makefile
index 0259fed497d8..4d1a9c121237 100644
--- a/audio/lame/Makefile
+++ b/audio/lame/Makefile
@@ -6,12 +6,10 @@
#
PORTNAME= lame
-PORTVERSION= 3.98.2
-PORTREVISION= 2
+PORTVERSION= 3.98.4
CATEGORIES= audio
MASTER_SITES= SF \
ftp://ftp.fu-berlin.de/unix/sound/%SUBDIR%/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//:S/./-/}
MAINTAINER= netchild@FreeBSD.org
COMMENT= Fast MP3 encoder kit
diff --git a/audio/lame/distinfo b/audio/lame/distinfo
index 350088e15745..ee16e2c2cdbc 100644
--- a/audio/lame/distinfo
+++ b/audio/lame/distinfo
@@ -1,3 +1,3 @@
-MD5 (lame-398-2.tar.gz) = 719dae0ee675d0c16e0e89952930ed35
-SHA256 (lame-398-2.tar.gz) = a17a28569d8ed1e514915c1f12bdf4eedac506e5fbdf9a429ba97d5d42c9af32
-SIZE (lame-398-2.tar.gz) = 1327643
+MD5 (lame-3.98.4.tar.gz) = 8e9866ad6b570c6c95c8cba48060473f
+SHA256 (lame-3.98.4.tar.gz) = ac3144c76617223a9be4aaa3e28a66b51bcab28141050c3af04cb06836f772c8
+SIZE (lame-3.98.4.tar.gz) = 1336025
diff --git a/audio/lame/files/patch-libmp3lame-lame.c b/audio/lame/files/patch-libmp3lame-lame.c
deleted file mode 100644
index ceedbc6378c1..000000000000
--- a/audio/lame/files/patch-libmp3lame-lame.c
+++ /dev/null
@@ -1,72 +0,0 @@
---- libmp3lame/lame.c.orig 2008-08-05 19:26:02.000000000 +0200
-+++ libmp3lame/lame.c 2009-08-17 21:25:17.749630168 +0200
-@@ -1602,6 +1602,13 @@
- /* update mfbuf[] counters */
- gfc->mf_size += n_out;
- assert(gfc->mf_size <= MFSIZE);
-+
-+ /* lame_encode_flush may have set gfc->mf_sample_to_encode to 0
-+ * so we have to reinitialize it here when that happened.
-+ */
-+ if (gfc->mf_samples_to_encode < 1) {
-+ gfc->mf_samples_to_encode = ENCDELAY + POSTDELAY;
-+ }
- gfc->mf_samples_to_encode += n_out;
-
-
-@@ -1931,6 +1938,10 @@
- int frames_left;
- int samples_to_encode = gfc->mf_samples_to_encode;
-
-+ /* Was flush already called? */
-+ if (gfc->mf_samples_to_encode < 1) {
-+ return 0;
-+ }
- memset(buffer, 0, sizeof(buffer));
- mp3count = 0;
-
-@@ -1942,7 +1953,9 @@
- end_padding += pad_out_samples;
-
- frames_left = (samples_to_encode + pad_out_samples) / gfp->framesize;
-- while (frames_left > 0) {
-+
-+ /* send in a frame of 0 padding until all internal sample buffers are flushed */
-+ while (frames_left > 0 && imp3 >= 0) {
- int frame_num = gfp->frameNum;
-
- mp3buffer_size_remaining = mp3buffer_size - mp3count;
-@@ -1951,22 +1964,22 @@
- if (mp3buffer_size == 0)
- mp3buffer_size_remaining = 0;
-
-- /* send in a frame of 0 padding until all internal sample buffers
-- * are flushed
-- */
- imp3 = lame_encode_buffer(gfp, buffer[0], buffer[1], 32,
- mp3buffer, mp3buffer_size_remaining);
--
-- if (frame_num != gfp->frameNum) {
-- --frames_left;
-- }
-- if (imp3 < 0) {
-- /* some type of fatal error */
-- return imp3;
-- }
- mp3buffer += imp3;
- mp3count += imp3;
-+ frames_left -= (frame_num != gfp->frameNum) ? 1 : 0;
- }
-+ /* Set gfc->mf_samples_to_encode to 0, so we may detect
-+ * and break loops calling it more than once in a row.
-+ */
-+ gfc->mf_samples_to_encode = 0;
-+
-+ if (imp3 < 0) {
-+ /* some type of fatal error */
-+ return imp3;
-+ }
-+
- mp3buffer_size_remaining = mp3buffer_size - mp3count;
- /* if user specifed buffer size = 0, dont check size */
- if (mp3buffer_size == 0)