aboutsummaryrefslogtreecommitdiff
path: root/audio/lash
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2012-12-14 09:35:02 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2012-12-14 09:35:02 +0000
commit2f4e9534061758d531eada02f6834b9428feef03 (patch)
treefff2d518da054f68ec5e07aa814b60a7cc3fa7cf /audio/lash
parent9629a9dd1e79ff555557777d7e9c8593ec6274e8 (diff)
downloadports-2f4e9534061758d531eada02f6834b9428feef03.tar.gz
ports-2f4e9534061758d531eada02f6834b9428feef03.zip
Notes
Diffstat (limited to 'audio/lash')
-rw-r--r--audio/lash/Makefile45
-rw-r--r--audio/lash/pkg-plist4
2 files changed, 30 insertions, 19 deletions
diff --git a/audio/lash/Makefile b/audio/lash/Makefile
index e3bf2565a8fe..6a592766fd98 100644
--- a/audio/lash/Makefile
+++ b/audio/lash/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: lash
-# Date created: 2007-01-13
-# Whom: Edward Tomasz Napierala <trasz@pin.if.uz.zgora.pl>
-#
+# Created by: Edward Tomasz Napierala <trasz@pin.if.uz.zgora.pl>
# $FreeBSD$
-#
PORTNAME= lash
PORTVERSION= 0.5.4
@@ -18,37 +14,50 @@ LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
LIB_DEPENDS= jack:${PORTSDIR}/audio/jack \
- uuid:${PORTSDIR}/misc/e2fsprogs-libuuid \
- dssialsacompat:${PORTSDIR}/audio/libdssialsacompat
+ dssialsacompat:${PORTSDIR}/audio/libdssialsacompat \
+ uuid:${PORTSDIR}/misc/e2fsprogs-libuuid
-GNU_CONFIGURE= yes
+OPTIONS_DEFINE= READLINE DOCS
+OPTIONS_DEFAULT=READLINE
+READLINE_DESC= Enable readline support
+
+USE_GNOME= gnomehack gtk20 libxml2
USE_GMAKE= yes
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-alsa-midi
-USE_GNOME= gnomehack gtk20 libxml2
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include/dssi -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-PORTDOCS= *
-
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MREADLINE}
+USE_READLINE= yes
+PLIST_SUB+= READLINE=""
+.else
+CONFIGURE_ENV+= vl_cv_lib_readline=no
+PLIST_SUB+= READLINE="@comment "
+.endif
+
.if ${PORT_OPTIONS:MDOCS}
-BUILD_DEPENDS= texi2html:${PORTSDIR}/textproc/texi2html
+BUILD_DEPENDS+= texi2html:${PORTSDIR}/textproc/texi2html
+.else
+CONFIGURE_ENV+= ac_cv_prog_lash_texi2html=no
.endif
-post-extract:
- @${REINPLACE_CMD} -e 's|texi2html --number|texi2html|' \
- ${WRKSRC}/docs/Makefile.in
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/if test/s|==|=|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ '/texi2html/s|--number||' ${WRKSRC}/docs/Makefile.in
post-install:
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} \
- ${WRKSRC}/docs/lash-manual-html-one-page/lash-manual.html \
- ${DOCSDIR}
+ cd ${WRKSRC}/docs/lash-manual-html-one-page \
+ && ${INSTALL_DATA} lash-manual.html ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/audio/lash/pkg-plist b/audio/lash/pkg-plist
index 787b7e6bb27a..04f61bbf1a3f 100644
--- a/audio/lash/pkg-plist
+++ b/audio/lash/pkg-plist
@@ -1,5 +1,5 @@
bin/lashd
-bin/lash_control
+%%READLINE%%bin/lash_control
bin/lash_save_button
bin/lash_panel
include/lash-1.0/lash/lash.h
@@ -13,6 +13,7 @@ lib/liblash.so
lib/liblash.la
lib/liblash.a
libdata/pkgconfig/lash-1.0.pc
+%%PORTDOCS%%%%DOCSDIR%%/lash-manual.html
%%DATADIR%%/dtds/lash-project-1.0.dtd
%%DATADIR%%/icons/lash_16px.png
%%DATADIR%%/icons/lash_24px.png
@@ -23,5 +24,6 @@ libdata/pkgconfig/lash-1.0.pc
@dirrm %%DATADIR%%/icons
@dirrm %%DATADIR%%/dtds
@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/lash-1.0/lash
@dirrm include/lash-1.0