aboutsummaryrefslogtreecommitdiff
path: root/audio/lash
diff options
context:
space:
mode:
authorEdward Tomasz Napierala <trasz@FreeBSD.org>2008-01-02 19:35:26 +0000
committerEdward Tomasz Napierala <trasz@FreeBSD.org>2008-01-02 19:35:26 +0000
commit260ef9ac169c36beb0f59be967f8db30a8201d2a (patch)
treebb4dd54e7be433125f8b2154a2065daf603e4cd1 /audio/lash
parent279aab45487e4bb5033738afd57eb42b5d946933 (diff)
downloadports-260ef9ac169c36beb0f59be967f8db30a8201d2a.tar.gz
ports-260ef9ac169c36beb0f59be967f8db30a8201d2a.zip
Notes
Diffstat (limited to 'audio/lash')
-rw-r--r--audio/lash/Makefile1
-rw-r--r--audio/lash/files/patch-lashd-conn_mgr.c15
2 files changed, 16 insertions, 0 deletions
diff --git a/audio/lash/Makefile b/audio/lash/Makefile
index 81ddca210479..3891f6e1e339 100644
--- a/audio/lash/Makefile
+++ b/audio/lash/Makefile
@@ -7,6 +7,7 @@
PORTNAME= lash
PORTVERSION= 0.5.4
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://download.savannah.gnu.org/releases/lash/
diff --git a/audio/lash/files/patch-lashd-conn_mgr.c b/audio/lash/files/patch-lashd-conn_mgr.c
new file mode 100644
index 000000000000..38042102d93e
--- /dev/null
+++ b/audio/lash/files/patch-lashd-conn_mgr.c
@@ -0,0 +1,15 @@
+--- lashd/conn_mgr.c.orig 2008-01-02 20:26:00.000000000 +0100
++++ lashd/conn_mgr.c 2008-01-02 20:27:11.000000000 +0100
+@@ -759,7 +759,11 @@
+
+ fprintf(stderr, "%s: error calling select(): %s\n", __FUNCTION__,
+ strerror(errno));
+- return NULL;
++
++ if (errno == EBADF)
++ continue;
++ else
++ return NULL;
+ }
+
+ if (conn_mgr->quit)