aboutsummaryrefslogtreecommitdiff
path: root/audio/last.fm/Makefile
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2007-02-06 14:20:53 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2007-02-06 14:20:53 +0000
commitafd1f07ae9c930e4dbc68bfba98acef698c93980 (patch)
tree34cf9c6b1f62269b5396a1b5c69a78534b2f4d85 /audio/last.fm/Makefile
parenta1d4c2a66408f663231bb8bc89052e5fe1e88324 (diff)
downloadports-afd1f07ae9c930e4dbc68bfba98acef698c93980.tar.gz
ports-afd1f07ae9c930e4dbc68bfba98acef698c93980.zip
Notes
Diffstat (limited to 'audio/last.fm/Makefile')
-rw-r--r--audio/last.fm/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/audio/last.fm/Makefile b/audio/last.fm/Makefile
new file mode 100644
index 000000000000..ab354e8d9f7c
--- /dev/null
+++ b/audio/last.fm/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: last.fm
+# Date created: February 5th, 2007
+# Whom: Michael Nottebrock <lofi@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= last.fm
+PORTVERSION= 1.1.3
+CATEGORIES= audio net
+MASTER_SITES= http://static.last.fm/client/Linux/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.src
+
+MAINTAINER= lofi@FreeBSD.org
+COMMENT= Official last.fm radio player
+
+PKGINSTALL= ${WRKDIR}/pkg-install
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+SUB_FILES= pkg-install pkg-deinstall
+USE_BZIP2= yes
+USE_QT_VER= 4
+QT_COMPONENTS= gui imageformats moc network uic xml
+HAS_CONFIGURE= yes
+
+CONFIGURE_ENV+= X11BASE=${X11BASE}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+post-build:
+ ${REINPLACE_CMD} -e 's|`dirname $$0`|${DATADIR}|g' \
+ ${WRKSRC}/bin/last.fm
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/last.fm ${PREFIX}/bin/last.fm
+ ${MKDIR} ${PREFIX}/share/services
+ ${INSTALL_DATA} ${FILESDIR}/lastfm.protocol ${PREFIX}/share/services
+ ${MKDIR} ${DATADIR}
+ ${CP} -Rp ${WRKSRC}/bin/* ${DATADIR}/
+
+post-install:
+.if !defined(PACKAGE_BUILDING)
+ @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+.endif
+
+.include <bsd.port.mk>